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Preface

This users guide provides documentation and examples on how to use the OpenModelica system, both for
the Modelica beginners and advanced users.
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Chapter 1

Introduction

The OpenM odelica system described in this document has both short-term and long-term goals:

The short-term goal is to develop an efficient interactive computational environment for the Modelica
language, as well as arather complete implementation of the language. It turns out that with support of
appropriate tools and libraries, Modelica is very well suited as a computational language for
development and execution of both low level and high level numerical algorithms, e.g. for control
system design, solving nonlinear equation systems, or to develop optimization agorithms that are
applied to complex applications.

The longer-term goal is to have a complete reference implementation of the Modelica language,
including smulation of equation based models and additional facilities in the programming
environment, as well as convenient facilities for research and experimentation in language design or
other research activities. However, our goal is not to reach the level of performance and quality
provided by current commercial Modelica environments that can handle large models requiring
advanced analysis and optimization by the Modelica compiler.

The long-term research related goals and issues of the OpenModelica open source implementation of a
Modelica environment include but are not limited to the following:

Development of a complete formal specification of Modelica, including both static and dynamic
semantics. Such a specification can be used to assist current and future Modelica implementers by
providing a semantic reference, as akind of reference implementation.

Language design, e.g. to further extend the scope of the language, e.g. for use in diagnosis, structural
analysis, system identification, etc., as well as modeling problems that require extensions such as partial
differential equations, enlarged scope for discrete modeling and simulation, etc.

Language design to improve abstract properties such as expressiveness, orthogonality, declarativity,
reuse, configurability, architectural properties, etc.

Improved implementation techniques, e.g. to enhance the performance of compiled Modelica code by
generating code for parallel hardware.

Improved debugging support for equation based languages such as Modelica, to make them even easier
to use.

Easy-to-use specialized high-level (graphical) user interfaces for certain application domains.
Visualization and animation techniques for interpretation and presentation of results.
Application usage and model library development by researchers in various application areas.

The OpenModelica environment provides a test bench for language design ideas that, if successful, can be
submitted to the Modelica Association for consideration regarding possible inclusion in the official Modelica
standard.
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The current version of the OpenModelica environment allows most of the expression, agorithm, and
function parts of Modelicato be executed interactively, as well as equation models and Modelica functions to
be compiled into efficient C code. The generated C code is combined with a library of utility functions, a run-
time library, and a numerical DAE solver. An external function library interfacing a LAPACK subset and other
basic algorithmsis under devel opment.

1.1  System Overview

The OpenModelica environment consists of severa interconnected subsystems, as depicted in Figure 1-1
below.

MDT Eclipse Plugin Graphical Model
Editor/Browser \ Editor/Browser
Interactive I
Emacs «— | session handler Textual
Editor/Browser T Model Editor
OMNotebook / \
DrModelica Execution | Modelica
Model Editor Compiler
Modelica
Debugger

Figure 1-1. The architecture of the OpenM odelica environment. Arrows denote data and control flow. The
interactive session handler receives commands and shows results from evaluating commands and expressions that
are translated and executed. Severa subsystems provide different forms of browsing and textual editing of
Modelica code. The debugger currently provides debugging of an extended al gorithmic subset of Modelica. The
graphical model editor is not really part of OpenModelica but integrated into the system and available from
MathCore without cost for academic usage.

The following subsystems are currently integrated in the OpenM odelica environment:

e An interactive session handler, that parses and interprets commands and Moddica expressions for
evaluation, simulation, plotting, etc. The session handler aso contains simple history facilities, and
completion of file names and certain identifiersin commands.

e A Modelica compiler subsystem, trandlating Modelica to C code, with a symbol table containing
definitions of classes, functions, and variables. Such definitions can be predefined, user-defined, or
obtained from libraries. The compiler also includes a Modelica interpreter for interactive usage and
constant expression evaluation. The subsystem also includes facilities for building simulation
executables linked with selected numerical ODE or DAE solvers.

e An execution and run-time module. This module currently executes compiled binary code from
trandated expressions and functions, as well as smulation code from eguation based models, linked
with numerical solvers. In the near future event handling facilities will be included for the discrete and
hybrid parts of the Modelica language.
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e Emacs textual model editor/browser. In principle any text editor could be used. We have so far
primarily employed Gnu Emacs, which has the advantage of being programmable for future extensions.
A Gnu Emacs mode for Modelica has previoudy been developed. The Emacs mode hides Modelica
graphical annotations during editing, which otherwise clutters the code and makes it hard to read. A
speedbar browser menu alows to browse a Modelica file hierarchy, and among the class and type
definitions in thosefiles.

e Eclipse plugin editor/browser. The Eclipse plugin caled MDT (Modelica Development Tooling)
provides file and class hierarchy browsing and text editing capabilities, rather analogous to previously
described Emacs editor/browser. Some syntax highlighting facilities are also included. The Eclipse
framework has the advantage of making it easier to add future extensions such as refactoring and cross
referencing support.

e OMNotebook DrModelica model editor. This subsystem provides a lightweight notebook editor,
compared to the more advanced Mathematica notebooks available in MathModelica. This basic
functionality still allows essentialy the whole DrModelica tutorial to be handled. Hierarchical text
documents with chapters and sections can be represented and edited, including basic formatting. Cells
can contain ordinary text or Modelica models and expressions, which can be evaluated and simulated.
However, no mathematical typesetting or graphic plotting facilities are yet available in the cells of this
notebook editor.

e Graphical model editor/browser. This is a graphical connection editor, for component based model
design by connecting instances of Modelica classes, and browsing Modelica model libraries for reading
and picking component models. The graphical model editor is not really part of OpenModelica but
integrated into the system and provided by MathCore without cost for academic usage. The graphical
model editor aso includes a textual editor for editing model class definitions, and a window for
interactive Modelica command eval uation.

e Modelica debugger. The current implementation of debugger provides debugging for an extended
algorithmic subset of Modelica, excluding equation-based models and some other features, but
including some meta-programming and model transformation extensions to Modelica. This is
conventional full-feature debugger, using Emacs for displaying the source code during stepping, setting
breakpoints, etc. Various back-trace and inspection commands are available. The debugger also
includes a data-view browser for browsing hierarchical data such as tree- or list structures in extended
Modelica

1.1.1 Implementation Status

In the current OpenModelica implementation version 1.3.2 (April 2006), not al subsystems are yet integrated
as well asis indicated in Figure 1-1. Currently there are two versions of the Modelica compiler, one which
supports most of standard Modelica including simulation, and is connected to the interactive session handler,
the notebook editor, and the graphic model editor, and another meta-programming Modelica compiler version
(called MetaModelica compiler) which is integrated with the debugger, Eclipse, and Emacs, supports meta-
programming Modelica extensions, but does not alow eguation-based modeling and simulation. Those two
versions are currently being merged into a single Modelica compiler version.



14

1.2 Interactive Session with Examples

The following is an interactive session using the interactive session handler in the OpenModelica environment,
called OMShell — the OpenModelica Shell). Most of these examples are also available in the OpenModelica
notebook UsersGuideExamples.onb inthe testmodels directory, see aso Chapter 3.

1.2.1 Starting the Interactive Session

The Windows version which at instalation is made available in the start menu as openModelica-
>OpenModelica Shell which responds with an interaction window:

penss P

We enter an assignment of a vector expression, created by the range construction expression 1: 12, to be stored
in the variable x. The value of the expression is returned.

>> X := 1:12
{1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12}

1.2.2  Trying the Bubblesort Function

Load the function bubblesort, either by using the pull-down menu File->Load Model, or by explicitly
giving the command:

>> loadFile ("C:/OpenModelical.4.2/testmodels/bubblesort.mo")

true
The function bubblesort is called below to sort the vector x in descending order. The sorted result is returned
together with its type. Note that the result vector is of type Real [:], instantiated as Real [12], since thisis
the declared type of the function result. The input Integer vector was automatically converted to a Real

vector according to the Modelica type coercion rules. The function is automatically compiled when called if
this has not been done before.

>> bubblesort (x)
{12.0,11.0,l0.0,9.0,8.0,7.0,6.0,5.0,4.0,3.0,2.0,1.0}

Another call:
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>> bubblesort ({4,6,2,5,8})
{8.0,6.0,5.0,4.0,2.0}

It is also possible to give operating system commands via the system utility function. A command is provided
as a string argument. The example below shows the system utility applied to the UNIX command cat, which
here outputs the contents of the file bubblesort . mo to the output stream. However, the cat command does not
boldface Modelica keywords — this improvement has been done by hand for readability.

>> cd("C:/OpenModelical.4.2/testmodels™")
>> gystem("cat bubblesort.mo")

function bubblesort
input Reall[:] x;
output Real[size(x,1)] v;
protected
Real t;
algorithm
Yy = Xj;
for i in 1l:size(x,1) loop
for j in 1l:size(x,1) loop
if y[i] > yI[j] then
t = ylil;
y[il] yI[3l;
y 3l t;
end if;
end for;
end for;
end bubblesort;

1.2.3  Trying the system and cd Commands

Note: Under Windows the output emitted into stdout by system commands is put into the winmosh console
windows, not into the winmosh interaction windows. Thus the text emitted by the above cat command would
not be returned. Only a success code (0 = success, 1 = failure) is returned to the winmosh window. For
example:

>> gystem("dir")
0

>> gystem("Non-existing command")
1

Another built-in command is cd, the change current directory command. The resulting current directory is
returned as a string.

>> cd()
"C:\OpenModelical.4.2\testmodels"

>> cd("..")
"C:\OpenModelical.4.2"

>> cd("C:\\OpenModelical.4.2\\testmodels™")
"C:\OpenModelical.4.2\testmodels"
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1.2.4 Modelica Library and DCMotor Model
We load a model, here the whole Modelica standard library, which aso can be done through the File->Load
Modelica Library menuitem:

>> loadModel (Modelica)
true

We aso load afile containing the dcmotor model:

>> loadFile ("C:/OpenModelical.4.2/testmodels/dcmotor.mo")

true
It issimulated:
>> gimulate (dcmotor, startTime=0.0,stopTime=10.0)
record
resultFile = "dcmotor res.plt™"

end record

We list the source code of the model:
>> list (dcmotor)

"model dcmotor
Modelica.Electrical.Analog.Basic.Resistor rl(R=10) ;
Modelica.Electrical.Analog.Basic.Inductor il;
Modelica.Electrical.Analog.Basic.EMF emfl;
Modelica.Mechanics.Rotational.Inertia load;
Modelica.Electrical.Analog.Basic.Ground g;
Modelica.Electrical.Analog.Sources.ConstantVoltage v;

equation
connect (v.p,rl.p);
connect (v.n,g.p) ;
connect (rl.n,il.p);
connect (il.n,emfl.p) ;
connect (emfl.n,g.p) ;
connect (emfl.flange b,load.flange a);

end dcmotor;
n

We test code instantiation of the model to flat code:
>> instantiateModel (dcmotor)

"fclass dcmotor

Real rl.v "Voltage drop between the two pins (= p.v - n.v)";
Real rl.i "Current flowing from pin p to pin n";

Real rl.p.v "Potential at the pin";

Real rl.p.i "Current flowing into the pin";

Real rl.n.v "Potential at the pin";

Real rl.n.i "Current flowing into the pin";

parameter Real rl.R = 10 "Resistance";

Real il.v "Voltage drop between the two pins (= p.v - n.v)";
Real il.i "Current flowing from pin p to pin n";

Real il.p.v "Potential at the pin";

Real il.p.i "Current flowing into the pin";

Real il.n.v "Potential at the pin";

Real il.n.i "Current flowing into the pin";

parameter Real il.L = 1 "Inductance";
parameter Real emfl.k = 1 "Transformation coefficient";
Real emfl.v "Voltage drop between the two pins";
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Real
Real
Real
Real
Real
Real
Real
Real
Real
Real
Real
Real
Real

Real
Real
Real
Real
Real
Real
Real
Real
Real
Real

emfl.
emfl.

emfl

emfl.
emfl.

emfl

emfl.
emfl.

load

< 4 d < <0

p
v
i
.p-
b
n

v.n.

i
.V
i

"Current flowing from positive to
"Angular velocity of flange b";

i "Current flowing into the pin";
v "Potential at the pin";
.n.1 "Current flowing into the pin";
angle of flange";

flange b.phi
flange b.tau

.phi "Absolute
load.
load.
load.
load.
parameter
load.
load.

flange a.phi
flange_a.tau
flange b.phi
flange b.tau
Real load.J =

i
w
.p.v "Potential at the pin";
o
n.

"Absolute rotation
"Cut torque in the
rotation angle of
"Absolute rotation
"Cut torque in the
"Absolute rotation
"Cut torque in the

flange";
component

negative pin";

(= flange a.phi

angle of flange";

flange";

angle of flange";

flange";
1 "Moment of inertia";

w "Absolute angular velocity of component";
a "Absolute angular acceleration of component";

.p.v "Potential at the pin";
.1 "Current flowing into the pin";

"Voltage drop between the two pins (= p.v - n.v)";

"Current flowing from pin p to pin n";

v

"Potential at the pin";

"Current flowing into the pin";

"Potential at the pin";

"Current flowing into the pin";

parameter Real v.V = 1
equation
rl1.R * rl.i = rl.v;

"Value of constant voltage";

rl.v = rl.p.v - rl.n.v;

0.0 = rl.p.i + rl.n.i;

rl.i = rl.p.1i;

il.L * der(il.i) = il.v;

il.v = il.p.v - il.n.v;

0.0 = il.p.1i + il.n.i;

il.i = il.p.1i;

emfl.v = emfl.p.v - emfl.n.v;
0.0 = emfl.p.i + emfl.n.i;
emfl.i = emfl.p.1i;

emfl.w = der(emfl.flange b.phi);
emfl.k * emfl.w = emfl.v;
emfl.flange b.tau = -(emfl.k * emfl.i);
load.w = der(load.phi) ;

load.a = der(load.w) ;

load.J *

4 od <@

.p.
.V
.V
.0

i

<
1}

It
< <<

= Vv

load.a = load.flange a.tau + load.flange b.tau;
load.flange a.phi = load.phi;
load.flange b.phi = load.phi;

0.0;

.V;

.p.V - v.n.v;
.p.i + v.n.i;
.p.i;

emfl.flange b.tau + load.flange_a.tau =
emfl.flange b.phi = load.flange a.phi;
emfl.n.i + v.n.i + g.p.i = 0.0;
emfl.n.v
v.n.v =
il.n.i
il.n.v
rl.n.i
rl.n.v ;
v.p.1 + rl.p.i = 0.0;

= Vv.n.v;
g.p.v;

emfl.p.i = 0.

emfl.p.v;

il.p.i = 0.0;

il.p.v;

0;

7

0.

0;

flange b.phi)";
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v.p.v = rl.p.v;
load.flange b.tau = 0.0;
end dcmotor;

We plot part of the simulated result:

>> plot ({load.w, load.phi})
true

E tmpPlot.plt
File Edit Special

Plot by OpenModelica
I ' ' I ' |oad.yw =

load.phi ®
3o0r ]

2ar ]
201 ]
181 ]
107 ]
nar ]

1.25 The val() function

The val(variableName,time) scription function can be used to retrieve the interpolated value of a ssimulation
result variable at a certain point in the simulation time, see usage in the BouncingBall simulation below.

1.2.6 BouncingBall and Switch Models

We load and simulate the BouncingBall example containing when-equations and if-expressions (the Modelica
key-words have been bold-faced by hand for better readability):

>> loadFile ("C:/OpenModelical.4.2/testmodels/BouncingBall.mo")
true

>> list (BouncingBall)
"model BouncingBall
parameter Real e=0.7 "coefficient of restitution";
parameter Real g=9.81 '"gravity acceleration";
Real h(start=1) "height of ball";
Real v "velocity of ball";
Boolean flying(start=true) "true, if ball is flying";
Boolean impact;
Real v_new;
equation
impact=h <= 0.0;
der (v)=if flying then -g else O0;
der (h) =v;
when {h <= 0.0 and v <= 0.0,impact} then
v_new=if edge (impact) then -e*pre(v) else 0;
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flying=v new > 0;
reinit (v, v_new);
end when;

end BouncingBall;
n

Instead of just giving a simulate and plot command, we perform a runScript command on a .mos

(Modelicascript) file sim_BouncingBall.mos that contains these commands:

loadFile ("BouncingBall.mo") ;
simulate (BouncingBall, stopTime=3.0) ;
plot ({h, flying}) ;

The runScript command:

>> runScript ("sim BouncingBall.mos")
"true
record

resultFile = "BouncingBall res.plt"
end record
true
true"

File Edit Special

1.0r1

nar

0.0

0.0 0.4 1.0 1.4 2.0
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3.0

=10l ]

hl
flying ®

We enter aswitch model, to test if-equations (e.g. copy and paste from another file and push enter):

>> model Switch
Real v;
Real i;
Real i1l;
Real itot;
Boolean open;
equation
itot = i + 11;

if open then

v = 0;
else

i = 0;
end if;

1 - i1 = 0;

1 -v-1=0;

open = time >= 0.5;
end Switch;
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ok
>> gimulate (Switch, startTime=0, stopTime=1);
Retrieve the value of itot at time=0 using the va1(variableName,time) function:

>> val(itot, 0)
1

Plot itot and open:

>> plot ({itot,open})
true

g tmpPlot. plt
File Edit Special

Plot by OpenModelica

201 71 open ®
itot =

0ar | | | | 1

0.0

oo 01 02 03 04 05 06 0OF 08 08 1.0

We note that the variable open switches from false (0) to true (1), causing itot to increase from 1.0 to 2.0.

1.2.7 Clear All Models

Now, first clear al loaded libraries and models:

>> clear ()
true

List the loaded models — nothing | eft:

>> list ()

nn

1.2.8 VanDerPol Model and Parametric Plot

We load another model, the vanberpPol model (or viathe menu File->Load Model):

>> loadFile ("C:/OpenModelical.4.2/testmodels/VanDerPol.mo"))
true

It issimulated:

>> simulate (VanDerPol)
record
resultFile = "VanDerPol res.plt"
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end record

It is plotted:

plotParametric (x,Vy) ;

4. tmpPlot.plt - | I:Ilﬂ

File Edit Special

Plot by OpenModelica

-2.0 -1.5 -1.0 -0.5 0.0 0.5 1.0 1.5 2.0

Perform code instantiation to flat forrm of the vanDerpPol model:
>> instantiateModel (VanDerPol)

"fclass VanDerPol
Real x(start=1.0);
Real y(start=1.0);
parameter Real lambda = 0.3;
equation
der (x) Vi
der(y) = -x + lambda * (1.0 - x * x) * y;

end VanDerPol;
n

1.2.9 Scripting with For-Loops, While-Loops, and If-Statements

A simple summing integer loop (using multi-line input without evaluation at each line into OM Shell requires
copy-paste as one operation from another document):
>> k := 0;
for i in 1:1000 loop
k := k + 1i;
end for;

>> k
500500

A nested loop summing reals and integers::

>> g := 0.0;
h : 5;
for i in {23.0,77.12,88.23} loop
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for j in i:0.5:(i+1) loop
g =g+ J;
g :=g+h/ 2;
end for;
h :=h + g;
end for;

By putting two (or more) variables or assignment statements separated by semicolon(s), ending with a variable,
one can observe more than one variable value;

>> h;g
1997.45
1479.09

A for-loop with vector traversal and concatenation of string elements:

>> i:="";
lst := {"Here ", "are ","some ", "strings."};
g = "n;
for i in 1lst loop
s := 8 + 1i;
end for;

>> S
"Here are some strings."

Normal while-loop with concatenation of 10 "abc " strings:

>> g:="";
i:=1;
while i<=10 loop
s:="abc "+s;
i1:=1+1;
end while;

>> S
"abc abc abc abc abc abc abc abc abc abc "

A simpleif-statement. By putting the variable last, after the semicolon, its value is returned after eval uation:

>> if 5>2 then a := 77; end if; a
77

An if-then-else statement with elseif:

>> if false then

a :=5;
elseif a > 50 then
b:= "test"; a:= 100;
else
a:=34;
end if;

Take alook at the variables a and b:

>> a;b

100
"tegst"

1.2.10 Variables, Functions, and Types of Variables

Assign avector to avariable:
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>> a:=1:5
{1,2,3,4,5}

Typein afunction:

>> function MySqgr input Real x; output Real y; algorithm y:=x*x; end MySqr;
Ok

Call the function:

>> b:=MySqr(2)
4.0

Look at the value of variable a:

>> a
{1,2,3,4,5}

Look at thetype of a:

>> typeOf (a)
"Integer[]"

Retrieve the type of b:

>> typeOf (b)
n Real n

What is the type of Mysqr? Cannot currently be handled.

>> typeOf (MySqr)
Error evaluating expr.

List the available variables:

>> listVariables ()
{currentSimulationResult, a, b}

Clear again:

>> clear ()
true

1.2.11 Using External Functions

Thefollowing isasmall example (ExternallLibraries.mo) to show the use of external functions:

model ExternalLibraries

Real x(start=1.0),y(start=2.0);
equation

der (x) =-ExternalFuncl (x) ;

der (y) =-ExternalFunc2 (y) ;
end Externallibraries;

function ExternalFuncl
input Real x;
output Real vy;
external
y=ExternalFuncl ext (x) annotation(Library="libExternalFuncl ext.o",

Include="#include \"ExternalFuncl ext.h\"");

end ExternalFuncl;

function ExternalFunc2
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input Real x;
output Real y;
external "C" annotation(Library="libExternalFunc2.a",
Include="#include \"ExternalFunc2.h\"");
end ExternalFunc2;

These C (.c) files and header files (.h) are needed:

/* file: ExternalFuncl.c */
double ExternalFuncl ext (double x)

{

double res;
res = X+2.0*x*x;
return res;

}

/* Header file ExternalFuncl ext.h for ExternalFuncl function */
double ExternalFuncl ext (double) ;

/* file: ExternalFunc2.c */
double ExternalFunc?2 (double x)

double res;
res = (x-1.0)*(x+2.0);
return res;

}

/* Header file ExternalFunc2.h for ExternalFunc2 */
double ExternalFunc?2 (double) ;

The following script file ExternalLibraries.mos will perform everything that is needed, provided you
have gcc installed in your path:

loadFile ("ExternalLibraries.mo") ;

system("gcc -c -o libExternalFuncl ext.o ExternalFuncl.c");
system("gcc -c¢ -o libExternalFunc2.a ExternalFunc2.c");
simulate (ExternalLibraries) ;

We run the script:
>> runScript ("ExternalLibraries.mos") ;

and plot the results:
>> plot ( {x,y}) ;
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e tmpPlot. plt
File Edit Special

Plot by OpenModelica
20 [ T T T T T ] }( -

1.2.12 Calling the Model Query and Manipulation API

In the OpenModelica System Documentation, an external API (application programming interface) is described
which returns information about models and/or allows manipulation of models. Calls to these functions can be
done interactively as below, but more typically by program clients to the OpenModelica Compiler (OMC)
server. Current examples or such clients are the OpenModelica MDT Eclipse plugin, OMNotebook, the
MathModelica Lite graphic model editor, etc. This APl is untyped for performance reasons, i.e.,, ho type
checking and minimal error checking is done on the calls. The results of a call is returned as a text string in
Modelica syntax form, which the client has to parse. An example parser in C++ is available in the
OMNotebook source code, whereas another example parser in Javais availablein the MDT Eclipse plugin.
Below we show a few calls on the previously simulated BouncingBall model. The full documentation on
this APl is available in the system documentation. First we load and list the model again to show its structure:

>>loadFile ("C:/OpenModelical.4.2/testmodels/BouncingBall.mo")
true

>>1ist (BouncingBall)

"model BouncingBall
parameter Real e=0.7 "coefficient of restitution";
parameter Real g=9.81 '"gravity acceleration";
Real h(start=1) "height of ball";
Real v "velocity of ball";
Boolean flying(start=true) "true, if ball is flying";
Boolean impact;
Real v_new;
equation
impact=h <= 0.0;
der(v)=if flying then -g else 0;
der (h) =v;
when (h <= 0.0 and v <= 0.0, impact} then
v_new=if edge (impact) then -e*pre(v) else 0;
flying=v new > 0;
reinit (v, v_new);
end when;

end BouncingBall;
n
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Different kinds of calls with returned results:

>>getClassRestriction (BouncingBall)
"model"

>>getClassInformation (BouncingBall)
{"model","n, ", {false,false, false}, {"writable",1,1,18,17}}

>>1sFunction (BouncingBall)
false

>>existClass (BouncingBall)
true

>>getComponents (BouncingBall)

{{Real,e,"coefficient of restitution", "public", false, false, false,
"parameter", "none", "unspecified"},

{Real, g, "gravity acceleration",

"public", false, false, false, "parameter", "none", "unspecified"},
{Real,h, "height of ball", "public", false, false, false,
"unspecified", "none", "unspecified"},

{Real,v,"velocity of ball",

"public", false, false, false, "unspecified", "none", "unspecified"},
{Boolean, flying, "true, if ball is flying", "public", false, false,
false, "unspecified", "none", "unspecified"},

{Boolean, impact,"",

"public", false, false, false, "unspecified", "none", "unspecified"},
{Real,v_new,"", "public", false, false, false, "unspecified", "none",

"unspecified"}}

>>getConnectionCount (BouncingBall)
0

>>getInheritanceCount (BouncingBall)
0

>>getComponentModifierValue (BouncingBall,e)
0.7

>>getComponentModifierNames (BouncingBall,e)

{}

>>getClassRestriction (BouncingBall)
"model"

>>getVersion() // Version of the currently running OMC
"1.4.2"

1.2.13 Quit OpenModelica

Leave and quit OpenModelica:

>> quit ()

1.3 Commands for the Interactive Session Handler

The following is the complete list of commands currently available in the interactive session hander.
simulate (modelname) Translate amodel named modelname and simulate it.
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simulate (Modenamel, startTime=<Real>] [, stopTime=<Real>] [, numberOfIntervals

plot (vars)

plotParametric (varl, var2)

cd()
cd (dir)
clear ()

clearVariables ()

=<Integer>]) Trandate and simulate a model, with optiona start time, stop
time, and optiona number of simulation intervals or steps for which the
simulation results will be computed. Many steps will give higher time
resolution, but occupy more space and take longer to compute. The default
number of intervalsis 500.

Plot the variables given as a vector or a scalar, eg. plot ({x1,x2}) or
plot (x1).

Plot var2 relative to varl from the most recently simulated model, e.g.
plotParametric(x,y).

Return the current directory.

Change directory to the directory given as string.
Clear dl loaded definitions.

Clear all defined variables.

instantiateModel (modename) Performs code instantiation of a model/class and return a string containing

list ()

list (modelname)
listVariables ()
loadModel (classname)

loadFile (Str)
readFile (Str)
runScript (Str)
system (Str)

timing (€XPr)

typeOf (variable)
saveModel (str, modelname)

help ()
quit ()

the flat class definition.

Return a string containing all loaded class definitions.

Return a string containing the class definition of the named class.
Return a vector of the names of the currently defined variables.

Load model or package of name classname from the path indicated by the
environment variable OPENMODELICALIBRARY.

Load Modelicafile (. mo) with name given as string argument str.
Load file given as string str and return a string containing the file content.
Execute script file with file name given as string argument str.

Execute str as a system(shell) command in the operating system; return
integer success value. Output into stdout from a shell command is put into
the console window.

Evaluate expression expr and return the number of seconds (elapsed time)
the evaluation took.

Return the type of the variable as a string.

Save the model/class with name modelname in the file given by the string
argument str.

Print this helptext (returned as a string).
Leave and quit the OpenModelica environment
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Chapter 2

Using the Graphical Model Editor

This chapter just presents a very simple example of using graphical modeling of Modelica models. A model is
built using the graphical model editor by using drag-and-drop of aready developed and freely available model

components from the Modelica Standard Library.

NOTE: This chapter is just a short sample of using the graphical model editor. See www.mathcore.com
for the current manual and the complete MathModelica System Designer Graphic Model Editor Users Guide.
As mentioned previously, the graphic editor is not part of OpenModelica, but a MathModelica Lite Edition of
the GraphicEditor that works together with OpenModelica can be downloaded from the OpenModelica web
site. (The MathModelica Lite edition of the editor is free for non-commercial usage and commercial

evaluation).

The Modelica Standard Library can be loaded into the OpenM odelica environment when the model editor is

started and can be browsed using the class browser visible at the | eft of Figure 2-1 below.

@ MathModelica System Designer - [GettingStarted.Hierarchical. TankSystem®* : Diagram View - GettingStarted.mo]
BB File Edit ¥ew Insert Tool Shape MWindow Help

FNOoGC AR vicBBE #:iasS4 BR 7

= I oo
Libia e x

Browse Libraries... - =%  Mame

Top Level View

liquidSource liquidSourcel

GeltingStarted PleontinuousContraller!
GettingStarted. ComponentB ased FleontinuousController2

5 5 FleontinuousController3
GettingStarted. Hierarchical tank

tark2
Componen Functions  Interfaces

a1 tank3

ts
Pleontinuous Cortrollert
m B
Ploortinuous Cortroller2
FlatTank  TankPl  TankPID
Pl

TankSyste

m

bl Parameters | Warisbles

Mame  Value Diescription
area 0.5/m2

flowlain 0.05|m2/s

mirty 1}

max 1o

T
bl
o
o

% -102.05  ¥:82.78

Figure 2-1. The Graphical Model Editor with the class browser to the left, the graphic editing areain the middle

and the instance component browser to the right.
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To open the library, click on the Browse libraries button in the class browser to the left. As shown by
Figure 2-2, the Modelica Standard Library is hierarchically structured into sublibraries.

Library Browser

Browse Libraries... -

Libraties |

ol o, [
| - [ constants
Maodell [ Electrical  »

[ 1cons »
3 math 4
] mecharics »
L3

[ stunits

] userscuide

Cpen Al

Figure 2-2. The Graphical Model Editor with the class browser showing the Modelica Standard library opened
up into sublibraries.

The following list briefly mentions some of the most important sublibraries in the Modelica standard library, as
well asthe Users Guide:

Blocks Continuous and discrete input/output blocks for use in block diagrams.

Constants Common constants from mathematics, physics, etc.

Electrical Common electrical components, such asresistors and transistors.

Icons Graphical layout for many component icons

Math Definitions of common mathematical functions, such as sin, cos, and log.
Mechanics Mechanical rotational and translational components.

STunits Type definitions with SI standard names and units.

UsersGuide Browsethe Users Guide.

2.1 Building a Simple DCMotor Model
We will introduce the model editor by showing how to build a model of a simple DC motor. Since the DC

motor includes both electrical and rotational mechanical components the example also illustrates multi-domain
modeling.

2.1.1 Creating a New Model

To create a new model, select New Model inthe File menu. A dialog box will appear, in which you will be
able to specify a name of the new model. Enter Mot or aSModel name.
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@ New Model 7
Model name:
|Motor| |
Description:
| |
Extends:
| |
Ingert into:
| |
Froperties
] partial [ encapsulated

Figure 2-3. Dialog box for creating a new model.

When clicking on the ok button of the dialog box a new window will appear. This window presents different
views of the model. A model has two graphical views (Icon and Diagram), and one text view (ModelicaText).
Y our new Motor model will also appear at the top package level in the class browser.

(o i ystem D Wiotor : Dia

BB File Edit View Tools Shape Window Help [2)(E (%]

FH i o (S NOCCAR QA5 vEo(@B [#ia S W 7

Li X

~ e

o | Name

Top Lewvel View

][]

Model Mator

|
[

Mo parameters found.

Madelica Text View {Ctri-3) ® 62,91 ‘i 159,34

Figure 2-4. The Graphical Model Editor with the new Mot or model appearing as a question mark icon in the
class browser window to the left.

Now you can assemble the DC motor by drag-and-drop of components from the class browser to the diagram
view window to the right. The constant voltage source component can be found in the
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Modelica.Electrical.BAnalog.Sources package whereas the rotational mass representing the motor
shaft islocated in the Modelica.Mechanics.Rotational package. The other electrical components needed
arelocated intheModelica.Electrical.Analog.Basic package.

Components placed in the diagram layer window can be graphically transformed using the mouse and
keyboard. To move a component, select it and hold down the left mouse button while moving the mouse. The
component will follow the mouse cursor. Release the mouse button when the component is located at the
desired position. If more than one component is selected, al of them will be moved simultaneously.

Scaling of components is done using the handles that are visible when a component is selected. Place the
mouse cursor over one of the handles, click and hold down the left mouse button while moving the mouse.

Components can also be rotated freely using the handles visible when a component is selected. Place the
mouse cursor over one of the handles, click and hold down the left mouse button and the shift button on the
keyboard while moving the mouse. The mouse cursor will change its appearance while rotating the component.

Pressing the right mouse button when the mouse cursor is placed over a component brings up a menu with
suitable operations.

resistort inductor1
-_l:l.n e

Ret L=1
inertial
1 =1

J=1

AU

R

groun]

Figure 2-5. Several components dragged into the diagram view of the Graphic Model Editor.

When the components have been placed on the drawing area, similar to the figure above, you have to draw the
lines that connect the components. Thisis done using the connector tool from the toolbar:

LN

To connect two components, select the connector tool and place the mouse cursor over a connector, i.e., the
square symbol on either side of the component. When you are close enough, the mouse cursor will change into
across. Click and a hold down the left mouse button, drag the cursor to the other connector and then release the
mouse button when the mouse cursor turns into a cross. Continue to connect al components until the model
diagram resembles the one in Figure 2-6 below.
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Figure 2-6. The components connected into a simple DC motor model.

2.1.2  The Graphic Editor Text View
The Modelica code of aModel can aso be viewed and edited using the Graphic Editor text view (Figure 2-7):

Fle Edt View Todls Shape Window Help

FE SRR oo " med sl 88 cEElEiadin WN 7
frocel mortor

annotation(Icon (eoordinateSysten (extent={{-100,-100},{100,100}}],0ray| 8 Name

Teplma Modelica.Electrical.Analog.Sources.ConstantVoltage constantVoltagel constantyoltagel

Hodelica.Mechanics.Rotational.Inertia inertial annotation (Placement | EMF1
I:‘ D Hodelica.Electrical.Analoy.Basic. Inductor inductorl annotation (Placel graund]
Hodelica.Electrical.Analoy.Basic.Ground groundl annctacion (Placewent inductorl
Modell  [HEE] Modelica.Electrical.Analog.Basic.Resistor resistorl(R=20) annoration inertial
Hodelica.Electrical.inalog.Basic.EMF EMF1 =nnotation|Placement (visib resistor|
equation

connect (inductorl.n, ENF1.p) snnotationiline (visible=trus,points={{7.
connect (EMF1.n, groundl.p) annotation{Line (visible=trus,points={{22.3
connect (EMF1.flange b, inertial,flange_a) =nnotation(Line(visible=trud
connect (resistorl.n, industorl.p) sonotation(Line(visible=true, pointss
connect (constantVoltagel.p,resistorl.p] =nnotation(Line(visible=true
connect (groundl.p, constantVoltagel.n) =nnotstion(Line{visible=true,p
end Motor;

Parameters can not be edited when the
Modelica Text view is active.

Rotate Right (Ctrl+R) Lnt Cal1

Figure 2-7. Graphic Model Editor text view.
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213 Plotting

After the model has been trandated and simulated, any of its variables can be plotted (Figure 2-8). Such
plotting from the Graphic Model Editor is not available in the MathModelica Lite Edition. Instead, plotting can
be made from the command line through the plot command, as in the examples shown in Section 1.2.

Simulation Center
File Edit Tools Wiew Simulate Plot Window Help
¢ Models |MUlD|

| Experiments: |Evperiment; 1 | New experiment | 7" Simulat

Windowe 1
Erperiments 100 —
Motor 1 083
asn
Mame 085
| ™t otor 080
- EMF1 075
[ congtantyoltagel (i)
#- ground1 055
[ inductor] 050
= imertE : gi; /
0 045
2 040
O derlphi) e
0O derfw) e
= flange_a 0235
: phi 020 p'j
# flange_b 010 fi
O phi a0 =]
™ ow oo
- resistor] 903
1) 10 20 30 40 30 al 0 20 90 o 110 1200 1300 140
B inertialw M inertiz!flange atau

Flot |Palameters ” Settings ‘

Figure 2-8. MathModelica plot window created after a simulation of the Mot or model, using the full version of
the MathModelica System Designer Graphic Editor (plotting not available in the MathModelica Lite version).
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Chapter 3

OMNotebook with DrModelica

This chapter covers the OpenModelica electronic notebook subsystem, called OMNotebook, together with the
DrModelica tutoring system for teaching Modelica, which is using such notebooks.

3.1 Interactive Notebooks with Literate Programming

Interactive Electronic Notebooks are active documents that may contain technical computations and text, as
well as graphics. Hence, these documents are suitable to be used for teaching and experimentation, simulation
scripting, model documentation and storage, etc.

3.1.1 Mathematica Notebooks

Literate Programming (Knuth 1984) is a form of programming where programs are integrated with
documentation in the same document. Mathematica notebooks (Wolfram 1997) is one of the first WY SIWY G
(What-Y ou-See-Is-What-Y ou-Get) systems that support Literate Programming. Such notebooks are used, e.g.,
in the MathModelica modeling and simulation environment, e.g. see Figure 3-1 below and Chapter 19 in
(Fritzson 2004)

3.1.2 OMNotebook

The OMNotebook software (Axelsson 2005, Fernstrém 2006) is a new open source free software that gives an
interactive WYSIWYG (What-Y ou-See-IsWhat-Y ou-Get) redlization of Literate Programming, a form of
programming where programs are integrated with documentation in the same document.

The OMNotebook facility is actualy an interactive WYSIWYG (What-Y ou-See-Is-What-Y ou-Get)
realization of Literate Programming, a form of programming where programs are integrated with
documentation in the same document. OMNotebook is a simple open-source software tool for an electronic
notebook supporting Modelica.

A more advanced electronic notebook tool, also supporting mathematical typesetting and many other
facilities, is provided by Mathematica notebooks in the MathM odelica environment, see Figure 3-1.
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Figure 3-1. Examples of Mathematica notebooks in the MathM odelica modeling and simulation environment.

Traditional documents, e.g. books and reports, essentially always have a hierarchical structure. They are
divided into sections, subsections, paragraphs, etc. Both the document itself and its sections usualy have
headings as labels for easier navigation. This kind of structure is also reflected in electronic notebooks. Every
notebook corresponds to one document (one file) and contains a tree structure of cells. A cell can have different
kinds of contents, and can even contain other cells. The notebook hierarchy of cells thus reflects the hierarchy
of sections and subsectionsin atraditional document such as a book..

3.2  The DrModelica Tutoring System —an Application of OMNotebook

Understanding programs is hard, especialy code written by someone else. For educational purposes it is
essential to be able to show the source code and to give an explanation of it at the same time.

Moreover, it isimportant to show the result of the source code’ s execution. In modeling and simulation it is
also important to have the source code, the documentation about the source code, the execution results of the
simulation model, and the documentation of the simulation results in the same document. The reason isthat the
problem solving process in computational simulation is an iterative process that often requires a modification
of the original mathematical model and its software implementation after the interpretation and validation of
the computed results corresponding to an initial model.

Most of the environments associated with equation-based modeling languages focus more on providing
efficient numerical algorithms rather than giving attention to the aspects that should facilitate the learning and
teaching of the language. There is a need for an environment facilitating the learning and understanding of
Modelica. These are the reasons for developing the DrModelica teaching material for Modelica and for
teaching modeling and simulation.
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An earlier version of DrModelica was developed using the MathModelica environment. The rest of this
chapter is concerned with the OMNotebook version of DrModelica and on the OMNotebook tool itself.

DrModelica has a hierarchical structure represented as notebooks. The front-page notebook is similar to a
table of contents that holds al other notebooks together by providing links to them. This particular notebook is
the first page the user will see (Figure 3-2).

@ OMNotebook: DrModelica.onb

File Edit Cell Format Insert  MWindow  Help

-

Version 2006-04-11 }

DrModelic gmedeiica Edition

Copynght: () Link spmg University, PELAR, 2003-2006, Wiley-IEEE Press, Modelica &ssociation.
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Detailed Copyright and Acknowledgment Information
Getting Started Using OMNotebook
OpenModelica commands
Berkeley license OpenModelica
1 A Quick Tour of Modelica
1.1 Getting Started - First Basic Examples

There i1z a long tradition that the first sample program in any computer language iz a trivial program
printing the gfing "Hello World" (7Y 9 in Peter Fritzson's bool). Since Modelica is an equation based
language, printng T strmredweT oot make much sence. Instead, cour Helle Weorld 2Modelica program solves
a trivial differential equation. The second example shows how you can write a model that solves a
Differential Algebraic Equation System (p. 190, In the Wan der Pol (p. 22) example declaration as well as
itialization and prefiz usage are shown m a shghtly more complicated way.

1.2 Classes and Instances

In Modelica objects are created implicitly just by Declaring Tnstances of Classes (p. 26). Almost anything
i Modelica is a class, but there are some keywords for spectfic use of the class concept, called

Ready

Figure 3-2. The front-page notebook of the OMNotebook version of the DrModelica tutoring system.
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In each chapter of DrModelica the user is presented a short summary of the corresponding chapter of the book
“Principles of Object-Oriented Modeling and Simulation with Modelica 2.1" by Peter Fritzson. The summary
introduces some keywords, being hyperlinks that will lead the user to other notebooks describing the keywords
in detail.

&l oMNotebook: Helloworld.onb*
File Edit Cell Format Insert ‘wWindow Help

First Basic Class

1 HelloWorld

The program contains a declaration of a class called He 11 oWorld with two fields and one equation. The first field 1z
the variable x which is initialized to a start value 2 at the time when the simulation starts. The second field is the variable
a, which iz a constant that iz mitialized to 2 at the begiming of the simulation. Such a constant iz prefized by the
keyword parameter in order to indicate that it iz constant during simulation but iz a model parameter that can be
changed between simulations.

The Modelica program solves a trivial diferential equation: x7 = - a * x=. The vanable % is a state variable
that can change value over time. The x ' is the time derivative of z.

class HelloWorld
BReal x(start = 1):

parameter Real a = 1;
equation
der(x) = - a * x;

end HelloWorld;

Ok

2 Simulation of HelloWorld

simulate( HelloWorld, startTime=0, stopTime=4 );

[done]

plot{ x }):

Plot by ©OpenModelica

1}-Nn

04

0oL

Ready

Figure 3-3. TheHelloworld class simulated and plotted using the OMNotebook version of DrModelica.

Now, let us consider that the link “Helloworld” in DrModelica Section is clicked by the user. The new
HelloWorld notebook (see Figure 3-3), to which the user is being linked, is not only a textual description but
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aso contains one or more examples explaining the specific keyword. In this class, Hel1loworld, a differential
equation is specified.

No information in a notebook is fixed, which implies that the user can add, change, or remove anything in a
notebook. Alternatively, the user can create an entirely new notebook in order to write his’her own programs or
copy examples from other notebooks. This new notebook can be linked from existing notebooks.

(Ll oMMotebook: drmodelica.onb o ] |
File Edit Cel Format Insert  Window Help
Algorithms and Functions
Algorithms
In Modelica, algornithmic statements can only occur within Algorithin Sections (p. 285),
starting with the keyword algorithm Simple Assiciiment Statements (p. 287) is the
most common kind of statements in algoritlun sections. There is a special form of
azsigment statement that is only nsed when the right hand side contaings a call to a
Function with Multiple Results (p. 287).
The for-Statement (alzo called for-loop) is a convenient way of expressing iteration (.
288). When uging the for-loop for iteration we must be able to express the range of
valueg over which the iteration variable should iterate in a closed form ag an iteration
expression. For cases where this is not feasible there iz also a While-loop iteration
construct in Modelica (p. 290). For conditional expressions the if-Statement (p. 292) is
usged. When-Statements (p. 293) are uzed to express actions af event instants and are
closely related to when-equations. The Reinit (p. 296) statement can be uzed in
when-statements to define new values for continuous-time state variables of a model at
an event.
The Aszert (p. 298) statement provides a convenient means for specifying checls on
model validity within a model
The most common ngage of Terminate (p. 298) is to give more appropriate stopping
criteria for terminating a simulation than a fixxed point in time.
Exercises J
Exercise 1
Exercise 2
Exercise 3
Exercise 4
Exercise S
Functions
The body of a Modelica function iz a kind of algorithim section that contains procedural
algorithmic code to be executed when the function iz Called (p. 300). Since a fumction i
a restricted and enhanced kind of clazs. it iz possible to inherit an existing finction El
Ready 4

Figure 3-4. DrModelica Chapter on Algorithms and Functions in the main page of the OMNotebook version of
DrModelica.
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When a class has been successfully evaluated the user can simulate and plot the result, as previously depicted
in Figure 3-3 for the simple He11oWwor1d example model..

After reading a chapter in DrModelica the user can immediately practice the newly acquired information by
doing the exercises that concern the specific chapter. Exercises have been written in order to elucidate language
constructs step by step based on the pedagogical assumption that a student learns better “using the strategy of
learning by doing”. The exercises consist of either theoretical questions or practical programming assignments.
All exercises provide answers in order to give the user immediate feedback.

Figure 3-4 shows part of Chapter 9 of the DrModelica teaching material. Here the user can read about
language constructs, like algorithm sections, when-statements, and reinit equations, and then practice
these constructs by solving the exercises corresponding to the recently studied section.

DMNutehuuk: Exercisel.nb o |

File Edit Cell Format Insert ‘Window Help

Exercise 1

Using Algorithm Sections

WWrite a function, Sum, which calculates the sum of numbers, in an array of arbitrary size.

| ]

Write a function, Ave rage, which calculates the average of numbers, in an array of arbitrary size. Average
should use make a function call to Sum.

| ]

Wnte a class, LargestAverage, that has two arrays and calculates the average of each of thern. Then it
compares the averages and sets a vanable to true if the frst array 15 larger than the second and otherwise false.

| ]

Answer

Ready Y
Figure 3-5. Exercise 1 in Chapter 9 of DrModelica.
Exercise 1 from Chapter 9 is shown in Figure 3-5. In this exercise the user has the opportunity to practice

different language constructs and then compare the solution to the answer for the exercise. Notice that the
answer isnot visible until the Answer section is expanded. The answer is shown in Figure 3-6.
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Il OMNotebook: Exercisel.nb*® =10l x|
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|
Answer

Sum

function Sum
input Reall[:] x;
output Real sum;
algorithm
for i in l:sizei(x,1) loop
sum := sum + x[i];
end for;

end Sum;

Average

function Average
input Reall[:] x;
output Real average;
protected
Real sum;
algorithm
average := Sumix) / size(x,1);

end Average;

LargestAverage

class LargestAverage
parameter Integer[:] &A1l = {1, Z, 3, 4, 5};
parameter Integer([:] AZ = {7, 8, 9}:
Real awverageil, awveragelZ;
Boolean AlLargest(start = false);

algorithm

averagedl = Average (Al);

averageAZ 1= Average (AZ);

if awverageil > averageAZ then
AlLargest := true;

el=e
AlLargest := false;

end if;

end LargestAverage;

Sunulation of LargestAverage

simulate| LargestiAverage J; }

When we look at the values m the vanables we see that A2 has the largest average (2 ) and therefore the
variable A 1Largest iz false (= 0.

Ready

s L

Figure 3-6. The answer section to Exercise 1 in Chapter 9 of DrModelica.

3.3 OpenModelica Notebook Commands

OMNotebook currently supports the commands and concepts that are summarized in this section.
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3.31 Cells

Everything inside an OMNotebook document is made out of cells. A cell basically contains a chunk of
data. That data can be text, images, or other cells. OMNotebook has four types of cells: headercell,
textcell, inputcell, and groupcell. Cells are ordered in a tree structure, where one cell can be a
parent to one or more additional cells. A tree view is available close to the right border in the notebook
window to display the relation between the cells.

3.3.2

Textcell — This cell type are used to display ordinary text and images. Each textcell has a style that
specifies how text is displayed. The cell’s style can be changed in the menu Format->Styles,
example of different stylesare: Text, Title, and Subtitle. The Textcell type aso has support
for following links to other notebook documents.

Inputcell — This cell type has support for syntax highlighting and evaluation. It is intended to be
used for writing program code, e.g. Modelica code. Evaluation is done by pressing the key
combination Shift+Return or Shift+Enter. All the text in the cell is sent to OMC (OpenModelica
Compiler/interpreter), where the text is evaluated and the result is displayed below the inputcell. By
double-clicking on the cell marker in the tree view, the inputcell can be collapsed causing the result
to be hidden.

Groupcell — This cell typeis used to group together other cell. A groupcell can be opened or closed.
When a groupcell is opened all the cells inside the groupcell are visible, but when the groupcell is
closed only the first cell inside the groupcell is visible. The state of the groupcell is changed by the
user double-clicking on the cell marker in the tree view. When the groupcell is closed the marker is
changed and the marker has an arrow at the bottom.

Cursors

An OMNotebook document contains cells which in turn contain text. Thus, two kinds of cursors are needed
for positioning, text cursor and cell cursor:

3.4

Textcursor — A cursor between characters in a cell, appearing as a small vertical line. Position the
cursor by clicking on the text or using the arrow buttons.

Cellcursor — This cursor shows which cell currently has the input focus. It consists of two parts.
The main cellcursor is basically just athin black horizontal line below the cell with input focus. The
cellcursor is positioned by clicking on a cell, clicking between cells, or using the menu item ce11 -
>Next Cell Of Cell->Previous Cell. The cursor can also be moved with the key combination
Ctrl+Up or Ctrl+Down. The dynamic cellcursor is a short blinking horisontal line. To make this
visible, you must click once more on the main cellcursor (the long horizontal line). NOTE: In order
to paste cells at the cellcursor, the dynamic cellcursor must be made active by clicking on the main
cellcursor (the horisontal line).

Selection of Text or Cells

To perform operations on text or cells we often need to select arange of characters or cells.

Select characters — There are several ways of selecting characters, e.g. double-clicking on a word,
clicking and dragging the mouse, or click followed by a shift-click at an adjacent positioin selects
the text between the previous click and the position of the most recent shift-click.

Select cells — Cells can be selected by clicking on them. Holding done Ctrl and clicking on the cell
markers in the tree view alows several cells to be selected, one at a time. Several cells can be
selected at once in the tree view by holding down the Shift key. Holding down Shift selects al cells
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3.4.1

between last selected cell and the cell clicked on. This only works if both cells belong to the same
groupcell.

File Menu

The following file related operations are available in the file menu:

3.4.2

Create a new notebook — A new notebook can be created using the menu File->New or the key
combination Ctrl+N. A new document window will then open, with a new document inside.

Open a notebook — To open a notebook use File->Open in the menu or the key combination
Ctrl+O. Only files of the type .onb or .nb can be opened. If a file does not follow the
OMNotebook format or the FullForm Mathematica Notebook format, a message box is displayed
telling the user what is wrong. Mathematica Notebooks must be converted to fullform before they
can be opened in OMNotebook.

Save a notebook — To save a hotebook use the menu item File->Save Or File->Save As. If the
notebook has not been saved before the save as dialog is shown and a filename can be selected.
OMNotebook can only save in xml format and the saved file is not compatible with Mathematica.
Key combination for save is Ctrl+S and for save as Ctrl+Shift+S. The saved file by default obtains
the file extension . onb.

Print — Printing a document to a printer is done by pressing the key combination Ctrl+P or using the
menu item File->Print. A normal print dialog is displayed where the usually properties can be
changed.

Import old document — Old documents, saved with the old version of OMNotebook where a
different file format was used, can be opened using the menu item File->Import->01d
OMNotebook file. Old documents have the extension .xm1.

Export text — The text inside a document can be exported to a text document. The text is exported to
this document without amost any structure saved. The only structure that is saved is the cell
structure. Each paragraph in the text document will contain text from one cell. To use the export
function, use menu item File- >Export - >Pure Text.

Close a notebook window — A notebook window can be closed using the menu item File->Close
or the key combination Ctrl+F4. Any unsaved changes in the document are lost when the notebook
window is closed.

Quitting OMNotebook — To quit OMNotebook, use menu item File->Quit or the key
combination Crtl+Q. This closes all notebook windows; users will have the option of closing OMC
aso. OMC will not automatically shutdown because other programs may still use it. Evaluating the
command quit() has the same result as exiting OM Notebook.

Edit Menu

Editing cell text — Cells have a set of of basic editing functions. The key combination for these are:
Undo (Ctrl+Z), Redo (Ctrl+Y), cut (Ctrl+X), copy (CtrI+C) and paste (Ctrl+V). These functions
can also be accessed from the edit menu; Undo (Edit->Undo), Redo (Edit->Redo), Cut (Edit-
>Cut), Copy (Edit->Copy) and Paste (Edit->Paste). Selection of text is done in the usual way
by double-clicking, triple-clicking (select a paragraph), dragging the mouse, or using (Ctrl+A) to
select al text within the cell.

Cut cell — Cells can be cut from a document with the menu item Edit->Cut or the key combination
Ctrl+X. The cut function will always cut cells if cells have been selected in the tree view, otherwise
the cut function cuts text.
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3.4.4

Copy cell — Cells can be copied from a document with the menu item Edit->Copy or the key
combination Ctrl+C. The copy function will always copy cellsif cells have been selected in the tree
view, otherwise the copy function copy text.

Paste cell — To paste copied or cut cells the cell cursor must be selected in the location where the
cells should be pasted. This is done by clicking on the cell cursor. Pasteing cells is done from the
menu Edit->Paste or the key combination Ctrl+V. If the cell cursor is selected the paste function
will always paste cells. OMNotebook share the same application-wide clipboard. Therefore cells
that have been copied from one document can be pasted into another document. Only pointers to
the copied or cut cells are added to the clipboard, thus the cell that should be pasted must still exist.
Consequently a cell can not be pasted from a document that has been closed.

Find — Find text string in the current notebook, with the options match full word, match cell, search
within closed cells. Short command Ctrl+F.

Replace — Find and replace text string in the current notebook, with the options match full word,
match cell, search+replace within closed cells. Short command Ctrl+H.

View expression — Text in acell is stored internally as a subset of HTML code and the menu item
Edit->View Expression let the user switch between viewing the text or the internal HTML
representation. Changes made to the HTML code will affect how the text is displayed.

Cell Menu

Add textcell — A new textcell is added with the menu item ce11->Add cell (previous cell style) or
the key combination Alt+Enter. The new textcell gets the same style as the previous selected cell
had.

Add inputcell — A new inputcell is added with the menu item cell->Add Inputcell or the key
combination Ctrl+Shift+].

Add groupcell — A new groupcell is inserted with the menu item cell->Groupcell or the key
combination Ctrl+Shift+G. The selected cell will then become the first cell inside the groupcell.

Ungroup groupcell — A groupcell can be ungrouped by selecting it in the tree view and using the
menu item Cell->Ungroup Groupcell Of by using the key combination Ctrl+Shift+U. Only one
groupcell at atime can be ungrouped.

Solit cell — Spliting a cell is done with the menu item cel1->split cell or the key combination
Ctrl+Shift+P. The cell is splited at the position of the text cursor.

Delete cell — The menu item cell->Delete Cell will delete all cells that have been selected in
the tree view. If no cell is selected this action will delete the cell that have been selected by the
cellcursor. This action can also be called with the key combination Ctrl+Shift+D or the key Del
(only works when cells have been selected in the tree view).

Cellcursor — This cell type is a special type that shows which cell that currently has the focus. The
cell is basicaly just a thin black line. The cellcursor is moved by clicking on a cell or using the
menu item Cell->Next Cell Of Cell->Previous Cell. The cursor can aso be moved with the
key combination Ctrl+Up or Ctrl+Down.

Format Menu

Textcell — This cell type is used to display ordinary text and images. Each textcell has a style that
specifies how text is displayed. The cells style can be changed in the menu Format->Styles,
examples of different styles are; Text, Title, and Subtitle. The Textcell type aso have
support for following links to other notebook documents.
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Text manipulation — There are a number of different text manipulations that can be done to change
the appearance of the text. These manipulations include operations like: changing font, changing
color and make text bold, but also operations like: changing the alignment of the text and the
margin inside the cell. All text manipulations inside a cell can be done on single letters, words or
the entire text. Text settings are found in the Format menu. The following text manipulations are
availablein OM Notebook:

> Font family

> Font face (Pain, Bold, Italic, Underline)

> Font size

> Font stretch

> Font color

> Text horizontal alignment

> Text vertical alignment

> Border thickness

> Margin (outside the border)

> Padding (inside the border)

3.45 Insert Menu

Insert image — Images are added to a document with the menu item Insert->Image or the key
combination Ctrl+Shift+M. After an image has been selected a dialog appears, where the size of the
image can be chosen. The images actua size is the default value of the image. OMNotebook
stretches the image accordantly to the selected size. All images are saved in the same file as the rest
of the document.

Insert link — A document can contain links to other OMNotebook file or Mathematica notebook and
to add anew link a piece of text must first be selected. The selected text make up the part of the link
that the user can click on. Inserting a link is done from the menu Insert->Link or with the key
combination Ctrl+Shift+L. A dialog window, much like the one used to open documents, allows the
user to choose the file that the link refersto. All links are saved in the document with arelative file
path so documents that belong together easily can be moved from one place to another without the
links failing.

3.4.6 Window Menu

3.4.7

Change window — Each opened document has its own document window. To switch between those
use the Window menu. The window menu lists al titles of the open documents, in the same order
as they were opened. To switch to another document, simple click on the title of that document.

Help Menu

About OMNotebook — Accessing the about message box for OMNotebook is done from the menu
Help->About OM Notebook.
About Qt — To access the message box for Qt, use the menu Help->About Qt.

Help Text — Opening the help text (document oMNotebookHelp.onb) for OMNotebook can be
done in the same way as any OMNotebook document is opened or with the menu Help->Help
Text. The menu item can aso be triggered with the key F1.
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3.4.8

Additional Features

Links— By clicking on alink, OMNotebook will open the document that is referred to in the link.

Update link — All links are stored with relative file path. Therefore OMNotebook has functions that
automatically updating links if a document is resaved in ancther folder. Every time a document is
saved, OMNotebook checks if the document is saved in the same folder as last time. If the folder
has changed, the links are updated.

Evaluate several cells — Several inputcells can be evaluated at the same time by selecting them in
the treeview and then pressing the key combination Shift+Enter or Shift+Return. The cells are
evauated in the same order as they have been selected. If a groupcell is selected al inputcells in
that groupcell are evaluated, in the order they are located in the groupcell.

Command completion — Inputcells have command completion support, which checks if the user is
typing a command (or any keyword defined in the file commands.xml) and finish the command. If
the user types the first two or three letters in a command, the command completion function fillsin
the rest. To use command completion, press the key combination Ctrl+Space or Shift+Tab. The
first command that matches the letters written will then appear. Holding down Shift and pressing
Tab (aternative holding down Ctrl and pressing Space) again will display the second command that
matches. Repeated request to use command completion will loop through all commands that match
the letters written. When a command is displayed by the command completion functionality any
field inside the command that should be edited by the user is automatically selected. Some
commands can have several of these fields and by pressing the key combination Ctrl+Tab, the next
field will be selected inside the command.

> Active Command completion: Ctrl+Space/ Shift+Tab

> Next command: Ctrl+Space/ Shift+Tab

> Next field in command: Ctrl+Tab’

Generated plot — When plotting a simulation result, OMC uses the program Ptplot to create a plot.
From Ptplot OMNotebook gets an image of the plot and automatically adds that image to the output
part of an inputcell. Like all other images in a document, the plot is saved in the document file
when the document is saved.

Stylesheet -OMNotebook follows the style settings defined in stylesheet.xml and the correct styleis
applied to acell when the cell is created.

Automatic Chapter Numbering — OMNotebook automatically numbers different chapter,
subchapter, section and other styles. The user can specify which styles should have chapter
numbers and which level the style should have. This is done in the stylesheet.xml file. Every style
can have a <chapterL evel> tag that specifies the chapter level. Level 0 or no tag at all, means that
the style should not have any chapter numbering.

Scrollarea — Scrolling through a document can be done by using the mouse wheel. A document can
a so be scrolled by moving the cell cursor up or down.

Syntax highlighter — The syntax highlighter runs in a separated thread which speeds up the loading
of large document that contains many Modelica code cells. The syntax highlighter only highlights
when letters are added, not when they are removed. The color settings for the different types of
keywords are stored in the file modelicacolors.xml. Besides defining the text color and
background color of keywords, whether or not the keywords should be bold or/and italic can be
defined.

Change indicator — A star (*) will appear behind the filename in the title of notebook window if the
document has been changed and needs saving. When the user closes a document that has some
unsaved change, OMNotebook asks the user if he/she wants to save the document before closing. If
the document never has been saved before, the save-as dialog appears so that a filename can be
choosen for the new document.
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e Update menus — All menus are constantly updated so that only menu items that are linked to actions
that can be performed on the currently selected cell is enabled. All other menu items will be
disabled. When atextcell is selected the Format menu is updated so that it indicates the text settings
for the text, in the current cursor position.
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Chapter 4

Emacs Textual Model Editor/Browser

An Emacs Modelica mode provides facilities for keyword highlighting, suppressing annotations, etc. It can
be downloaded from the OMDevelopers pat of the OpenModelica web page
www.idaliu.se/projectsOpenModelica.

(?? Need to describe those facilities, including how the Modelica mode is started).

Another quite useful facility is the Speedbar menu, depicted in Figure 4-1. (?? This Screendump shows the
same facility used for RML code, not Modelica code. Needs to be updated. Currently not included in the
Modelicamode.)

BT [ 7 ot - _lolx]
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Figure 4-1. Emacs with a speedbar menu to the left, which allows clicking on file names (for expansion or
closing the file contents menu). An expanded file shows all function, class, and type declarations. By clicking
on one of those, you can position the editor at the appropriate definition.

Give the command M-x speedbar to start the Speedbar menu. See Section 6.1 for an explanation to the
notation M-x, etc.
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When you open files the speedbar menu will automatically update itself. Y ou can double-click with the
left mouse button or single-click with the middle button to expand trees, and jump between files and
program definitions.

At the top you see the search path to the current directory, where you can click on the directory names
at different levels to jump back and forth in the hierarchy. Subdirectories are visible in the tree as
expandabl e nodes.

It isaso possible to right-click in the speedbar window to have a menu appear.
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Chapter 5

MDT — The OpenModelica Development Tooling
Eclipse Plugin

5.1

Introduction

The Modelica Development Tooling (MDT) Eclipse Plug-In integrates the OpenModelica compiler with
Eclipse. MDT, together with the OpenModelica compiler, provides an environment for working with
M odelica development projects.

The following features are available:

5.2

Browsing support for Modelica projects, packages, and classes
Wizards for creating Modelica projects, packages, and classes
Syntax color highlighting

Syntax checking

Browsing of the Modelica Standard Library

Code completion for class names and function argument lists.

Installation

The ingtallation of MDT is accomplished by following the below instalation instructions. These
instructions assume that you have successfully downloaded and installed Eclipse (http://www.eclipse.org).

gD RE

©ooN®

Start Eclipse

Select Help->Software Updates->Find and Install... fromthe menu

Select ‘ Search for new featuresto install’ and click ‘ Next’

Select ‘New Remote Site...’

Enter ‘MDT’ as name and * http://www.ida.liu.se/labs/pel ab/modelica/OpenModelicalMDT' as
URL and click ‘OK’

Make sure ‘MDT’ is selected and click ‘ Finish’

In the updates dialog select the ‘MDT’ feature and click ‘ Next’

Read through the license agreement, select ‘| accept...” and click ‘Next'

Click *Finish’ to install MDT
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5.3  Getting started

5.3.1 Configuring the OpenModelica Compiler

MDT needs to be able to locate the binary of the compiler. It uses the environment variable
OPENMODELICAHOME to do so.

If you have problems using MDT, make sure that OPENMODELICAHOME is pointing to the folder
where the Open Modelica Compiler is installed. In other words, OPENMODELICAHOME must point to
the folder that contains the Open Modelica Compiler (OMC) binary. On the Windows platform it’'s called
omc.exe and on Unix platformsit’s called omc.

5.3.2 Using the Modelica Perspective

The most convenient way to work with Modelica projects is to use to the Modelica perspective. To switch
to the Modelica perspective, choose the window menu item, pick Oopen Perspective followed by
Other... Select theModelica option from the dialog presented and click ox.

5.3.3 Creating a Project

To start a new project, use the New Modelica Project Wizard. It is accessible through File->New->
Modelica Project or by right-clicking in the Modelica Projects view and selecting New- >Modelica
Project.

New Modelica Project

Create a Modelica project

Create a Modelica project in the workspace.

Project name: |PPC 9?[}4

Einish l l Cancel
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5.3.4 Creating a Package

To create a new package inside a Modelica project, select File->New->Modelica Package. Enter the
desired name of the package and a description of what it contains.

New Modelica Package

Modelica Package r

Create a new Modelica package.

Source folder: [PPCQ?{] l [Emse...]
Mame: [Cﬂre l

Description: |Thi5 package contains the core stuff |

[ is encapsulated package

Einish | l Cancel
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5.3.5 Creating a Class

To create a new Modelica class, select where in the hierarchy that you want to add your new class and
select File->New->Modelica Class. When creating a Modelica class you can add different restrictions
on what the class can contain. These can for example be model, connector, block, record, Or
function. When you have selected your desired class type, you can select modifiers that add code blocks
to the generated code. ‘Include initial code block’ will for example add the line ‘initial
equation’ totheclass.

New Modelica Class

Modelica Class

Create a new Modelica class.

Source folder: [PPCQ?[].-’Cure l [Ermwse...]

Name: |ALU |

Type: block E]

Modifiers: include initial equation block

[]is partial class
[

Einish | l Cancel




5.3.6 Syntax Checking

Whenever a Modelica (.mo) file is saved by the Modelica Editor, it is checked for syntactical errors. Any
errors that are found are added to the Problems view and also marked in the source code editor. Errors are
marked in the editor as a red circle with awhite cross, a squiggly red line under the problematic construct,
and as a red marker in the right-hand side of the editor. If you want to reach the problem, you can either
click theitem in the Problems view or select the red box in the right-hand side of the editor.

Modelica - ALU.mo - Eclipse SDK

File Edit Mawvigate Search Project SWT Hierarchy Bun Window Help

el e e el o (votecs] >

Ko O

%8 Modeli... 32~ = O |V e =0

- 2 PPCO70 block ALU (<] m
=~ Core

equation
B ALU.mo .

b package.mo || imital equation
.project
[» = System Library

end ALU;
(4] D
Console [Z. Problems &2 ¥ =

2 errors, 0 warnings, 0 infos

Description Resource |In Folder Location
@ unexpected token ALU.mo PPCY970/Core line 5
@ unexpected token ALU.mo PPCO70/Core line 5

(2] | 1w |al | D

5.3.7 Indentation Support

MDT currently has support for automatic indentation. When typing the Return (Enter) key, the next lineis
indented correctly. You can also correct indentation of the current line or a range selection using CTRL+I
or “Correct Indentation” action on the toolbar or in the Edit menu.
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5.3.8 Code Completion

MDT supports Code Completion in two variants. The first variant, code completion when typing a dot after
aclass (package) name, shows aternativesin a menu:

< Modelica - DCEngine.mo - Eclipse SDK

File Edit Refactor Mawigate Search Run  Project  Window Help
Ci-EH e w |- ¥ |t P -

[ Modelica Projects &5 = B *DCEngine. mo £
= Tﬁ EngineSimulation model DCEngine
¥ DCEngine . mo import I-Iu:udelica.l
project i
= ; Standard Library I %Elsifants
=1 Modelica end DCEngine; £ Electrical
+- £ Blocks
+- £ Constants  Icons
+- £ Electrical £ Math
-3 Icons 3 Mechanics
- f3 Math B s1units
+ acos EElThermaI
+ asin
+ aktan
+ atang
baselconl

The second variant is useful when typing a call to a function. It shows the function signature (formal
parameter names and types) in a popup when typing the parenthesis after the function name, here the
signature Real sin(SI.Angle u) Of the sin function:

= Modelica - DCEngine.mo - Eclipse SDK

File Edit Refactor Mawvigate Search Run Project  Window Help

l=<'_'.f'|_|:,_|l'=='l a1 %" {l;- JE::":::"

[MY] Modelica Projects 23 =0 *LCERgIne.mo oa
=124 EngineSimulation model DCEngine
+ DCEngine. mo import Modelica.Math. *;
|Z] .project output Real x;
—| -2 Standard Library egquation
= Modelica Feal singSLLAngle ) |
+ -4 Blocks ¥ = zin|
+- £} Constants
+- 4 Electrical B
end DCEngine;
+-F4 Icons a
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Chapter 6

Modelica Algorithmic Subset Debugger

This chapter presents a comprehensive Modelica debugger for an extended algorithmic subset of the
Modelica language. This replaces debugging of agorithmic code using primitive means such as print
statements or asserts which is complex, time-consuming and error- prone.

Note: This Debugger is not yet released for general usage. There is current ongoing work in integrating
the Debugger into the MDT/Eclipse plugin for Modelica. This chapter has not yet been updated for the
Eclipse plugin release of the debugger in OpenModelica 1.4.2.

The debugger is portable since it is based on transparent source code instrumentation techniques that are
independent of the implementation platform.

The usual debugging functionality found in debuggers for procedural or traditional object-oriented
languages is supported, such as setting and removing breakpoints, single-stepping, inspecting variables,
back-trace of stack contents, tracing, etc.

We presents the debugger functionality by a debugging session on a short Modelica example. The
functionality of the debugger is shown using pictures from the Emacs debugging mode for Modelica
(modelicadebug-mode).

Note 1. The current (August 2006) implementation of the debugger only works together with the
Modelica compiler version that supports an extended algorithmic subset of Modelica, without equations
and simulation, but including meta-programming support. Both compiler versions will be merged into a
single version in the near future. It is not yet released for general usage.

Note 2: when applying the debugger to debug the OpenModelica compiler itself, give the make debug
command to compile the code with debugging turned on, or just the command: make, to compile it without
debugging support.

6.1 The Debugger Commands

The Emacs Modelica debug mode is implemented as a specialization of the Grand Unified Debugger
(GUD) interface (gud-mode) from Emacs. Because the Modelica debug mode is based on the GUD
interface, some of the commands have the same familiar key bindings.

The actual commands sent to the debugger are also presented together with GUD commands preceded
by the Modelica debugger prompt: mdbes.

If the debugger commands have severa alternatives these are presented using the notation:
alternativel|alternative2]|....

The optional command components are presented using notation: [optionall.

In the Emacs interface: M-x stands for holding down the Meta key (mapped to A1t in genera) and
pressing the key after the dash, here x, c-x stands for holding down the control (ctrl) key and
pressing x, <RET> isequivalent to pressing the Enter key, and <spcC> to pressing the space key.

6.2  Starting the Modelica Debugging Subprocess

The command for starting the Modelica debugger under Emacs is the following:

M-x modelicadebug <RET> executable <RET>
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6.3  Setting/Deleting Breakpoints

A part of a session using this type of commands is shown in Figure 6-1 below. The presentation of the
commands follows.

macs@kafka.carafe.ida.liu.se =]
File Edit Options Buffers Tools Complete InfOut Signals Help

e X L & ?

function eval
input Exp  exp_1z
output Feal rval_12
algorithm
rval_1 i=
match exp_1
local Integer wl.w2:

wp el.e2:
caze RCOMST{wl} then wi:
caze PLUS(el,=2) egquation
vl = evaliell: w2 = ewaliedl:
then wl+y2:
caze SUB{el.e2) equation
vi[F evalield: 2 = evalie2):

——(D05}-- ewval.no (Modelicat--L14--C8--Top------—---
Current directory is Aoygdrivesc/home/adrpo/doc/ero jects/mod @
%licaﬂﬂodelicaEDnFerenceEOOEftests/

Init

modb@> - Modelica debugger

mel@r - 2002, 2003, 2004, LIU/IDA/PELAB. acrpo@ida,liu,se
mb@> - debugging process 2800

mob@> - on tty:sdevittyl

nob@>Breskpoint an: [eval.mo:3] added to breskpoints list,
nob@rBreakpoint on: [eval.noill] added to breskpoints list,
melb@rBreskpoint omd [eval.nodld] added to breskpoints list,
nclb@>show

---------- CURRENT BREAKPOIMTS ---------

#0 -» eval,noid

#1 -» eval,mozll

#2 -» eval.mo:ld

nol@ e lear
Breakpoints list cleared
ikl |
l—_!—l;** *gux {Debuggerjruny--L18--C5--A11---—-------

Figure 6-1. Using breakpoints.
To set abreakpoint on the line the cursor (point) is at:

C-x <SPC>
mdb@> break on file:lineno|string <RET»>

To delete a breakpoint placed on the current source code line (gud - remove):

C-c C-d
C-x C-a C-d
mdb@> break off file:lineno|string <RET>

Instead of writing break one can use alternativeSbr | break |breakpoint.
Alternatively one can delete al breakpoints using:

mdb@> cl|clear <RET»>

Showing all breakpoints:

mdb@> sh|show <RET>

6.4  Stepping and Running

To perform one step (gud-step) in the Modelica code:

C-c C-s
C-x C-a C-s
mdb@> st|step <RET>

To continue after a step or abreakpoint (qud-cont) in the Modelica code:
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C-c C-r
C-x C-a C-r
mdb@> ru|run <RET>
Examples of using these commands are presented in Figure 6-2.

macs@kafka.carafe.ida.linse =l

File Edit Options Buffers Tools Complete In/Out Signals Help

@ X L& & ?

function sval
input  Exp exp_l:
output Real rval_1:
algorithn
rual_1 3=
match exp_1
local Integer wl. wE:
Exp el el
case[FCOMST (vl then wiz
caze PLUS{el,.e2) equation
vl = evalield: w2 = evalis2):
then wl+v2:
caze SUB(el,e2) equation
vl = evalield: w2 = evalis2):

then wl-v2:
caze MUL{el.e2) equation
vl = evalield:r o2 = evaliel):
then wilxw2:
caze DIViel,e2) equation
--{00S}-- ewal.no {Modelica?--L9--C6--Top--=====----=--- B
Current. directory is Acygdrive/c/homedsdrpo/doc/projects/modelica @

ModelicaConference2005/tests/
[Init]

moblE@> - Modelica debugger

molblE@> - 2002, 2003, 2004, LIU/IDASPELAB. adrpolida,liu,se
mobliE> - debugging process 3716

mdbE> - on tty:ddevsttyl

nodb@>Breakpoint oni [eval.mo:9] added to breakpoints list,
ndb@>Breskpoint on: [eval.mo:1l] added to breakpoints list,
nob@>[Parse]

4-16/2%x3+10

[Ewall

Breskpoint [1]. on eval.mo:ll reached
eval,mo:ll,7BevalBoallievaliel) => (vl}
il > un

Breakpoint. [0]. on ewval,mo:9 reached
eval .moi9 . BFevallaxionRCONST (vl => (wl}
EER |

I__!T** *gucx {Debugger srund—-L20--LE--All-------—--———- |

Figure 6-2. Stepping and running.

6.5 Examining Data

There are no GUD keybindings for these commands but they are inspired from the GNU Project debugger
(GDB).
To print the contents/size of a variable one can write:

mdb@> pr|print variable name <RET>
mdb@> sz|sizeof variable name <RET>

at the debugger prompt. The sizeis displayed in bytes.
Variable values to be printed can be of a complex type and very large. One can restrict the depth of
printing using:
mdb@> [set] de|depth integer <RET>
Moreover, we have implemented an external viewer written in Java caled ModelicaDataViewer tO
browse the contents of such a large variable. To send the contents of a variable to the external viewer for
inspection one can use the command:

mdb@> bw|browse|gr|graph var name <RET>
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at the debugger prompt. The debugger will try to connect to the Modelicabataviewer and send the
contents of the variable. The external data browser has to be started a priori. If the debugger cannot connect
to the externa viewer within a specified timeout a warning message will be displayed. A picture of the
external ModelicaDataViewer tool is presented in Figure 6-3.

-__* ModelicaDataViewer - | Ellll

|| Modelica Data Viewer
-] Modelica Variables
B et:Exp
IJ:'|—_| SUE:record
[ | RCONSTrecord
L% 2Real
;] MUL:record
;l D% record
| RCONST:record
L—# 1&Real
| RCONST:record
% zReal
| RCONST:record
L% 3Real

-1 e2Exp
=] RCOMST:recard
L# 10Real

|»

Modelica Data Viewer (Browser) Help

Quick crash-course on Modelica variable exploring

® Ztart the wviewer before starting the debugger

O (this could be rectified in the fiture so that the
wiewer 1g started by the debugger)

# Click on variable name inside the tree to explore a variable e
# [MWore could be added here in the future] =l

Figure 6-3. Modelica Data Viewer (Browser) for data structures, here a small abstract syntax tree.

If the variable which one tries to print does not exist in the current scope (not a live variable) a notifying
warning message will be displayed.

Automatic printing of variables at every step or breakpoint can be specified by adding a variable to a
display list:
mdb@> di|display variable name <RET>
To print the entire display list:
mdbe> di|display <RET>
Removing a display variable from the display list:
mdb@> un|undisplay variable name <RET>
Removing all variables from the display list:
mdb@> undisplay <RET>
Printing the current live variables:
mdbe> 1li|live|livevars <RET>
Instructing the debugger to print or to disable the print of the live variable names at each step/breapoint:

mdb@> [set] li|live|livevars [on|off]<RET>

Figure 6-4 shows examples of some of these commands within a debugging session:
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macs@kafka.carafe.idalivse =] ]

File Edit Options Buffers Tools Complete InfOut Signals Help

@ x ©ixd P ?

cutput Real rval_1:

alzorithm
rual_1 i=
match exp_1
local Integer wl.wE:
g el e2:

case RCOMST{vl) then wi:

caze FLUS{el.e2) equation
vl = evalield: w2 = evalis2):
then wl+y2:

caze SUB{el.eZ2) equation
vl = evali{ell: [M2 = evalie2):
then wl-v2:

caze MUL{el.e2) equation

(00S}-- eval.no (Modelical--14--C31-- G¥---——==---=-= |
Breakpoint. [1]. on eval,mo:ll reached
eval . moill, 7EevalBoallieval (el => (wll
il > un

Breakpoint. [0]. on ewval,mo:9 reached
eval.mo:9.0feval@axiomtRCOMST (vly => (vl}
nch@Exprink vl

Resultsilnot in current context]
FParameters ivl=d

ndb@>st

eval,moild 23@evallcall jevalie2) => (w2}

ndb@xprint e2

Resultzilnot in current context]

Parameters ;e2=MUL (DIV{RCOMST{163 RCOMST(2) ) . RCONSTL3: )
nchErdisplay e2

Resultsilnot in current context]

Parameters je2=MUL (DIV(RCOMST (16} . RCOMST (23 ) .RCONST (32
Variable: [e2] added to display wariabile list,

mclb@rdisplay
—————— LIST OF DISPLAY VARIAELES ------
#J -> 2
nch@>undisplay
List of display variahles cleared,
e e |
I-_!—l:** *gudx {Debugger jrunt-—-L38--C5--Bot-------—------ |

Figure 6-4. Examining variable values using print and display commands.

6.6 Additional commands

The stack contents (backtrace) can be displayed using:
mdb@> bt |backtrace <RET>

Because the contents of the stack can be quite large, one can print afiltered view of it:
mdb@> fbt|fbacktrace filter string <RET>

Also, one can restrict the numbers of entries the debugger is storing using:
mdb@> maxbt |maxbacktrace integer <RET>

For displaying the status of the Modelica runtime:
mdb@> sts|stat|status <RET>
The status of the extended Modelica runtime comprises information regarding the garbage collector,

alocated memory, stack usage, etc.
The current debugging settings can be displayed using:

mdb@> stg|settings <RET>

The settings printed are: the maximum remembered backtrace entries, the depth of variable printing, the
current breakpoints, the live variables, the list of the display variables and the status of the runtime system.
One can invoke the debugging help by issuing:

mdb@> he|help <RET>

For leaving the debugger one can use the command:

mdb@> qu|quit|ex|exit|by|bye <RET>
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A session using these commands is presented in Figure 6-5 below:

emacs@kafka.carafe.idalinse 18| x|

File Edit Options Buffers Tools Complete In/Out Sighals Help

C@x LRI B?

output Real rval_1:
algorithn
rval_1 :=
match exp_l
local Integer wl.u2:
xp el.e2;:
cazs RCOMSTOw1) then wiz
case PLUS(el.e2) equation
vl = evalleld: 2 = evalle2):
then wl+e2:
case SUB{el.e2) equation
vl = evaliely; [v2 = eval(s2i;
then wl-u2:
caze MIL{el,e2) equation
vl = evalleld: 2 = evalle2):
then wlsu2:
caze DIViel,e2) equation
(D0S2-- ewval.mo (Modelica)--L14--C21-- G¥-—=—————=————=—————— |
nodbE >d isp lay
------ LIST OF DISPLAY WARIABLES ------
#) - 82
nodbE -undisplay
List of display wvarisbles cleared.
molbi@>ht

STACK
#) -rewal.moill.7.11.20 relationfevall.goallcallievaliel} =» {(v1}]
#1 -»sval,moild,?,14,20 relationfevall.gosllcallievaliel) => (vl}]
#2 -reval,mo:9,8,9,17 relation[evall.goallaxion:RCONST(uwly =3 (w13]
#3 -reval.moild.23.14.36 relation[evall.goallcallievalis2} => (u2}]

ndb@>stel]

********************* CURRENT SETTINGS
mar backtrace sntries: 10
depth of wariable print: 1
execution type:i step

print names of livevars each step: false
Variskles printed at each step/breskpoint:
—————— LIST OF DISPLAY VARIABLES ------
Mo display variables are set
breakpoints s
—————————— CURREMT BREAKPOINTS ---------
#0 -> eval.motd
#1 -> eval,motll
thy: Sdevittyl
ﬁl‘** *gud* Debugger trun} -—L 45--0B--45%-—--—--——------—-——-- 5|

Figure 6-5. Additional debugger commands.

6.7 Hints for Debugging Large Programs

In order to faster get to an interesting place when debugging a large program such as the OpenModelica
compiler itself, you can put a breakpoint at the place where you would like to start the investigation, but
give the fast debug command when starting the execution from the beginning. In that case the debugger
will avoid saving backtrace and variables up to this breakpoint. Then you can turn off backtrace and run the
debugger as usual.

6.8 Summary of Debugger Commands

The following is a complete list of the current debugger commands

br |break |breakpoint string [on[off]  Setting/unsetting breakpoints

cl|clear Clear all breakpoints

sh|show Show all breakpoints

bt |backtrace Print the backtrace (stack)

fbt | fbacktrace filter Print filtered backtrace (stack)

mb |maxbacktrace int (O=full, default=0) Set the maximum of backtrace entries (stack).
ca|callchain Print the call chain

fca|fcallchain filter Print filtered call chain

mc |maxcallchain integer Set the maximum of callchain entries. (O=full, default=100)
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[set] de|depth integer
[set] ms|maxstring integer

set st|step [on|off]
st |step|<ENTER> | <CR>
ne |next

ru|run

stg|settings

he |help
sts|stat|status

li|live|livevars

[set] li|live|livevars [on|off]

pr|print var_name
sz|size|sizeof var_name
di|display var_name
ud|undisplay var_name
di|display
ud|undisplay

gr|graph var_name
pty|printtype identifier
fa|fast

qu|quit |ex|exit|by|bye

Set the depth of variable printing. (0=full, default=10)

Set how may chars we print from long strings. (O=full,
default=60)

Set the execution mode.

Perform one step.

Jump over next statement.

Run the program.

Print the current settings.

Showing help.

Printing the status of Modelica runtime.
Print the names of live variables.

On/Off printing names of livevars each step.
Print the live variable.

Print sizeof the live variable.

Display the live variable each step.
Un-display the live variable.

Show display variables.

Un-display ALL display variables.

Send the live variable to external viewer.
Print typeinfo on any Modelicaid.

FAST debugging: no backtrace, callchain, livevars.
Exiting the debugger/program.
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Frequently Asked Questions (FAQ)

Below are some frequently asked questionsin three areas, with associated answers.

7.1

7.2

OpenModelica General

Q: Why are not the MultiBody and Media libraries included in the OpenM odelica distribution.

A: These libraries need specid features in the Modelica language which are not yet implemented in
OpenModelica. We are working on it, but it will take some time.

Q: | did not find the graphic editor MathModelica Lite in the OpenModelica distribution. Where
can| find it?

A: You can download it via a link at the OpenModelica web site, e.g. the one placed under the
OpenModelica Environment heading, Graphic Editor bullet.

Q: OpenModelica 1.4.2 does not read the MODELICAPATH environment variable, even though
thisis part of the Modelica Language Specification.

A: Use the OPENMODELICALIBRARY environment variable instead. We have temporarily
switched to this variable, in order not to interfere with other Modelica tools which might be
installed on the same system. In the future, we might switch to a solution with a settings file, that
also allows the user to turn on the MODELICAPATH functionality if desired.

Q: How do | enter multi-line models into OM Shell since it evaluates when typing the Enter/Return
key?

A: There are basically three methods:. 1) load the model from afile using the pull-down menu or the
loadModel command. 2) Enter the model/function as one (possibly long) line. 3) Type in the model
in another editor, where using multiple linesis no problem, and copy/paste the model into OM Shell
as one operation, then push Enter. Another option is to use OMNotebook instead to enter and
evaluate models.

OMNotebook

Q: OMNotebook hangs, what to do?

A: It is probably waiting for the omc.exe (compiler) process. (Under windows): Kill the processes
omc.exe, g++.exe (C-compiler), as.exe (assembler), if present. If OMNotebook then asks whether
to restart OMC, answer yes. If not, kill the process OMNotebook.exe and restart manually.

Q: After aprevious session, when starting OM Notebook again, | get a strange message.

A: You probably quit the previous OpenModelica session in the wrong way, which left the process
omc.exe running. Kill that process, and try starting OM Notebook again.
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7.3

Q: | copy and paste a graphic figure from Word or some other application into OMNotebook, but
the graphic does not appear. What is wrong?

A: OMNotebook supports the graphic picture formats supported by Qt 4, including the .png, .bomp
(bitmap) formats, but not for example the gif format. Try to convert your picture into one of the
supported formats, (e.g. in Word, first do paste as bitmap format), and then copy the converted
version into atext cell in OMNotebook.

Q: Plotting does not work in OM Notebook.

A: You probably have an old version of Java installed. Update your installation, and try again.
(Another known problem, soon to be fixed, is that plotting of parameters and constants does not yet
work).

Q: | select acell, copy it (e.g. Ctrl-C), and try to paste it at another place in the notebook. However,
this does not work. Instead some other text that | earlier put on the clipboard is pasted into the
nearest text cell.

A: The problem is wrong choice of cursor mode, which can be text insertion or cell insertion. If you
click inside a cell, the cursor become vertical, and OMNotebook expects you to paste text inside the
cell. To paste a cell, you must be in cell insertion mode, i.e., click between two cells (or after a
cell), you will get avertical line. Place the cursor carefully on that vertical line until you see a small
horizonta cursor. Then you should past the cell.

Q: I amtrying to click in cells to place the vertical character cursor, but it does not seem to react.

A: This seems to be a Qt feature. You have probably made a selection (e.g. for copying) in the
output section of an evaluation cell. This seems to block cursor position. Click again in the output
section to disable the selection. After that it will work normally.

Q: | have copied atext cell and start writing at the beginning of the cell. Strangely enough, the font
becomes much smaller than it should be.

A: This seemsto be a Qt feature. Keep some of the old text and start writing the new stuff inside the

text, i.e., at least one character position to the right. Afterwards, delete the old text at the beginning
of the cell.

OMDev - OpenModelica Development Environment

Q: | get problems compiling and linking some files when using OMDev with the MINGW (Gnu) C
compiler under Windows.

A: You probably have some Logitech software installed. There is a known bug/incompatibility in
Logitech products, e.g. drivers, including dynamically loadable mouse drivers. Uninstall all
Logitech products, and switch to a mouse from some other vendor.
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Appendix A

Major OpenModelica Releases

This Appendix lists the most important OpenModelica releases and a brief description of their contents.
However, right now only the versions from 1.3.1 to 1.4.2 are described. (The earlier releases will be
described in a future update of the Users Guide).

A.1 OpenModelica 1.4.2, August 2006

This release has improvements and bug fixes of the OMC compiler, OMNotebook, the MDT plugin and the
OMDev. OMShell is the same as previously.

A.1.1 OpenModelica Compiler (OMC)

This release includes further improvements of the OpenMaodelica Compiler (OMC):
e Improved initialization and index reduction.
e  Support for integer arraysis now largely implemented.

e The va(variabletime) scripting function for accessing the value of a simulation result variable at a
certain point in the ssmulated time.

e Interactive evalution of for-loops, while-loops, if-statements, if-expressions, in the interactive
scripting mode.

e |Improved documentation and examples of calling the Model Query and Manipulation API.

e Many bug fixes.

A.1.2 OpenModelica Notebook (OMNotebook)

Search and replace functions have been added. The DrModelica tutorial (al files) has been updated,
obsolete sections removed, and models which are not supported by the current implementation marked
clearly. Automatic recognition of the .onb suffix (e.g. when double-clicking) in Windows makes it even
more convenient to use.

A.1.3 OpenModelica Eclipse Plug-in (MDT)
Two major improvements are added in this release:

e Browsing and code completion works both for standard Modelica and for MetaModelica.

e The debugger for algorithmic code is now available and operationa in Eclipse for debugging of
M etaM odelica programs.

A.1.4 OpenModelica Development Environment (OMDev)

Mostly the same as previously.

A.2 OpenModelica 1.4.1, June 2006

This release has only improvements and bug fixes of the OMC compiler, the MDT plugin and the OMDev
components. The OM Shell and OMNotebook are the same.
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A.2.1 OpenModelica Compiler (OMC)

This release includes further improvements of the OpenMaodelica Compiler (OMC):
e  Support for external objects.
e  OMC now reports the version number (via command line switches or CORBA API getVersion()).
¢ |Implemented caching for faster instantiation of large models.
e Many bug fixes.

A.2.2 OpenModelica Eclipse Plug-in (MDT)

Improvements of the error reporting when building the OMC compiler. The errors are now added to the
problemsview. Thelatest MDT release is version 0.6.6 (2006-06-06).

A.2.3 OpenModelica Development Environment (OMDev)

Small fixes in the MetaM odelica compiler. MetaModelica Users Guide is now part of the OMDev release.
The latest OMDev was release in 2006-06-06.

A.3 OpenModelica 1.4.0, May 2006

This release has a number of improvements described below. The most significant change is probably that
OMC has now been trand ated to an extended subset of Modelica (MetaModelica), and that all devel opment
of the compiler is now donein thisversion..

A.3.1 OpenModelica Compiler (OMC)
This release includes further improvements of the OpenMaodelica Compiler (OMC):

e Partial support for mixed system of equations.

¢ New initidization routine, based on optimization (minimizing residuals of initial equations).

e Symbolic simplification of builtin operators for vectors and matrices.

e Improved code generation in simulation code to support e.g. Modelica functions.

e Support for classes extending basic types, e.g. connectors (support for MSL 2.2 block connectors).
e  Support for parametric plotting via the plotParametric command.

e Many bug fixes.

A.3.2 OpenModelica Shell (OMShell)

Essentidly the same OMShell as in 1.3.1. One difference is that now all error messages are sent to the
command window instead of to a separate log window.

A.3.3 OpenModelica Notebook (OMNotebook)

Many significant improvements and bug fixes. This version supports graphic plots within the cells in the
notebook. Improved cell handling and Modelica code syntax highlighting. Command completion of the
most common OMC commands is now supported. The notebook has been used in several courses.

A.3.4 OpenModelica Eclipse Plug-in (MDT)

This is the first really useful version of MDT. Full browsing of Modelica code, e.g. the MSL 2.2, is now
supported. (MetaModelica browsing is not yet fully supported). Full support for automatic indentation of
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Modelica code, including the MetaModelica extensions. Many bug fixes. The Eclipse plug-in is now in use
for OpenM odelica development at PELAB and MathCore Engineering AB since approximately one month.

A.3.5 OpenModelica Development Environment (OMDev)
The following mechanisms have been put in place to support OpenModelica devel opment.
e A separate web page for OMDev (OpenModelica Development Environment).

o A pre-packaged OMDev zip-file with precompiled binaries for development under Windows using
the mingw Gnu compiler from the Eclipse MDT plug-in. (Development is also possible using
Visua Studio).

e All source code of the OpenM odelica compiler has recently been translated to an extended subset of
Modelica, currently called MetaModelica. The current size of OMC is approximately 100 000 lines
All development is now done in this version.

e A new tutorial and users guide for development in MetaModelica.
e  Successful builds and tests of OMC under Linux and Solaris.

A.4 OpenModelica 1.3.1, November 2005
This release has several important highlights.

Thisis aso the first release for which the New BSD (Berkeley) open-source license applies to the source
code, including the whole compiler and run-time system. This makes is possible to use OpenModelica for
both academic and commercial purposes without restrictions.

A.4.1 OpenModelica Compiler (OMC)
This release includes a significantly improved OpenModelica Compiler (OMC):
e Support for hybrid and discrete-event simulation (if-equations, if-expressions, when-equations;
not yet if-statements and when-statements).
e Parsing of full Modelica 2.2
e Improved support for external functions.

e Vectorization of function arguments; each-modifiers, better implementation of replaceable, better
handling of structural parameters, better support for vector and array operations, and many other
improvements.

e Flattening of the Modelica Block library version 1.5 (except a few models), and simulation of most
of these.

e Automatic index reduction (present also in previous release).
e Updated User's Guide including examples of hybrid simulation and external functions.

A.4.2 OpenModelica Shell (OMShell)

An improved window-based interactive command shell, now including command completion and better
editing and font size support.

A.4.3 OpenModelica Notebook (OMNotebook)

A free implementation of an OpenModelica notebook (OMNOtebook), for electronic books with course
material, including the DrModelica interactive course material. It is possible to smulate and plot from this
notebook.
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A.4.4 OpenModelica Eclipse Plug-in (MDT)
An early apha version of the first Eclipse plug-in (called MDT for Modelica Development Tooling) for

Modelica Development. This version gives compilation support and partial support for browsing Modelica
package hierarchies and classes.

A.45 OpenModelica Development Environment (OMDev)
The following mechanisms have been put in place to support OpenModelica devel opment.

e Bugzilla support for OpenM odelica bug tracking, accessible to anybody.

e A system for automatic regression testing of the compiler and simulator, (+ other system parts)
usually run at check in time.

e Version handling is done using SVN, which is better than the previously used CVS system. For
example, name change of modules is now possible within the version handling system.
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Appendix B

Contributors to OpenModelica

This Appendix lists the individua s who have made significant contributions to OpenModelica, in the form
of software development, design, documentation, project leadership, tutorial material, etc. The individuals
are listed for each year, from 1998 to the current year: the project leader and main author/editor of this
document followed by main contributors followed by contributorsin aphabetical order.

B.1 OpenModelica Contributors 2006
Peter Fritzson, PELAB, Linkoping University, Linkping, Sweden.

Peter Aronsson, MathCore Engineering AB, Linkdping, Sweden.
Adrian Pop, PELAB, Linkoping University, Linkoping, Sweden.

David Akhvlediani, PELAB, Linkdping University, Linkdping, Sweden.
Bernhard Bachmann, Fachhochschule Bielefeld, Bielefeld, Germany.
David Broman, PELAB, Linkdping University, Linkdping, Sweden.
Anders Fernstrém, PELAB, Linkdping University, Linkdping, Sweden.
Elmir Jagudin, PELAB, Link&ping University, Linkping, Sweden.
Hakan Lundvall, PELAB, Link&ping University, LinkOping, Sweden.
Kgj Nystrom, PELAB, Linkoping University, Linkoping, Sweden.

L ucian Popescu, MathCore Engineering AB, Linkdping, Sweden.
Andreas Remar, PELAB, Link6ping University, Linkoping, Sweden.
Anders Sandholm, PELAB, Link&ping University, Linképing, Sweden.

B.2 OpenModelica Contributors 2005
Peter Fritzson, PELAB, Linkoping University, Linkping, Sweden.

Peter Aronsson, PELAB, Linkdping University and MathCore Engineering AB, Linkdping, Sweden.
Adrian Pop, PELAB, Link&ping University, Linkoping, Sweden.
Hakan Lundvall, PELAB, Link&ping University, LinkGping, Sweden.

Ingemar Axelsson, PELAB, Linkdping University, Linkdping, Sweden.
David Broman, PELAB, Linkdping University, Linkdping, Sweden.
Daniel Hedberg, MathCore Engineering AB, Linkdping, Sweden.
Hakan Lundvall, PELAB, Link&ping University, LinkOping, Sweden.
Kgj Nystrom, PELAB, Linkoping University, Linkoping, Sweden.

L ucian Popescu, MathCore Engineering AB, Linkdping, Sweden.
Levon Saldamli, PELAB, Linkdping University, Linkdping, Sweden.

B.3 OpenModelica Contributors 2004
Peter Fritzson, PELAB, Linkoping University, Linktping, Sweden.
Peter Aronsson, Linkdping University, Linkdping, Sweden.
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Bernhard Bachmann, Fachhochschule Bielefeld, Bielefeld, Germany.

Peter Bunus, PELAB, Linkoping University, Linkdping, Sweden.

Daniel Hedberg, MathCore Engineering AB, Linkdping, Sweden.

Hakan Lundvall, PELAB, Link&ping University, LinkOping, Sweden.

Emma Larsdotter Nilsson, PELAB, Linkoping University, Linkdping, Sweden.
Kaj Nystrom, PELAB, Linkoping University, Linkoping, Sweden.

Adrian Pop, PELAB, Link&ping University, Linkoping, Sweden.

L ucian Popescu, MathCore Engineering AB, Linkdping, Sweden.

Levon Saldamli, PELAB, Linkdping University, Linkdping, Sweden.

B.4 OpenModelica Contributors 2003
Peter Fritzson, PELAB, Linkoping University, Linkping, Sweden.

Peter Aronsson, Linkoping University, Linkping, Sweden.
Levon Saldamli, PELAB, Linkdping University, Linkdping, Sweden.

Peter Bunus, PELAB, Linkoping University, Linkdping, Sweden.

Vadim Engelson, PELAB, Linkdping University, Linkdping, Sweden.

Daniel Hedberg, Linképing University, Linkping, Sweden.

Eva-Lena Lengquist-Sandelin, PELAB, Linkdping University, Linkdping, Sweden.
Susanna Monemar, PELAB, Linkdping University, Linkdping, Sweden.

Adrian Pop, PELAB, Link&ping University, Linkoping, Sweden.

Erik Svensson, MathCore Engineering AB, Link&ping, Sweden.

B.5 OpenModelica Contributors 2002
Peter Fritzson, PELAB, Linkoping University, Linkping, Sweden.

Levon Saldamli, PELAB, Linkdping University, Linkdping, Sweden.
Peter Aronsson, Linkdping University, Linkdping, Sweden.

Daniel Hedberg, Linkdping University, Linkdping, Sweden.
Henrik Johansson, PELAB, Linkoping University, Linkoping, Sweden
Andreas Karstrom, PELAB, Linkoping University, Linkdping, Sweden

B.6 OpenModelica Contributors 2001
Peter Fritzson, PELAB, Linkoping University, Linkping, Sweden.
Levon Saldamli, PELAB, Linkdping University, Linkdping, Sweden.
Peter Aronsson, Linkdping University, Linkdping, Sweden.

B.7 OpenModelica Contributors 2000
Peter Fritzson, PELAB, Linkoping University, Linkping, Sweden.

B.8 OpenModelica Contributors 1999
Peter Fritzson, PELAB, Linkdping University, Linkdping, Sweden

Peter Ronnquist, PELAB, Linkoping University, Linkdping, Sweden.



73

B.9 OpenModelica Contributors 1998
Peter Fritzson, PELAB, Linkoping University, Linktping, Sweden.
David Kagedal, PELAB, Link&ping University, Linkdping, Sweden.
Vadim Engelson, PELAB, Linkoping University, Linkoping, Sweden.
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