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Preface

This users guide provides documentation and examples on how to use the OpenModelica system, both for
the Modelica beginners and advanced users.






Chapter 1

Introduction

The OpenModelica system described in this document has both short-term and long-term goals:

The short-term goal is to develop an efficient interactive computational environment for the Modelica
language, as well as a rather complete implementation of the language. It turns out that with support of
appropriate tools and libraries, Modelica is very well suited as a computational language for
development and execution of both low level and high level numerical algorithms, e.g. for control
system design, solving nonlinear equation systems, or to develop optimization algorithms that are
applied to complex applications.

The longer-term goal is to have a complete reference implementation of the Modelica language,
including simulation of equation based models and additional facilities in the programming
environment, as well as convenient facilities for research and experimentation in language design or
other research activities. However, our goal is not to reach the level of performance and quality
provided by current commercial Modelica environments that can handle large models requiring
advanced analysis and optimization by the Modelica compiler.

The long-term research related goals and issues of the OpenModelica open source implementation of a
Modelica environment include but are not limited to the following:

Development of a complete formal specification of Modelica, including both static and dynamic
semantics. Such a specification can be used to assist current and future Modelica implementers by
providing a semantic reference, as a kind of reference implementation.

Language design, e.g. to further extend the scope of the language, e.g. for use in diagnosis, structural
analysis, system identification, etc., as well as modeling problems that require extensions such as partial
differential equations, enlarged scope for discrete modeling and simulation, etc.

Language design to improve abstract properties such as expressiveness, orthogonality, declarativity,
reuse, configurability, architectural properties, etc.

Improved implementation techniques, e.g. to enhance the performance of compiled Modelica code by
generating code for parallel hardware.

Improved debugging support for equation based languages such as Modelica, to make them even easier
to use.

Easy-to-use specialized high-level (graphical) user interfaces for certain application domains.
Visualization and animation techniques for interpretation and presentation of results.
Application usage and model library development by researchers in various application areas.

The OpenModelica environment provides a test bench for language design ideas that, if successful, can be
submitted to the Modelica Association for consideration regarding possible inclusion in the official Modelica
standard.
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The current version of the OpenModelica environment allows most of the expression, algorithm, and
function parts of Modelica to be executed interactively, as well as equation models and Modelica functions to
be compiled into efficient C code. The generated C code is combined with a library of utility functions, a run-
time library, and a numerical DAE solver. An external function library interfacing a LAPACK subset and other
basic algorithms is under development.

1.1  System Overview

The OpenModelica environment consists of several interconnected subsystems, as depicted in Figure 1-1
below.

MDT Eclipse Plugin Graphical Model
Editor/Browser \ Editor/Browser
Interactive I
Emacs «— | session handler Textual
Editor/Browser M Model Editor
OMNotebook / \
DrModelica Execution | Modelica
Model Editor Compiler
Modelica
Debugger

Figure 1-1. The architecture of the OpenModelica environment. Arrows denote data and control flow. The
interactive session handler receives commands and shows results from evaluating commands and expressions that
are translated and executed. Several subsystems provide different forms of browsing and textual editing of
Modelica code. The debugger currently provides debugging of an extended algorithmic subset of Modelica. The
graphical model editor is not really part of OpenModelica but integrated into the system and available from
MathCore without cost for academic usage.

The following subsystems are currently integrated in the OpenModelica environment:

e An interactive session handler, that parses and interprets commands and Modelica expressions for
evaluation, simulation, plotting, etc. The session handler also contains simple history facilities, and
completion of file names and certain identifiers in commands.

e A Modelica compiler subsystem, translating Modelica to C code, with a symbol table containing
definitions of classes, functions, and variables. Such definitions can be predefined, user-defined, or
obtained from libraries. The compiler also includes a Modelica interpreter for interactive usage and
constant expression evaluation. The subsystem also includes facilities for building simulation
executables linked with selected numerical ODE or DAE solvers.

e An execution and run-time module. This module currently executes compiled binary code from
translated expressions and functions, as well as simulation code from equation based models, linked
with numerical solvers. In the near future event handling facilities will be included for the discrete and
hybrid parts of the Modelica language.
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e Emacs textual model editor/browser. In principle any text editor could be used. We have so far
primarily employed Gnu Emacs, which has the advantage of being programmable for future extensions.
A Gnu Emacs mode for Modelica has previously been developed. The Emacs mode hides Modelica
graphical annotations during editing, which otherwise clutters the code and makes it hard to read. A
speedbar browser menu allows to browse a Modelica file hierarchy, and among the class and type
definitions in those files.

e Eclipse plugin editor/browser. The Eclipse plugin called MDT (Modelica Development Tooling)
provides file and class hierarchy browsing and text editing capabilities, rather analogous to previously
described Emacs editor/browser. Some syntax highlighting facilities are also included. The Eclipse
framework has the advantage of making it easier to add future extensions such as refactoring and cross
referencing support.

e OMNotebook DrModelica model editor. This subsystem provides a lightweight notebook editor,
compared to the more advanced Mathematica notebooks available in MathModelica. This basic
functionality still allows essentially the whole DrModelica tutorial to be handled. Hierarchical text
documents with chapters and sections can be represented and edited, including basic formatting. Cells
can contain ordinary text or Modelica models and expressions, which can be evaluated and simulated.
However, no mathematical typesetting or graphic plotting facilities are yet available in the cells of this
notebook editor.

e Graphical model editor/browser. This is a graphical connection editor, for component based model
design by connecting instances of Modelica classes, and browsing Modelica model libraries for reading
and picking component models. The graphical model editor is not really part of OpenModelica but
integrated into the system and provided by MathCore without cost for academic usage. The graphical
model editor also includes a textual editor for editing model class definitions, and a window for
interactive Modelica command evaluation.

e Modelica debugger. The current implementation of debugger provides debugging for an extended
algorithmic subset of Modelica, excluding equation-based models and some other features, but
including some meta-programming and model transformation extensions to Modelica. This is
conventional full-feature debugger, using Emacs for displaying the source code during stepping, setting
breakpoints, etc. Various back-trace and inspection commands are available. The debugger also
includes a data-view browser for browsing hierarchical data such as tree- or list structures in extended
Modelica.

1.1.1 Implementation Status

In the current OpenModelica implementation version 1.4.5 (January 2009), not all subsystems are yet
integrated as well as is indicated in Figure 1-1. Currently there are two versions of the Modelica compiler, one
which supports most of standard Modelica including simulation, and is connected to the interactive session
handler, the notebook editor, and the graphic model editor, and another meta-programming Modelica compiler
version (called MetaModelica compiler) which is integrated with the debugger, Eclipse, and Emacs, supports
meta-programming Modelica extensions, but does not allow equation-based modeling and simulation. Those
two versions are currently being merged into a single Modelica compiler version.
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1.2 Interactive Session with Examples

The following is an interactive session using the interactive session handler in the OpenModelica environment,
called OMShell — the OpenModelica Shell). Most of these examples are also available in the OpenModelica
notebook UsersGuideExamples.onb in the testmodels directory, see also Chapter 4.

1.2.1  Starting the Interactive Session

The Windows version which at installation is made available in the start menu as OpenModelica-
>0penModel ica Shel I which responds with an interaction window:

{ifi oMshell - Opentodelica Shell =10l x|
File Edit WView Help
s B @32 0Ol

CpenModelica 1.4.5 =

Copyright (c) o0OSMC 2002-2008

To get help on using CMShell and OpenModelica, type "help()"

and press snter.

3

L

Ready &

We enter an assignment of a vector expression, created by the range construction expression 1:12, to be stored
in the variable x. The value of the expression is returned.

>> x = 1:12
{1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12}

1.2.2  Trying the Bubblesort Function
Load the function bubblesort, either by using the pull-down menu File->Load Model, or by explicitly
giving the command:

>> loadFile("'C:/0OpenModelical.4.5/testmodels/bubblesort.mo')

true
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The function bubblesort is called below to sort the vector x in descending order. The sorted result is returned
together with its type. Note that the result vector is of type Real[:], instantiated as Real [12], since this is
the declared type of the function result. The input Integer vector was automatically converted to a Real
vector according to the Modelica type coercion rules. The function is automatically compiled when called if
this has not been done before.

>> bubblesort(x)
{12.0,12.0,10.0,9.0,8.0,7.0,6.0,5.0,4.0,3.0,2.0,1.0}

Another call:

>> bubblesort({4,6,2,5,8})
{8.0,6.0,5.0,4.0,2.0}

It is also possible to give operating system commands via the system utility function. A command is provided
as a string argument. The example below shows the system utility applied to the UNIX command cat, which
here outputs the contents of the file bubblesort.mo to the output stream. However, the cat command does not
boldface Modelica keywords — this improvement has been done by hand for readability.

>> cd(*'C:/OpenModelical.4_5/testmodels™)
>> system(*'cat bubblesort.mo')

function bubblesort

input Real[:] Xx;

output Real[size(x,1)] vy:
protected

Real t;
algorithm

y = X3

for i in 1l:size(x,1) loop

for j in 1:size(x,1) loop
if y[i] > y[J1 then

t o= y[i];
yLil == yLil:
yl = t;
end if;
end for;
end for;

end bubblesort;

1.2.3  Trying the system and cd Commands

Note: Under Windows the output emitted into stdout by system commands is put into the winmosh console
windows, not into the winmosh interaction windows. Thus the text emitted by the above cat command would
not be returned. Only a success code (0 = success, 1 = failure) is returned to the winmosh window. For
example:

>> system(*'dir')
0

>> system("'Non-existing command'™)
1

Another built-in command is cd, the change current directory command. The resulting current directory is
returned as a string.

>> cd()
"C:\OpenModelical.4_5\testmodels"
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>> cd(™..™)
""C:\OpenModelical.4.5"

>> cd(*'C:\\OpenModelical.4.5\\testmodels'™)
"C:\OpenModelical.4_5\testmodels"

1.2.4 Modelica Library and DCMotor Model

We load a model, here the whole Modelica standard library, which also can be done through the File->Load
Modelica Library menu item:

>> loadModel (Modelica)
true

We also load a file containing the dcmotor model:

>> loadFile('C:/0OpenModelical.4._5/testmodels/dcmotor._mo™)
true

It is simulated:
>> simulate(dcmotor,startTime=0.0,stopTime=10.0)

record
resultFile = "dcmotor_res.plt"”
end record

We list the source code of the model:
>> list(dcmotor)

“"model dcmotor
Modelica.Electrical .Analog.Basic.Resistor r1(R=10);
Modelica.Electrical .Analog.Basic. Inductor il;
Modelica.Electrical .Analog.Basic.EMF emfl;
Modelica.Mechanics.Rotational . lnertia load;
Modelica.Electrical .Analog.Basic.Ground g;
Modelica.Electrical .Analog.Sources.ConstantVoltage v;
equation
connect(v.p,rl.p);
connect(v.n,g.p);
connect(rl.n,il.p);
connect(il.n,emfl.p);
connect(emfl.n,g.-p);
connect(emfl.flange_b, load.flange_a);
end dcmotor;

We test code instantiation of the model to flat code:
>> instantiateModel (dcmotor)

"fclass dcmotor

Real rl.v "Voltage drop between the two pins (= p-v - n.v)";
Real rl.i "Current flowing from pin p to pin n";

Real rl.p.v "Potential at the pin";

Real rl.p.i "Current flowing into the pin";

Real rl.n.v "Potential at the pin";

Real rl.n.i "Current flowing into the pin";

parameter Real r1.R = 10 "Resistance";

Real il.v "Voltage drop between the two pins (= p.v - n.v)";



15

Real il.i "Current flowing from pin p to pin n";
Real il.p.v "Potential at the pin";

Real il.p.i "Current flowing into the pin";

Real il.n.v "Potential at the pin";

Real 1l.n.i "Current flowing into the pin";

parameter Real il.L = 1 "Inductance™;

parameter Real emfl_k = 1 "Transformation coefficient";

Real emfl.v "Voltage drop between the two pins';

Real emfl.i "Current flowing from positive to negative pin";
Real emfl.w "Angular velocity of flange_b™;

Real emfl.p.v "Potential at the pin";

Real emfl.p.i "Current flowing into the pin';

Real emfl.n.v "Potential at the pin";

Real emfl.n.i "Current flowing into the pin";

Real emfl.flange b.phi "Absolute rotation angle of flange";
Real emfl.flange _b.tau '""Cut torque in the flange";

Real load.phi "Absolute rotation angle of component (= flange_a.phi = flange_b.phi)";
Real load.flange_a.phi "Absolute rotation angle of flange";
Real load.flange _a.tau '"Cut torque in the flange™;

Real load.flange_b.phi "Absolute rotation angle of flange";
Real load.flange b.tau ""Cut torque in the flange";

parameter Real load.J = 1 "Moment of inertia";

Real load.w "Absolute angular velocity of component';

Real load.a "Absolute angular acceleration of component';
Real g.p.v "Potential at the pin';

Real g.p.i "Current flowing into the pin";

Real v.v "Voltage drop between the two pins (= p.v - n.v)";
Real v.i "Current flowing from pin p to pin n";

Real v_p.v "Potential at the pin";

Real v.p.i "Current flowing into the pin";

Real v.n.v "Potential at the pin";

Real v.n.i "Current flowing into the pin";

parameter Real v.V = 1 "Value of constant voltage";

equation
ri.R * ri1.i = rl.v;

ri.v

rl.p.v - rl.n.v;

0.0 = rl.p.i + rl.n.i;

*
1

(S]

emfl._Kk
emfl_flange b.tau = -(emfl.k * emfl.i);
load.w
load.a
load.J

load.flange_a.phi
load.flange_b.phi

©

< o< <@
= O < <

<

<< << |

emfl.flané
emfl._flang

rl.p.i;

der(il.i) = il.v;
il.p.v - il.n.v;

l.p.i +il.n.i;
il.p.i;

= emfl.p.v - emfl.n.v;
mfl.p.i + emfl.n.i;

i =emfl.p.i;

= der(emfl_flange_b._phi);
* emfl.w = emfl.v;

der(load.phi);
der(load.w);
* load.a

= load.phi;
= load.phi;
0.0;

.V;

<

+ 1
< <

-n.
-n.

- <

-p-
.p-
-p

D (D ==

 b.tau + load.flange_a.-tau = 0.0;
_b._phi

= load.flange_a.phi;

load.flange_a.tau + load.flange_b.tau;
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emfl.n.i + v.n.i + g.p.i = 0.0
emfl.n.v = v.n.v;

V.Nn.v = g.p.Vv;

il.n.i + emfl.p.i = 0.0;
il.n.v = emfl.p.v;

rl.n.i + il.p.i = 0.0;

rl.n.v = il.p.v;

v.p-i + rl.p.i = 0.0;

i

V.p.v = rl.p.v;

load.flange_b.tau = 0.0;
end dcmotor;

We plot part of the simulated result:

>> plot({load.w, load.phi})
true

Il Flot Window - 0| x|
File Edit Insert Tools Help
J_| Open; Save | Print | Select | Zoom Pan | Grid | Hold | Preferences | Active | Image
Plot by OpenlModelica
3.5
3
2.5 @ load.w
2
1.5
@ oad.phi
1
0.5
1]
2 4 B 3
time
Connection closed 4

1.2.5 The val() function

The val(variableName,time) scription function can be used to retrieve the interpolated value of a simulation
result variable at a certain point in the simulation time, see usage in the BouncingBall simulation below.
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1.2.6  BouncingBall and Switch Models

We load and simulate the BouncingBall example containing when-equations and if-expressions (the Modelica
key-words have been bold-faced by hand for better readability):

>> loadFile("'C:/OpenModelical.4.5/testmodels/BouncingBall_mo')
true

>> list(BouncingBall)
"model BouncingBall
parameter Real e=0.7 "coefficient of restitution”;
parameter Real g=9.81 "gravity acceleration";
Real h(start=1) "height of ball";
Real v "velocity of ball";
Boolean flying(start=true) "true, if ball is flying";
Boolean impact;
Real v_new;
equation
impact=h <= 0.0;
der(v)=if flying then -g else 0;
der(h)=v;
when {h <= 0.0 and v <= 0.0, impact} then
v_new=i1f edge(impact) then -e*pre(v) else 0;
flying=v_new > 0;
reinit(v, v_new);
end when;
end BouncingBall;"

Instead of just giving a simulate and plot command, we perform a runScript command on a .mos
(Modelica script) file sim_BouncingBal I .mos that contains these commands:

loadFile(*'BouncingBall_mo™);
simulate(BouncingBall, stopTime=3.0);
plot({h,flying});

The runScript command:

>> runScript("'sim_BouncingBall .mos')
""true
record

resultFile = "BouncingBall_res._plt"
end record
true
true"

£ tmpPlot.plt ] 3]

File Edit Special

Plot by OpenModelica

lying ®

047 7

021 7

nop

0.0 (1§} 1.0 14 20 25 3.0
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We enter a switch model, to test if-equations (e.g. copy and paste from another file and push enter):

>> model Switch
Real v;
Real 1i;
Real i1;
Real itot;
Boolean open;
equation
itot = 1 + il;

if open then

v = 0;
else
i =0;
end if;
1 - il =0;

1-v-1-=0;

open = time >= 0.5;
end Switch;
Ok

>> simulate(Switch, startTime=0, stopTime=1);

Retrieve the value of itot at time=0 using the val (variableName,time) function:

>> val(itot,0)
1

Plot itot and open:

>> plot({itot,open})
true

e tmpPlot.plt
File Edit Special

Plot by OpenModelica
2':' | T T T T T ] Dpen =
itot

0.0

oo 01 02 03 04 05 06 0OF 08 09 10

We note that the variable open switches from false (0) to true (1), causing itot to increase from 1.0 to 2.0.

1.2.7 Clear All Models

Now, first clear all loaded libraries and models:

>> clearQ)



true

List the loaded models — nothing left:
>> list()

1.2.8 VanDerPol Model and Parametric Plot

We load another model, the VanDerPol model (or via the menu File->Load Model):

>> loadFile('C:/0OpenModelical.4._5/testmodels/VanDerPol _mo™))
true

It is simulated:

>> simulate(VanDerPol)
record

resultFile = "VanDerPol_res._plt"”
end record

It is plotted:
plotParametric(x,y);

i tmpPlot.plt O] =]

File Edit Special

Plot by OpenModelica

-2.0 -1.58 -1.0 -0.5 0.0 0.4 1.0 1.5 2.0

Perform code instantiation to flat forrm of the vanDerPol model:
>> instantiateModel (VanDerPol)

"fclass VanDerPol

Real x(start=1.0);

Real y(start=1.0);

parameter Real lambda = 0.3;

equation
der(x) = vy;
der(y) -x + lambda * (1.0 - x * xX) * y;

end VanDerPol;
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1.2.9  Scripting with For-Loops, While-Loops, and If-Statements

A simple summing integer loop (using multi-line input without evaluation at each line into OMShell requires
copy-paste as one operation from another document):
>> k 1= 0;
for 1 in 1:1000 loop
k ;= k + 1
end for;

>> k
500500

A nested loop summing reals and integers::

g := 0.0;
h = 5;
for 1 in {23.0,77.12,88.23} loop
for j in 1:0.5:(i+1) loop
g :=9+]J;
g:=g+h/2;
end for;
h = h + g;
end for;

By putting two (or more) variables or assignment statements separated by semicolon(s), ending with a variable,
one can observe more than one variable value:

>> h;g
1997.45
1479.09

A for-loop with vector traversal and concatenation of string elements:

>> pI="";
Ist := {"Here ", "are ","some ","strings."};
s = "";
for 1 in Ist loop
S :1=s + 1;
end for;
>> s

"Here are some strings."

Normal while-loop with concatenation of 10 "abc " strings:

>> sI="";
i:=1;
while i<=10 loop
s:="abc "+s;
1:=i+1;
end while;
>> s
""abc abc abc abc abc abc abc abc abc abc ™

A simple if-statement. By putting the variable last, after the semicolon, its value is returned after evaluation:

>> if 552 then a := 77; end if; a
77

An if-then-else statement with elseif:

>> if false then
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a = 5;
elseif a > 50 then
b:= "test'; a:= 100;
else
a:=34;
end if;
Take a look at the variables a and b:
>> a;b
100
"test"”

1.2.10 Variables, Functions, and Types of Variables

Assign a vector to a variable:

>> a:=1:5
{1,2,3,4,5}

Type in a function:

>> function MySqr input Real x; output Real y; algorithm y:=x*x; end MySqr;
Ok

Call the function:

>> b:=MySqr(2)
4.0

Look at the value of variable a:

>> a
{1.,2,3,4,5}

Look at the type of a:

>> typeOf(a)
"Integer[]”

Retrieve the type of b:

>> typeOf(b)
"Real""

What is the type of MySqr? Cannot currently be handled.

>> typeOf(MySqr)
Error evaluating expr.

List the available variables:

>> listVariables()
{currentSimulationResult, a, b}

Clear again:

>> clearQ)
true
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1.2.11 Using External Functions
The following is a small example (ExternalLibraries.mo) to show the use of external functions:

model ExternallLibraries
Real x(start=1.0),y(start=2.0);

equation
der(x)=-ExternalFuncl(x);
der(y)=-ExternalFunc2(y);

end ExternalLibraries;

function ExternalFuncl
input Real x;
output Real y;
external
y=ExternalFuncl_ext(x) annotation(Library="1ibExternalFuncl_ext.o",
Include="#include \"ExternalFuncl_ext_h\""");
end ExternalFuncl;

function ExternalFunc?2
input Real x;
output Real y;
external "C" annotation(Library="libExternalFunc2.a",
Include="#include \"ExternalFunc2.h\""");
end ExternalFunc2;

These C (.c) files and header files (.h) are needed:

/* File: ExternalFuncl.c */
double ExternalFuncl_ext(double x)

double res;
res = x+2.0*X*x;
return res;

}

/* Header file ExternalFuncl_ext.h for ExternalFuncl function */
double ExternalFuncl_ext(double);

/* File: ExternalFunc2.c */
double ExternalFunc2(double x)

double res;
res = (x-1.0)*(x+2.0);
return res;

}

/* Header file ExternalFunc2.h for ExternalFunc2 */

double ExternalFunc2(double);
The following script file ExternalLibraries.mos will perform everything that is needed, provided you
have gcc installed in your path:

loadFile("ExternalLibraries.mo™);

system(‘'gcc -c¢ -o libExternalFuncl_ext.o ExternalFuncl.c');
system(''gcc -c -o libExternalFunc2.a ExternalFunc2.c™);
simulate(ExternallLibraries);

We run the script:

>> runScript(“ExternalLibraries.mos™);
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and plot the results:
>> plot({x,y}):

< tmpPlot.plt

File Edit Special

Plet by OpenModelica

Qe 1x E
Y.
151 ]
1.0[ ]
&L i

oo 01 2z 03 04 05 06 OF 08 08 1.0

1.2.12 Calling the Model Query and Manipulation API

In the OpenModelica System Documentation, an external API (application programming interface) is described
which returns information about models and/or allows manipulation of models. Calls to these functions can be
done interactively as below, but more typically by program clients to the OpenModelica Compiler (OMC)
server. Current examples or such clients are the OpenModelica MDT Eclipse plugin, OMNotebook, the
MathModelica Lite graphic model editor, etc. This API is untyped for performance reasons, i.e., no type
checking and minimal error checking is done on the calls. The results of a call is returned as a text string in
Modelica syntax form, which the client has to parse. An example parser in C++ is available in the
OMNotebook source code, whereas another example parser in Java is available in the MDT Eclipse plugin.
Below we show a few calls on the previously simulated BouncingBall model. The full documentation on
this API is available in the system documentation. First we load and list the model again to show its structure:

>>loadFile(*'C:/0OpenModelical.4.5/testmodels/BouncingBall_mo™)
true

>>list(BouncingBall)

"model BouncingBall
parameter Real e=0.7 "coefficient of restitution”;
parameter Real g=9.81 "gravity acceleration";
Real h(start=1) "height of ball";
Real v "velocity of ball";
Boolean flying(start=true) "true, if ball is flying";
Boolean impact;
Real v_new;
equation
impact=h <= 0.0;
der(v)=if flying then -g else 0;
der(h)=v;
when {h <= 0.0 and v <= 0.0, impact} then
v_new=if edge(impact) then -e*pre(v) else 0;
flying=v_new > 0;
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reinit(v, v_new);
end when;
end BouncingBall;

Different kinds of calls with returned results:

>>getClassRestriction(BouncingBall)
"model™’

>>getClassInformation(BouncingBall)
{"'model™ """, {false, false,false},{"writable™,1,1,18,17}}

>>isFunction(BouncingBall)
false

>>existClass(BouncingBall)
true

>>getComponents(BouncingBall)

{{Real,e,"coefficient of restitution”, "public”, false, false, false,
"parameter', '"'none', "unspecified"},

{Real,g,"gravity acceleration®,

"public", false, false, false, '"parameter', "none', "unspecified"},
{Real,h,”height of ball', "public", false, false, false,
"unspecified", "none', "unspecified"},

{Real,v,"velocity of ball",

“"public", false, false, false, "unspecified", "none", "unspecified"},
{Boolean,flying,"true, if ball is flying"”, "public”, false, false,
false, "unspecified”, "none', "unspecified"},

{Boolean, impact,"",

“"public", false, false, false, "unspecified”, "none", 'unspecified"},
{Real,v_new,"", "public"”, false, false, false, "unspecified”, '"none",
"unspecified"}}

>>getConnectionCount(BouncingBall)
0

>>getlnheritanceCount(BouncingBall)
0

>>getComponentModifierValue(BouncingBall,e)
0.7

>>getComponentModifierNames(BouncingBall,e)

>>getClassRestriction(BouncingBall)
"model™

>>getVersion() // Version of the currently running OMC
"1.4.5"

1.2.13 Quit OpenModelica

Leave and quit OpenModelica:
>> quit(Q)
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1.2.14 Dump XML Representation

The command dumpXMLDAE dumps an XML representation of a model, according to several optional
parameters.

dumpXMLDAE(modelname[,asInSimulationCode=<Boolean>] [,filePrefix=<String>]
[,storelnTemp=<Boolean>] [,addMathMLCode =<Boolean>])

This command dumps the mathematical representation of a model using an XML representation, with optional
parameters. In particular, asInSimulationCode defines where to stop in the translation process (before
dumping the model), the other options are relative to the file storage: filePrefix for specifying a different
name and storelnTemp to use the temporary directory. The optional parameter addMathMLCode gives the
possibility to don't print the MathML code within the xml file, to make it more readable.Usage is trivial, just:
addMathMLCode=true/false (default value is false).

1.2.15 Dump Matlab Representation

The command export dumps an XML representation of a model, according to several optional parameters.
exportDAEtoMatlab(modelname);

This command dumps the mathematical representation of a model using a Matlab representation. Example:

$ cat daequery.mos
loadFile(*'BouncingBall.mo™);
exportDAEtoMatlab(BouncingBall);
readFile(""BouncingBall_imatrix.m");

$ omc daequery.mos
true
"The equation system was dumped to Matlab file:BouncingBall _imatrix.m"

% Incidence Matrix
%
% number of rows: 6

IM={[3,-6],[1,{"if", "true”,"==" {3},{}.}1.[2.{"if", “edge(impact)”
{3}.{5}.}31.[4.2]1.[5.{"if", “true”,"==" {4},{}.}1.[6.-51};

VL = {"foo","v_new", "impact”, "flying®,"v","h"};

EqStr = {"impact = h <= 0.0;","foo = if impact then 1 else 2;","when {h <= 0.0 AND v
<= 0.0, impact} then v_new = if edge(impact) then (-e) * pre(v) else 0.0; end
when; ", *when {h <= 0.0 AND v <= 0.0, impact} then flying = v_new > 0.0; end
when; ", "der(v) = if flying then -g else 0.0;","der(h) = v;"};

OldEgStr={"fclass BouncingBall", "parameter Real e = 0.7 "coefficient of
restitution';", "parameter Real g = 9.81 "'gravity acceleration';", "Real h(start = 1.0)
"height of ball";","Real v "velocity of ball";","Boolean flying(start = true) "true,
if ball is flying";", "Boolean impact;*,"Real v_new;","Integer foo;","equation”,”
impact = h <= 0.0;"," Too = if impact then 1 else 2;"," der(v) = if flying then -g
else 0.0;"," der(h) =v;"," when {h <= 0.0 AND v <= 0.0, impact} then"," v _new = i
edge(impact) then (-e) * pre(v) else 0.0;"," flying = v_new > 0.0;","

reinit(v,v_new);"," end when;","end BouncingBall;",""};"

f
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1.3

Summary of Commands for the Interactive Session Handler

The following is the complete list of commands currently available in the interactive session hander.

simulate(modelname)

Translate a model named modelname and simulate it.

simulate(modelname[,startTime=<Real>][,stopTime=<Real>][,numberOfintervals

plot(vars)

plotParametric(varl, var2)

cdO

cd(dir)

clear()
clearVariables()
dumpXMLDAE(modelname, ...)

=<lInteger>]) Translate and simulate a model, with optional start time, stop
time, and optional number of simulation intervals or steps for which the
simulation results will be computed. Many steps will give higher time
resolution, but occupy more space and take longer to compute. The default
number of intervals is 500.

Plot the variables given as a vector or a scalar, e.g. plot({x1,x2}) or
plot(x1)

Plot var2 relative to varl from the most recently simulated model, e.g.
plotParametric(x,y).

Return the current directory.

Change directory to the directory given as string.

Clear all loaded definitions.

Clear all defined variables.

Dumps an XML representation of a model, according to several optional
parameters.

exportDAEtoMatlab(name) Dumps an Matlab representation of a model.

instantiateModel (modelname)Performs code instantiation of a model/class and return a string containing

listQ
1ist(modelname)
listvariables(Q
loadModel (classname)

loadFile(str)
readFile(str)
runScript(str)
system(str)

timing(expr)

typeOf(variable)
saveMode I (str, modelname)

helpQ
quitQ

the flat class definition.

Return a string containing all loaded class definitions.

Return a string containing the class definition of the named class.
Return a vector of the names of the currently defined variables.

Load model or package of name classname from the path indicated by the
environment variable OPENMODEL I CAL I BRARY.

Load Modelica file (.mo) with name given as string argument str.
Load file given as string str and return a string containing the file content.
Execute script file with file name given as string argument str.

Execute str as a system(shell) command in the operating system; return
integer success value. Output into stdout from a shell command is put into
the console window.

Evaluate expression expr and return the number of seconds (elapsed time)
the evaluation took.

Return the type of the variable as a string.

Save the model/class with name modelname in the file given by the string
argument str.

Print this helptext (returned as a string).
Leave and quit the OpenModelica environment
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Chapter 2

Using the Graphical Model Editor

This chapter just presents a very simple example of using graphical modeling of Modelica models using the
SimForge graphical editor that can be used together with OpenModelica. More detailed documentation is
available at: http://trac.elet._polimi.it/simforge.

A model is built using the graphical model editor by using drag-and-drop of already developed and freely
available model components from the Modelica Standard Library.

2.1 Getting Started

Install Java, OpenModelica and SimForge according to the Installation Notes.

Important: when launching SimForge for the first time, go to Tools|Settings, and set the paths.
On Windows machines:

e OPENMODELICAHOME contains the OpenModelica root directory, e.g.
C:\OpenModelical.4.5

e OPENMODELICALIBRARY points to the directory which contains the Modelica directory of your
favourite Modelica Standard Library package; you can use the one provided with the OpenModelica
installation, e.g., C: \OpenModelical.4.5\ModelicalLibrary

e LD LIBRARY_PATH is irrelevant

On linux machines:

e OPENMODELICAHOME must point to the directory which contains the bin subdirectory where the
omc (OpenModelica compiler) executable is located, e.g., /usr/share/openmodelica-1.4/

e OPENMODELICALIBRARY points to the directory which contains the Modelica directory of your
favourite  Modelica Standard Library package, e.g., /usr/share/openmodelica-
1.4/modelica-2.2/

e LD _LIBRARY_PATH points to the directory containing the Libmico library; you can use the one
provided by your OpenModelica installation, e.g. /usr/lib/mico-openmodelica-1.4

These will be the default choices for all the new projects which are created. They can be overridden within each
project by using project-specific settings.
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2.2 Creating a new project

Go to File|New project. Choose a name for the project - this will be the name of the directory containing all
project files, so it must be a legal directory name - and select the path where you want this new directory to be
created.

SF SimForge EIEIZI
File Tools Help
L L3 LS |

P 2
[

G ]|
= fido -] [=][&] (=] [EElE]

(5 Desktop 3 SimpleFluid

Look In:

=3 Documents | Templates

[ Examples  gtmp
=3 flexdock g varken

Path: Browse - Music [ Videos
[ Pictures 3 Work

Cancel 5 Public g workspace

(g SimForge-0.8

SF Creating project E

Project name:

Folder name: |,'homeifi\do

Files of Type: |AII Files |-|

b o [ |

HEN [v]

SimForge will create the project directory, which contains: the IEC61131 directory, for IEC 61131 controllers
code, the Modelica directory, for Modelica code, the Results directory, for permanent storage of simulation
results, the Temp directory for temporary files, and the Properties.xml file for the project properties.

Double-click on the Modelica node of the project tree. The three nodes contain the following elements:

e Used external packages: all the packages which are used by the project, but which are not part of the
project itself, so they are read-only, and are not contained within the project directory. Examples: the
Modelica Standard Library, or any other free or commercial third-party library that will be used by the
current project.

e Modelica classes: a tree view of all the models and packages defined within the project, irrespective of
their actual representation as single files or structured entities (i.e., sub-directories). Models within this
tree can be edited in both graphics and textual modes.

e Modelica files: a view of all the .mo files contained in the project. Can be useful to inspect files, and
rearrange the file contents. Text-only editing.
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SimtEorge = /home/hldo/tmp/NewProject

File Edit Vview Tools Window Help

=2l @ |

MNewProject |v M

5 Modelica

o 9 Used external packages
[ S| Modelica classes

D Modelica files

=3 /EC61131-3

D SFC

0 Ladder

D Dictionary
D Connections

[y [simulation result

[

<]

At this point you can create one or more top-level models or packages, which will be saved in the Modelica
subdirectory of the project. For instance, right-click on Modelica classes and type TestPackage as the package
name, Package as the class type. If you leave 'structured entity' unchecked, the package will be saved as a
single .mo file, otherwise it will be saved as a sub-directory containing a package.mo file plus files for all other

contained classes.

SF SimForge - fhome/fildo/tmp/NewProject EIEIE
File Edit View Tools Window Help

e i R |

NewProject |- : 1=
g Modelica E

o [ Used external packages
[ ] Modelica classes

0 Modelica files

= IEC61131-3

D SFC

[y Ladder

D Dictionary

D Connections

Name: ‘Test?ackage ‘

0 Simulation result

Type: ‘Fa:kaga |'|

[ Structured entity (directory) h

|
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Now right-click on TestPackage in the project tree, select 'Add class', then type in ModelA and select model as

the type of class.

SF SimForge - fhome/fildo/tmp/NewProject EE]E
File Edit View Tools Window Help

el B |

NewProject |v : el
=5 Modelica

o 9 Used external packages
¢ [ Modelica classes
[ TestPackage
[ Modelica files
7 /EC61131-3
D SFC
0O Ladder
D Dictionary
[ Connections Name: ‘MOdeIA |

N} Simulation result

Type: ‘Mude\ |v‘

[ Structured entity (directory)

| B

-

<] [

Double-click on the ModelA node to open the text and graphical editors. You can now start editing your model.
The three icons on the right of the tool bar can be used to check the model, compile and simulate it, and to
show the omc console.

SimEorge = /home/fldo/tmp/NewProject

Eile Edit View Tools Window Help

wDeHWe | B2 |

NewProject "

i A AR ‘ RESH | = ‘ K@= degem
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You can now customize the project properties. Click on Tools|Project properties. The General tab provides
information about the project's path, as well as some user-defined comments to the project.
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:: s Add
Kl
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The Modelica tab contain the following settings:

e The OPENMODELICAHOME, OPENMODELICALIBRARY, and LD_LIBRARY_PATH paths for
this project. By default these are set to the tool settings, but it is possible to customize them by clicking
on the checkbox and providing a new path, so that each project can use its own version of OMC,
Modelica Standard Library, and OMC runtime libraries.

e A checkbox to load the Modelica Standard Library. If you want to use the Modelica Standard Library
for your project, you have to set this checkbox explicitly when you first create the project, and make
sure you then click on the Reload omc button, so that omc loads the standard library, and makes it
visible immediately in the project tree. This is not necessary when you later re-open the project, as the
required Modelica library will be loaded automatically.

e Additional external libraries: you can add them here by giving the paths of the packages. They will
show up under the Used external packages node of the project tree, as read-only classes.

Note that it is possible to load multiple projects at the same time in SimForge. They can be selected by the
drop-down menu on top of the project tree. Each project talks to a separate instance of OMC, so it is possible to
open different projects using different versions of OpenModelica and standard library at the same time within a
single instance of the SimForge application. It is also possible to load two different projects that contain two
different versions of the same package (thus with the same name). All the class editing windows contain
information about the project name, so that there's no chance of being confused.
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Chapter 3

2D Plotting and 3D Animation

This chapter covers 2D plotting available from OMNotebook, OMShell or programmable plotting from your
own Modelica model. The 3D animation is currently available only from OMNotebook (and not on Mac).

3.1 Enhanced Qt-based 2D Plot Functionality

Starting with OpenModelica 1.4.5, new enhanced plotting functionality is available (Eriksson, 2008). The new
plotting is implemented based on a Qt-based (Trolltech, 2007) GUI package. This new plotting functionality
has additional features compared to the old Java-based PtPlot plotting. The simulation data is sent directly to
the plotting window in OMNotebook (or a popup window if called from OMShell), which handles the
presentation (see Figure 3-1). As OMNotebook now has access to all source data it is now be possible to
manipulate diagrams, e.g. zoom or change scales.

To allow the use of graphics functions from within Modelica models a hew Modelica interface has been
developed. This utilizes an external library to communicate with OMNotebook. In addition to this, a number of
new functions that can be used for drawing geometric objects like circles, rectangles and lines have been added.

The following is a summary of the capabilities of the new 2D graphics package:

e Interaction with OMNotebook. The graphics package has been developed to be fully integrated with
OMNotebook and allow modifications of diagrams that have been previously created.

e Usage without OMNotebook. If the functionality of the graphics package is used without OMNotebook,
a new window should be opened to present the resulting graphics.

e Logarithmic scaling. Some applications of OpenModelica produce simulation data with large value
ranges, which is hard to make good plots of. One solution to this problem is to scale the diagram
logarithmically, and this is allowed by the graphics package.

e Zoom. To allow studying of small variations the user is allowed to zoom in and out in a diagram.

e Support for graphic programming. To allow creation of Modelica models that are able to draw
illustrations, show diagrams and suchlike, it is possible to use the graphics package not only from the
external APl of OMC, but also from within Modelica models. To accomplish this a new Modelica
interface for the graphics package has been created.

e Programmable Modelica API. The Modelica API is defined by a number of Modelica functions, located
in the package Modelica.Graphics.Plot, which use external libraries to access functionality of the
graphics package.

The programmable Modelica API functions include the following:

e plot(x). Draws a two-dimensional line diagram of x as a function of time.
e plotParametric(x,y). Draws a two-dimensional parametric diagram with y as a function of x.
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e plotTable([X1, .., Y1; .. ; Xn, .., Yn]). Draws a two-dimensional parametric diagram with y as a function
of x.

e drawRect(x1, X2, y1, y2). Draws a rectangle with vertices in (x1, y1) and (x2, y2).

e drawEllipse(x1, X2, y1, y2). Draws an ellipse with the size of a rectangle with vertices in (x1, y1) and
(x2, y2).

e drawLine(xl, x2, y1, y2). Draws a line from (x1, y1) to (x2, y2).

CORBA: answer. i.e. done

h |
TCP/IP: simulation data
OoMC = GraphWidget
= Resutiie
. GraphCell
CORBA: plot OMMNotebook

Figure 3-1. Plotting architecture with the new 2D graphics package.

3.2 Simple 2D Plot

To create a simple time plot the model Hel loWor Id defined in DrModelica is simulated. To reduce the amount
of simulation data in this example the number of intervals is limited with the argument
numberOfIntervals=10. The simulation is started with the command below.

simulate(HelloWorld, startTime=0, stopTime=4, numberOflntervals=10);

When the simulation is finished the file Hel loworld res.plt contains the simulation data. The contents of
the file is the following (some formatting has been applied).

0 1
4.440892098500626e-013 0.9999999999995559
0.4444444444444444 0.6411803884299349
0.8888888888888888 0.411112290507163
1.333333333333333 0.2635971381157249
1.777777777777778 0.1690133154060587
2.222222222222222 0.1083680232218813
2.666666666666667 0.06948345122279623
3.111111111111112 0.04455142624447787
3.555555555555556 0.02856550078454138
4 0.01831563888872685

Diagrams are now created with the new graphics package by using the following command.
plot(x);
seems to correspond well with the data.
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Plot by OpenModelica
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Figure 3-2. Simple 2D plot of the HelloWorld example.

By re-simulating and saving results at many more points, e.g. using the default 500 intervals, a much smoother
plot can be obtained.

simulate(HelloWorld, startTime=0, stopTime=4, numberOflntervals=500);
plot(x);

plot (x) |

true

BN

0.6
\\\NH\H { | .x
0.4
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Figure 3-3. Simple 2D plot of the HelloWorld example with larger number of points.

Additional features of the new plotting are shown in Figure 3-4 and Figure 3-5.

=

File Edit Insert Tools Help

J_| Open  Save | Print | Select | Zoom Pan | Grid | Preferences | Active

Plot by OpenModelica

r.
|T Show line
|T Show data points

Change color

time

4

Figure 3-4. Features of the new Qt-based Plotting Package: Show data points, Change line colors, etc.
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Clear
0.33
Hold

Antialiasing \
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Preferences 1
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Figure 3-5. Features of the new Qt-based Plotting Package: Zoom, Fit in view, Grid, etc.

3.2.1  All Plot Functions and their Options

The plot functions can be used in a number of ways, depending on the arguments that are included with the

call. The following calls are supported.



38

Command Description

plot(x) Creates a diagram with data from the last simulation that
had a variable named x.

plot({x,y,---., z}) Like the previous command, but with several variables.

plot(model, Xx) Creates a diagram with data from the previously simulated
model model.

plot(model, {x,y,..., z}) | Like the previous, but with several variables.

plotParametric(x, y)

Creates a parametric diagram with data from the last
simulated variables named x and y.

plotParametric(model, x, | Creates a parametric diagram with data from the previously

y) simulated model model.

plotAll () Creates a diagram with all variables from the last simulated
model as functions of time.

plotAll(model) Creates a diagram with all variables from the model model

as functions of time.

All of these commands can have any number of optional arguments to further customize the the resulting
diagram. The available options and their allowed values are listed below.

Option Default value Description

grid true Determines whether or not a grid is shown in the
diagram.

title "Plot by OpenModelica"™ | This text will be used as the diagram title.

interpolation | linear Determines if the simulation data should be interpolated
to allow drawing of continuous lines in the diagram.
"linear” results in linear interpolation between data
points, “constant" keeps the value of the last known data
point until a new one is found and "none" results in a
diagram where only known data points are plotted.

legend true Determines whether or not the variable legend is shown.

points true Determines whether or not the data points should be
indicated by a dot in the diagram.

logX false Determines whether or not the horizontal axis is
logarithmically scaled.

logY false Determines whether or not the wvertical axis is
logarithmically scaled.

xRange {0, 0} Determines the horizontal interval that is visible in the
diagram. {0, 0} will select a suitable range.

yRange {0, 0O} Determines the vertical interval that is visible in the
diagram. {0, 0} will select a suitable range.

antiAliasing false Determines whether or not antialiasing should be used
in the diagram to improve the visual quality.

vTitle This text will be used as the vertical label in the
diagram.

hTitle “time” This text will be used as the horizontal label in the
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| diagram.

3.2.2 Zooming

The left mouse button can for instance be used for zooming in on interesting parts of the diagram.The same
result can be achieved by using the optional parameters xRange and yRange. The plotParametric

command would then look like the following.
plotParametric(x, y, XRange={0.9, 1.95}, yRange={-1.5, 1.35})

B
S OMNotebook: (untitled)®
File Edit Cel Format Insert ‘Window Help

¥ EJ = .l L ; = o 2] 4 69

plotParametric(x,y)

True

2H
i

154
1

=

0.5
o
0.5

-1

-1.5}-

2

Ready

Ln 1, Col 20

Figure 3-6. Zooming in an Input cell.

[
& OMNotebook: (untitled)*

File Edit Cel Format Insert Window Help
Ml = 8 8 X [« | @
| plotParametric(x,v)

true

0.5}

0.5}

Ready

Ln 1, Col 20

Figure 3-7. Magnified input cell.
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3.2.3 Plotting all variables of a model

A command, plotAll, has been introduced to plot all the variables of a model. This can be useful if a model
contains many interesting variables, as it might be easier to remove variables that are not important than to list
all those who are. The commands available for this are plotAlIl () and plotAll(model). If the optional
model parameter is omitted the last simulated model will be used. The command below applies plotAll to the
model HelloWorld. The result is shown in Figure 3-8. The simplest way to remove unimportant variables is to
use the Remove command in the Legend menu..

plotAll(HelloWorld);

plothAll (HelloWorld)
true
Plot by OpenModelica
TF] T | 1 T
|

- | @ sdummy

0. 5HEE __..._..-_'..::.'"_"'.;n..__.;. AEERANERNRERE INRESduUnUBERAH 114 ik
I el | | [ [ I
Ao et defete4b 4ot =1k 1t 4t +f 14 -‘_\_‘-‘—\—v\_._‘_\-._‘._l_\_‘_-_“_-. : 1 I : -+ 1 1 { IR Y 4 i .:(
|:| i Hi rlEH] 1 HH {RERERE i L I R SR 00 5 8 s s o e P P i
s et R D
..... LR _d__.__._F{—-——"'-‘_'__f"_: | @ der{sdummy)
e _."",

-0.5 ___.-’);_,..r"'f:__-.._ '""'“'""'i"""-"""""""'!‘:"'-"."'_"""“'i"%""'“"-‘"“'"““"" HULELHERE UL

% | | @ der{x)

B2
Vs . |
1 ! }
} 1 1.5 2 2.5 3 ~ 4
time

Figure 3-8. Result of the plotAll command.

3.24 Plotting During Simulation

When running long simulations, or if plotting without need for commands like plot or plotParametric is
desired, the interface for transfer of simulation data during running simulations can be used. This is enabled by
running the following command.

enableSendData(true)

The same command, but with the parameter false, is used to disable the interface. Enabling of the interface has
some drawbacks though. The simulation time will be longer as the transfer of data will require some resources.
If the simulation data would have been plotted anyway, some of this time will be saved later however. To
reduce the amount of data that has to be transferred, and thereby reduce the time needed to do so, the
interesting variables in the model can be specified with the command setVvariableFilter. If for instance the
model Hel loWor Id is to be simulated the following commands can be used.
class HelloWworld
Real x(start = 1);
parameter Real a = 1;
equation
der(x) = - a * x;
end HelloWorld;

enableSendData(true);
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setVariableFilter({x});
simulate(HelloWorld, startTime=0, stopTime=25);

When the simulation data has been transferred the button D will appear to the right of the input field. By
pressing this the dialog Simulation data will appear, where new curves can be created.

3.25 Programmable Drawing of 2D Graphics

The graphics package provides functions for drawing of basic geometrical objects in the graphics area. These
can be used from Modelica models and are executed when the model is simulated. To avoid name conflicts, the
functions have been put in the package Modelica.pltpkg. The functions of the Modelica programmable
plotting interface are described below.

plot(model, "x"). Creates a diagram with data from the variable x in the previously simulated model
model.

plot(model, "X, y"). Like the function above, but with more than one variable.

plotParametric(model, "X", "y"). Creates a parametric diagram with data from the variables x and y
in the previously simulated model model.

plotTable([x1, y1, z1, ...; X2, y2, z2, ...;...]). Draws y and z as functions of x..
clear().Clears the active GraphWidget.

rect(xi, X2, y1, y2). Draws a rectangle with vertices in (x1, y1) and (xz2, y2).

ellipse(x1, X2, y1, y2). Draws an ellipse with the size of a rectangle with vertices in (x1, y1) and (x2,
y2).

line(x1, x2, y1, y2). Draws a line from (x1, y1) to (x2, y2).

hold(Boolean on). Determines whether or not the active GraphWidget should be cleared before new
graphics is drawn.

wait(ms). Waits for (at least) ms milliseconds.

The following model shows how these functions can be used to draw ellipses, rectangles, and lines.

model testGeom
parameter Integer n=10;
protected
Boolean b[n,n];
equation
for x in 1:n loop

for y in 1:n loop

when initial() then
if((y == 1) or (y == 10) or (x == 1) or (x == 10)) then
b[x,y] = pltpkg.rect(x, y, x+1, y+1, FfillColor = "blue",
color = *‘green');
else if(y > 4 and y <= 5 and x >= 4 and x <= 5) then
b[x,y] = pltpkg.-line(x, y, x+1, y+1, color = "red");
else
b[x,y] = pltpkg.ellipse(x, y, x+1, y+1, fillColor = "yellow",
color = "black");
end if;
end if;
end when;

end for;

end for;
end testGeom;
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Figure 3-9. Programmable drawing of rectangles and ellipses.

3.2.6 Plotting of table data

Another way to visualize data provided by the graphics package is plotting of table data. This is done by using
the command pltpkg.plotTable, which expects a matrix of Real values as a parameter. The rows of this
matrix represent variable values. The first column is the time variable and the other columns contains values at
these points in time. The names of the variables can be specified with the argument variableNames, which is
a String list. The following model demonstrates how this command can be used.

model table
protected
Boolean b;
algorithm
b := pltpkg.pltTable([ 0, 0.95, 0.92, 20, 25;
10, 0.94, 0.92, 23, 28;
20, 0.94, 0.91, 32, 35;
30, 0.93, 0.90, 43, 46] ):
end table;

The result is shown in Figure 3-10
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Figure 3-10. Plotting of table data..
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3.3 Java-based PtPlot 2D plotting

The plot functionality in OpenModelica 1.4.4 and earlier was based on PtPlot (Lee, 2006), a Java-based plot
package produced within the Ptolemy project. To plot one uses plot commands within input cells which it
evaluates. Available plotting commands which calls Java-based plotting are as follows, still available but
renamed with a suffix 2:

// normal one variable plotting, time on the X axis

plot2( variable );

// normal multiple variable plotting, time on the X axis
plot2( {variablel, variable2, variable3, .. variableN} );

// to plot dependent values
plotParametric2( variableX, variableY );

For example:

simulate(HelloWorld, startTime=9, stopTime=4);
plot(x);

i)

File Edit Special

Plot by OpenModelica

0.0

0.0 0.5 1.0 1.8 2.0 25 a.n 34 4.0

Figure 3-11. Java-based PtPlot plot window.

34 3D Animation

There are two main approaches to add 3D graphics information to Modelica objects:

e Graphical annotations
e Graphical objects

Both of these approaches were investigated, but the second was finally chosen.
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3.4.1 Object Based Visualization

Since one important goal of this work is to come up with a system for visualization that might be used for
simulations done with the Modelica MultiBody library (Otter, 2008), it follows that much can be learned from
investigating currently available solutions. There are commercial software packages available that can visualize
MultiBody simulations.

The MultiBody package is well suited for visualization. Entities in a MultiBody simulation correspond to
physical entities in a real world and as such have many of the properties needed to correctly display them
within a visualization of the simulation, such as position and rotation. Other properties such as color and shape
can easily be added as properties or be decided based on the object type.

Instead of using annotations to encode information about how a certain object is supposed to look when
visualized, object based visualization creates additional Modelica objects of a predetermined type that can be
known to the client actually doing the visualization. These objects contain variables such as position, rotation
and size that can be connected to the simulated variables using ordinary Modelica equations. When asked to
visualize a model, the OpenModelica compiler can find variables in the model that are in the visualization
package and only send only those datasets over to the client doing the visualization, in this case OMNotebook.

Taking inspiration from the MultiBody library, a small package has been designed that provides a minimal
set of classes that can be connected to variables in the simulation. It is created as a Modelica package and can
be included in the Modelica Library. The package is called SimpleVisual, and consists of a small hierarchy
of classes that in increasing detail can describe properties of a visualized object. It is implemented on top of the
Qt graphics package called Coin3D (Coin3D, 2008). More information is available in (Magnusson, 2008). A
comprehensive earlier work on integrating and generating 3D graphics from Modelica models is reported in
(Engelson, 2000).

This section gives a short introduction to how the SimpleVisual package is used.

3.4.2 BouncingBall

The bouncing ball model is a simple example to the Modelica language. Adding visualization of the bouncing
ball using the SimpleVisual package is very straightforward.

model BouncingBall
parameter Real e=0.7 "coefficient of restitution”;
parameter Real g=9.81 "gravity acceleration";
Real h(start=10) "height of ball";
Real v "velocity of ball™;
Boolean flying(start=true) "true, if ball is flying";
Boolean impact;
Real v_new;
equation
impact=h <= 0.0;
der(v)=if flying then -g else 0;
der(h)=v;
when {h <= 0.0 and v <= 0.0, impact} then
v_new=iTf edge(impact) then -e*pre(v) else 0;
flying=v_new > 0;
reinit(v, v_new);
end when;
end BouncingBall;

To run a simulation of the bouncing ball, create a new InputCell and call the simulate command. The simulate
command takes a model, start time, and an end time as arguments.
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simulate(BouncingBall, start=0, end=5s);

3.4.2.1 Adding Visualization

The bouncing ball will be simulated with a red sphere. We will let the variable h control the y position of the
sphere. Since the ball has a size and the model describes the bouncing movement of a point, we will use that
size to translate the visualization slightly upwards. First, we must import the SimpleVisual package and
create an object to visualize. That is done by adding a few lines to the beginning of the BouncingBal I model,
which we rename to BouncingBal 13D to emphasize that we have made some changes:

model BouncingBall3D

import SimpleVisual.*
SimpleVisual .PositionSize ball "color=red;shape=sphere;";

The string "color=red;" is used to set the color parameter of the object and the shape parameter controls how
we will display this object in the visualization.

The next step is to connect the position of the ball object to the simulation. Since Modelica is an equation
based language, we must have the same number of variables as equations in the model. This means that even
though the only aspect of the ball that is really interesting is its y-position, each variable in the ball object must
be assigned to an equation. Setting a variable to be constant zero is a valid equation. The SimpleVisual library
contains a number of generic objects which gives the user an increasing amount of control.

SimpleVisual _Position
SimpleVisual .PositionSize
SimpleVisual .PositionRotation

SimpleVisual .PositionRotationSize
SimpleVisual .PositionRotationSize0_set

Since we are really only interested in the position of the ball, we could use SimpleVisual.Position, but to
make it a little bit more interesting we use SimpleVisual .PositionSize and make the ball a little bigger.

obj.size[1]=5; obj.size[2]=5; obj.size[3]=5;
obj.frame_a[1]=0; obj.frame_a[2]=h+obj.size[2]/2; obj.frame_a[3]=0;

A SimpleVisual .PositionSize object has two properties; size and frame_a. All are three dimensional
real numbers, or Real[3] in Modelica.

e size controls the size of the visual representation of the object.
e frame_a contains the position of the object.

3.4.2.2 Running the Simulation and Starting Visualization

To be able to simulate the model with the added visualization, OpenModelica must load the SimpleVisual
package.

loadLibrary(Modelica.SimpleVisual)

Now, call simulate once more. This time the simulation will generate values for the added SimpleVisual object
that can be read by the visualization in OMNotebook.

simulate(BouncingBall3D, start=0, end=5s);

To display the visualization, create an input cell and call the visualize in the input part of the cell.

visualize(BouncingBall3D);



46

L. GMNoteliool: bouncinegballiexample-onb) __J \_J \ﬂ
File Edit Cell Format Insert  Window Help
e .
2 Simulation
zimulats (BouncingBall, startTime=0, stopTime=10};
[done]
wvisualize(BouncingBall);
[done]
L]
0,753
Ready Dane Ln 1, Col 25

Figure 3-12. 3D animation of the bouncing ball model.

3.4.3 Pendulum 3D Example

This example explores a slightly more complex scenario where the visualization uses all the properties of a
SimpleVisual object. The model used is a simple ideal 2D pendulum, not modeling properties like friction, air
resistance etc.

class MyPendulum3D "Planar Pendulum"
constant Real P1=3.141592653589793;
parameter Real m=1, g=9.81, L=5;
Real F;
Real x(start=5),y(start=0);
Real vx,vy;
equation
m*der (vx)=-(X/L)*F;
m*der (vy)=-(y/L)*F-m*g;
der(x)=vx;
der(y)=vy;
XN2+yN2=L"2;
end MyPendulum3D;

Start by identifying the variables in the model that will be needed to create a visual representation of the
simulation.

e Real x and Real y hold the current position of the pendulum.
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e Real L is a parameter which holds the length of the pendulum.

3.4.3.1 Adding the Visualization

As before, to be able to use the SimpleVisual package we must import it.

class MyPendulum3D "‘Planar Pendulum™
import Modelica.SimpleVisual;

Adding a sphere to represent the weight of the pendulum is done in the same way the BouncingBall was
visualized. The variables x and y hold the position.
ééél VX,VY;
SimpleVisual .PositionSize ball "color=red;shape=ball;";
equation
ball._size[1]=1.5; ball.size[2]=1.5; ball_.size[3]=1.5;
ball._frame_a[1]=x; ball_frame_a[2]=y; ball_frame_a[3]=0;
m*der (vx)=-(xX/L)*F;

The next step is to create a visualization of the "thread" that holds the pendulum. It will be represented by a
small elongated cube connected to the ball in one end and in the fixed center of the pendulum movement. We
will want the object to rotate with the pendulum motion so create a SimpleVisual.
PositionRotationSize object.

SimpleVisual .PositionRotationSize thread 'shape=cube;"

To specify the rotation of an object, the visualization package uses two points. One is the position of the object,
frame_a, that has been demonstrated earlier. The other position, frame_b, is interpreted as the end point of a
vector from frame_a. This vector is used as the new up direction for the object. In this example, defining
frame_b is simple. The cube that represents the thread will always be pointing to (0, 0, 0). We already know
the length of the thread from the parameter L.

thread.size[1]=0.05; thread.size[2]=L; thread.size[3]=0.05;

thread.frame_a[l]=x; thread.frame_a[2]=y; thread.frame_a[3]=0;
thread.frame_b[1]=0; thread.frame_b[2]=0; thread.frame_b[3]=0;

Running this simulation and starting the visualization, we notice that everything is not quite right. The thread is
centered around the pendulum. We could calculate a new position by translating the x and y coordinates along
the rotation vector, but there is a better way. Change the object type to SimpleVisual.
PositionRotationSizeOffset. The offset parameter is a translation within the local coordinate system of
the object. To shift the center of the object to be at the bottom of the thread we add an offset of L/2 to the y
component of offset.

thread.size[1]=0.05; thread.size[2]=L; thread.size[3]=0.05;
thread.frame_a[1]=x; thread.frame_a[2]=y; thread.frame_a[3]=0;
thread.frame_b[1]=0; thread.frame_b[2]=0; thread.frame_b[3]=0;
thread.offset[1]=0; thread.offset[2]=L/2; thread.offset[3]=0;

In the final model, a simple static fixture has also been added.

class MyPendulum3D "‘Planar Pendulum™
import Modelica.SimpleVisual;
constant Real P1=3.141592653589793;
parameter Real m=1, g=9.81, L=5;
Real F;
Real x(start=5),y(start=0);
Real vx,vy;
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SimpleVisual .PositionSize ball "color=red;shape=ball;";
SimpleVisual .PositionSize fixture "shape=cube;";
SimpleVisual .PositionRotationSizeOffset thread 'shape=cube;";

equation

fixture.size[1]=0.5; fixture.size[2]=0.1; fixture.size[3]=0.5;

fixture.frame_a[1]=0; fixture.frame_a[2]=0; fixture.frame_a[3]=0

ball.size[1]=1.5; ball.size[2]=1.5; ball.size[3]=1.5;
ball.frame_a[l]=x; ball_frame_a[2]=y; ball._frame_a[3]=0;
thread.size[1]=0.05; thread.size[2]=L; thread.size[3]=0.05;
thread.frame_a[l]=x; thread.frame_a[2]=y; thread.frame_a[3]=0;
thread.frame_b[1]=0; thread.frame_b[2]=0; thread.frame_b[3]=0;
thread.offset[1]=0; thread.offset[2]=L/2; thread.offset[3]=0;
m*der (vxX)=-(xX/L)*F;

m*der(vy)=-(y/L)*F-m*g;

der(x)=vx;

der(y)=vy;

XN2+yN2=L"2;

end MyPendulum3D;

We simulate and visualize as previously:

am o)

ifiotehoolcmypendulmmriexample oniy

|ﬂ|e Edc  Cell Forma  Insert  window  Help

loadModel (Modelica. 3implevisual)

[done]

sirulate (MyPendulum, startTime=0, stopTime=5);
[done]

wvisualize (MyPendulim)

[one]

K Skop J
.,

1.1l

! Rearly Mnne

Figure 3-13. Visualization with animation of 3D pendulum.
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Chapter 4

OMNotebook with DrModelica

This chapter covers the OpenMaodelica electronic notebook subsystem, called OMNotebook, together with the
DrModelica tutoring system for teaching Modelica, which is using such notebooks.

4.1 Interactive Notebooks with Literate Programming

Interactive Electronic Notebooks are active documents that may contain technical computations and text, as
well as graphics. Hence, these documents are suitable to be used for teaching and experimentation, simulation
scripting, model documentation and storage, etc.

411 Mathematica Notebooks

Literate Programming (Knuth 1984) is a form of programming where programs are integrated with
documentation in the same document. Mathematica notebooks (Wolfram 1997) is one of the first WYSIWYG
(What-Y ou-See-Is-What-You-Get) systems that support Literate Programming. Such notebooks are used, e.g.,
in the MathModelica modeling and simulation environment, e.g. see Figure 4-1 below and Chapter 19 in
(Fritzson 2004)

4.1.2 OMNotebook

The OMNotebook software (Axelsson 2005, Fernstrom 2006) is a new open source free software that gives an
interactive WYSIWYG (What-You-See-Is-What-You-Get) realization of Literate Programming, a form of
programming where programs are integrated with documentation in the same document.

The OMNotebook facility is actually an interactive WYSIWYG (What-You-See-Is-What-You-Get)
realization of Literate Programming, a form of programming where programs are integrated with
documentation in the same document. OMNotebook is a simple open-source software tool for an electronic
notebook supporting Modelica.

A more advanced electronic notebook tool, also supporting mathematical typesetting and many other
facilities, is provided by Mathematica notebooks in the MathModelica environment, see Figure 4-1.
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Figure 4-1. Examples of Mathematica notebooks in the MathModelica modeling and simulation environment.

Traditional documents, e.g. books and reports, essentially always have a hierarchical structure. They are
divided into sections, subsections, paragraphs, etc. Both the document itself and its sections usually have
headings as labels for easier navigation. This kind of structure is also reflected in electronic notebooks. Every
notebook corresponds to one document (one file) and contains a tree structure of cells. A cell can have different
kinds of contents, and can even contain other cells. The notebook hierarchy of cells thus reflects the hierarchy
of sections and subsections in a traditional document such as a book..

4.2  The DrModelica Tutoring System —an Application of OMNotebook

Understanding programs is hard, especially code written by someone else. For educational purposes it is
essential to be able to show the source code and to give an explanation of it at the same time.

Moreover, it is important to show the result of the source code’s execution. In modeling and simulation it is
also important to have the source code, the documentation about the source code, the execution results of the
simulation model, and the documentation of the simulation results in the same document. The reason is that the
problem solving process in computational simulation is an iterative process that often requires a modification
of the original mathematical model and its software implementation after the interpretation and validation of
the computed results corresponding to an initial model.

Most of the environments associated with equation-based modeling languages focus more on providing
efficient numerical algorithms rather than giving attention to the aspects that should facilitate the learning and
teaching of the language. There is a need for an environment facilitating the learning and understanding of
Modelica. These are the reasons for developing the DrModelica teaching material for Modelica and for
teaching modeling and simulation.
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An earlier version of DrModelica was developed using the MathModelica environment. The rest of this
chapter is concerned with the OMNotebook version of DrModelica and on the OMNotebook tool itself.

DrModelica has a hierarchical structure represented as notebooks. The front-page notebook is similar to a
table of contents that holds all other notebooks together by providing links to them. This particular notebook is
the first page the user will see (Figure 4-2).

E DMNotebook: DrModelica.onb™®

File Edit Cell Format Insert  ‘Window Help

Version 2006-04-11 |

DrModelic gmodelica Edition

Copynght () Linképing University, PELABR, 2003-2006, Wiley-IEEE Press, Modelica Assonation.
Contact: Openlfodelica@ida v se, Opentdodelica Project web site:

www ida v sefprojectsiOpentdo delica

Book web page: www mathcore. com/driodelica, Book author: Peter Fritzson(@ida . se

Dilvlodelica Authors: (2003 versiomn) Susanna Monemar, Eva-Lena Lengouist Sandelin, Peter Fritzson, Peter Bunus
Dillodelica Avuthors: (2005 and later updates): Peter Fritzson

This DrModelica natebook has been developed o facilitate learning the Modelica language as well as
praviding an iniraduction to object-oriented modeling and simulation. &t is based an and is
supplementary material to the Modelica hook: Feter Fritzson: " Frinciples af Ohject-Oriented
Modeling and Simulation with Modelica" (2004), 040 pages, Wiley-IEEE Press, ISBN (-471-471631.
Al of the examples and exercises in DrModelica and the page references are from that ook, Most of
the texi in DrMadelica iz also based on that boal.

Detailed Copyright and Acknowledgment Information
Getting Started Using OMNotebook
OpenModelica commands
Berkeley license Openhodelica
1 A Quick Tour of Modelica
1.1 Getting Started - First Basic Examples
Thete iz a long tradition that the first sample program i any computer language 12 a trivial program

phinting the g "He]lo TWetld" (p) 9 in Peter Fritzson's book). Since Modelica 15 an equation based

langnage, prntng T StroTe oo not make rmuch sence. Instead, our Hello World Modelica program solves

a triwal differential equation. The second ezample shows how you can write a model that solves a
Differential Algebraic Equation System (p. 19). In the Van der Pol (p. 22) example declaration as well as
mitiahzation and prefiz usage are shown in a slightly more complicated way.

1.2 Classes and Instances

In Modelica objects are created mmplicitly just by Declanng Tnstances of Classes (p. 26). Almost anything
n Modelica is a class, but there are some keywords for specific use of the class concept, called =

Ready

Figure 4-2. The front-page notebook of the OMNotebook version of the DrModelica tutoring system.
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In each chapter of DrModelica the user is presented a short summary of the corresponding chapter of the book
“Principles of Object-Oriented Modeling and Simulation with Modelica 2.1” by Peter Fritzson. The summary
introduces some keywords, being hyperlinks that will lead the user to other notebooks describing the keywords
in detail.

O oMNotebook: HelloWorldionb®

File Edit Cel Format Insert Window Help

First Basic Class

1 HelloWorld

The program contains a declaration of a class called HelloWorld with two fields and one equation. The first field 15
the variable x which is inifialized to a start value 2 at the time when the simulation starts. The second field is the vanable
a, which 15 a constant that is iitialized to 2 at the begitning of the simulation. Such a constant i3 prefiwed by the
keyword parameter i order to ndicate that it 15 constant durmg simulation but 15 a model parameter that can be
changed between simulations.

The Modelica program solbves a trivial differential equationn %™ = - a * =®. The variable x1is a state variable
that can change value over time. The x ' iz the titme derivative of =

class HelloWorld
Real x{start = 1);

parameter Real a = 1;
eguation
der(x) = - a * x;

end HelloWorld;

Ok

2 Simulation of HelloWorld

simulate{ HelloWorld, startTime=0, stopTime=4 };

[done]

plotl{ = };

Plot by OpenModelica

047

ool

Ready

Figure 4-3. The Hel loWor Id class simulated and plotted using the OMNotebook version of DrModelica.

Now, let us consider that the link “Helloworld” in DrModelica Section is clicked by the user. The new
HelloWorld notebook (see Figure 4-3), to which the user is being linked, is not only a textual description but
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also contains one or more examples explaining the specific keyword. In this class, Hel loWor 1d, a differential
equation is specified.

No information in a notebook is fixed, which implies that the user can add, change, or remove anything in a
notebook. Alternatively, the user can create an entirely new notebook in order to write his/her own programs or
copy examples from other notebooks. This new notebook can be linked from existing notebooks.

I3 oMNotebook: drmodelica.onb o ] |
File Edit el Format  Insert  window  Help
Algorithms and Functions
Algorithins
In Modelica, algoritlunic statements can only occur within Algorithin Sections (p. 285),
starting with the lceyword algorithm. Simple Assigniment Statements (p. 287) is the
most common kind of statements in algorithi gections. There is a gpecial form of
assignment statement that is only used when the right hand =ide contains a call to a
Function with Multiple R esults (p. 287).
The for-Statement (alzo called for-loop) is a convenient way of expressing iteration (p.
288). When using the for-loop for iteration we must be able to express the range of
values over which the iteration variable should iterate in a cloged form ag an iteration
expression. For cases where this is not feasible there iz also a While-loop iteration
construct m Modelica (p. 290). For conditional expressions the f-Statement (p. 292) i
uzed. When-Statements (p. 203} are uzed to express actions af event instants and are
clozely related to when-equations. The Reinit (p. 296) statement can be used in
when-statements to define new values for continuous-time state variables of a model at
an event.
The Assert (p. 298) statement provides a convenient means for specifying checls on
model validity within a model.
The most common usage of Tenminate (p. 298) is to give more appropriate stopping
criteria for terminating a simulation than a fixed pomt in fime.
Exercises J
Exercise 1
Exercise 2
Exercise 3
Exercise 4
Exercise S
Functions
The body of a Modelica function ig a kind of algorithm gection that containg procedural
algorithmic code to be executed when the function is Called (p. 300). Since a function is
a resfricted and enhanced kind of clazz. it iz no=sible to inherit an exiztme fimction El
Ready a4

Figure 4-4. DrModelica Chapter on Algorithms and Functions in the main page of the OMNotebook version of
DrModelica.
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When a class has been successfully evaluated the user can simulate and plot the result, as previously depicted
in Figure 4-3 for the simple Hel loWor 1d example model..

After reading a chapter in DrModelica the user can immediately practice the newly acquired information by
doing the exercises that concern the specific chapter. Exercises have been written in order to elucidate language
constructs step by step based on the pedagogical assumption that a student learns better “using the strategy of
learning by doing”. The exercises consist of either theoretical questions or practical programming assignments.
All exercises provide answers in order to give the user immediate feedback.

Figure 4-4 shows part of Chapter 9 of the DrModelica teaching material. Here the user can read about
language constructs, like algorithm sections, when-statements, and reinit equations, and then practice
these constructs by solving the exercises corresponding to the recently studied section.

[ oMNotebook: Exercisel.nb -0l x|

File Edit Cell Format Insert ‘Window  Help

Exercise 1

Using Algorithm Sections

Write a function, Sum, which calculates the sum of numbers, in an array of arbitrary size.

Whte a fonction, Ave rage, which calculates the average of munbers, m an array of arbitrary size. Average
should use make a finction call to Sum.

| ]

Write a class, Large st Average, that has two arrays and calculates the average of each of them. Then 1t
cotpares the averages and sets a vartable to true if the frst array iz larger than the second and otherwise falze.

| ]

Answer

Ready o
Figure 4-5. Exercise 1 in Chapter 9 of DrModelica.
Exercise 1 from Chapter 9 is shown in Figure 4-5. In this exercise the user has the opportunity to practice

different language constructs and then compare the solution to the answer for the exercise. Notice that the
answer is not visible until the Answer section is expanded. The answer is shown in Figure 4-6.
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Il OMNotebook: Exercisel.nb*® =10l x|

File Edit el Format Insert ‘Window Help

|
Answer

Sum

function Sum
input Reall[:] x;
output Real sum;
algorithm
for i in l:sizei(x,1) loop
sum := sum + x[i];
end for;

end Sum;

Average

function Average
input Reall[:] x;
output Real average;
protected
Real sum;
algorithm
average := Sumix) / size(x,1);

end Average;

LargestAverage

class LargestAverage
= {1, 2, 3, 4, 3};
parameter Integer([:] AZ = {7, 8, 9}:

parameter Integer[:] Al

Real awverageil, awveragelZ;
Boolean AlLargest(start = false);

algorithm

averagedl = Average (Al);

averageAZ 1= Average (AZ);

if awverageil > averageAZ then
AlLargest := true;

el=e
AlLargest := false;

end if;

end LargestAverage;

Sunulation of LargestAverage

simulate| LargestiAverage J; }

When we look at the values m the vanables we see that A2 has the largest average (2 ) and therefore the
variable A 1Largest iz false (= 0.

Ready

s L

Figure 4-6. The answer section to Exercise 1 in Chapter 9 of DrModelica.

4.3 OpenModelica Notebook Commands

OMNotebook currently supports the commands and concepts that are summarized in this section.
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4.3.1 Cells

Everything inside an OMNotebook document is made out of cells. A cell basically contains a chunk of
data. That data can be text, images, or other cells. OMNotebook has four types of cells: headercell,
textcell, inputcell, and groupcell. Cells are ordered in a tree structure, where one cell can be a
parent to one or more additional cells. A tree view is available close to the right border in the notebook
window to display the relation between the cells.

e Textcell — This cell type are used to display ordinary text and images. Each textcell has a style that
specifies how text is displayed. The cell’s style can be changed in the menu Format->Styles,
example of different styles are: Text, Title, and Subtitle. The Textcell type also has support
for following links to other notebook documents.

e Inputcell — This cell type has support for syntax highlighting and evaluation. It is intended to be
used for writing program code, e.g. Modelica code. Evaluation is done by pressing the key
combination Shift+Return or Shift+Enter. All the text in the cell is sent to OMC (OpenModelica
Compiler/interpreter), where the text is evaluated and the result is displayed below the inputcell. By
double-clicking on the cell marker in the tree view, the inputcell can be collapsed causing the result
to be hidden.

e Groupcell — This cell type is used to group together other cell. A groupcell can be opened or closed.
When a groupcell is opened all the cells inside the groupcell are visible, but when the groupcell is
closed only the first cell inside the groupcell is visible. The state of the groupcell is changed by the
user double-clicking on the cell marker in the tree view. When the groupcell is closed the marker is
changed and the marker has an arrow at the bottom.

4.3.2 Cursors

An OMNotebook document contains cells which in turn contain text. Thus, two kinds of cursors are needed
for positioning, text cursor and cell cursor:

e Textcursor — A cursor between characters in a cell, appearing as a small vertical line. Position the
cursor by clicking on the text or using the arrow buttons.

e Cellcursor — This cursor shows which cell currently has the input focus. It consists of two parts.
The main cellcursor is basically just a thin black horizontal line below the cell with input focus. The
cellcursor is positioned by clicking on a cell, clicking between cells, or using the menu item Cel I-
>Next Cell or Cell->Previous Cell. The cursor can also be moved with the key combination
Ctrl+Up or Ctrl+Down. The dynamic cellcursor is a short blinking horisontal line. To make this
visible, you must click once more on the main cellcursor (the long horizontal line). NOTE: In order
to paste cells at the cellcursor, the dynamic cellcursor must be made active by clicking on the main
cellcursor (the horisontal line).

4.4 Selection of Text or Cells

To perform operations on text or cells we often need to select a range of characters or cells.

e Select characters — There are several ways of selecting characters, e.g. double-clicking on a word,
clicking and dragging the mouse, or click followed by a shift-click at an adjacent positioin selects
the text between the previous click and the position of the most recent shift-click.

e Select cells — Cells can be selected by clicking on them. Holding done Ctrl and clicking on the cell
markers in the tree view allows several cells to be selected, one at a time. Several cells can be
selected at once in the tree view by holding down the Shift key. Holding down Shift selects all cells
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44.1

between last selected cell and the cell clicked on. This only works if both cells belong to the same
groupcell.

File Menu

The following file related operations are available in the file menu:

4.4.2

Create a new notebook — A new notebook can be created using the menu File->New or the key
combination Ctrl+N. A new document window will then open, with a new document inside.

Open a notebook — To open a notebook use File->0Open in the menu or the key combination
Ctrl+O. Only files of the type .onb or .nb can be opened. If a file does not follow the
OMNotebook format or the FullForm Mathematica Notebook format, a message box is displayed
telling the user what is wrong. Mathematica Notebooks must be converted to fullform before they
can be opened in OMNotebook.

Save a notebook — To save a notebook use the menu item File->Save or File->Save As. If the
notebook has not been saved before the save as dialog is shown and a filename can be selected.
OMNotebook can only save in xml format and the saved file is not compatible with Mathematica.
Key combination for save is Ctrl+S and for save as Ctrl+Shift+S. The saved file by default obtains
the file extension .onb.

Print — Printing a document to a printer is done by pressing the key combination Ctrl+P or using the
menu item File->Print. A normal print dialog is displayed where the usually properties can be
changed.

Import old document — Old documents, saved with the old version of OMNotebook where a
different file format was used, can be opened using the menu item File->Import->0ld
OMNotebook File. Old documents have the extension .xml.

Export text — The text inside a document can be exported to a text document. The text is exported to
this document without almost any structure saved. The only structure that is saved is the cell
structure. Each paragraph in the text document will contain text from one cell. To use the export
function, use menu item File->Export->Pure Text.

Close a notebook window — A notebook window can be closed using the menu item File->Close
or the key combination Ctrl+F4. Any unsaved changes in the document are lost when the notebook
window is closed.

Quitting OMNotebook — To quit OMNotebook, use menu item File->Quit or the key
combination Crtl+Q. This closes all notebook windows; users will have the option of closing OMC
also. OMC will not automatically shutdown because other programs may still use it. Evaluating the
command quit() has the same result as exiting OMNotebook.

Edit Menu

Editing cell text — Cells have a set of of basic editing functions. The key combination for these are:
Undo (Ctrl+2), Redo (Ctrl+Y), Cut (Ctrl+X), Copy (Ctrl+C) and Paste (Ctrl+V). These functions
can also be accessed from the edit menu; Undo (Edit->Undo), Redo (Edit->Redo), Cut (Edit-
>Cut), Copy (Edit->Copy) and Paste (Edit->Paste). Selection of text is done in the usual way
by double-clicking, triple-clicking (select a paragraph), dragging the mouse, or using (Ctrl+A) to
select all text within the cell.

Cut cell — Cells can be cut from a document with the menu item Edit->Cut or the key combination
Ctrl+X. The cut function will always cut cells if cells have been selected in the tree view, otherwise
the cut function cuts text.
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4.4.3

4.4.4

Copy cell — Cells can be copied from a document with the menu item Edit->Copy or the key
combination Ctrl+C. The copy function will always copy cells if cells have been selected in the tree
view, otherwise the copy function copy text.

Paste cell — To paste copied or cut cells the cell cursor must be selected in the location where the
cells should be pasted. This is done by clicking on the cell cursor. Pasteing cells is done from the
menu Edit->Paste or the key combination Ctrl+V. If the cell cursor is selected the paste function
will always paste cells. OMNotebook share the same application-wide clipboard. Therefore cells
that have been copied from one document can be pasted into another document. Only pointers to
the copied or cut cells are added to the clipboard, thus the cell that should be pasted must still exist.
Consequently a cell can not be pasted from a document that has been closed.

Find — Find text string in the current notebook, with the options match full word, match cell, search
within closed cells. Short command Ctrl+F.

Replace — Find and replace text string in the current notebook, with the options match full word,
match cell, search+replace within closed cells. Short command Ctrl+H.

View expression — Text in a cell is stored internally as a subset of HTML code and the menu item
Edit->View Expression let the user switch between viewing the text or the internal HTML
representation. Changes made to the HTML code will affect how the text is displayed.

Cell Menu

Add textcell — A new textcell is added with the menu item Cel 1->Add Cel I (previous cell style) or
the key combination Alt+Enter. The new textcell gets the same style as the previous selected cell
had.

Add inputcell — A new inputcell is added with the menu item CelI->Add Inputcell or the key
combination Ctrl+Shift+l.

Add groupcell — A new groupcell is inserted with the menu item Cel1->Groupcell or the key
combination Ctrl+Shift+G. The selected cell will then become the first cell inside the groupcell.
Ungroup groupcell — A groupcell can be ungrouped by selecting it in the tree view and using the
menu item Cel I->Ungroup Groupcell or by using the key combination Ctrl+Shift+U. Only one
groupcell at a time can be ungrouped.

Split cell — Spliting a cell is done with the menu item Cel1->Split cell or the key combination
Ctrl+Shift+P. The cell is splited at the position of the text cursor.

Delete cell — The menu item Cell->Delete Cell will delete all cells that have been selected in
the tree view. If no cell is selected this action will delete the cell that have been selected by the
cellcursor. This action can also be called with the key combination Ctrl+Shift+D or the key Del
(only works when cells have been selected in the tree view).

Cellcursor — This cell type is a special type that shows which cell that currently has the focus. The
cell is basically just a thin black line. The cellcursor is moved by clicking on a cell or using the
menu item CelI->Next Cell or Cell->Previous Cell. The cursor can also be moved with the
key combination Ctrl+Up or Ctrl+Down.

Format Menu

Textcell — This cell type is used to display ordinary text and images. Each textcell has a style that
specifies how text is displayed. The cells style can be changed in the menu Format->Styles,
examples of different styles are: Text, Title, and Subtitle. The Textcell type also have
support for following links to other notebook documents.
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Text manipulation — There are a number of different text manipulations that can be done to change
the appearance of the text. These manipulations include operations like: changing font, changing
color and make text bold, but also operations like: changing the alignment of the text and the
margin inside the cell. All text manipulations inside a cell can be done on single letters, words or
the entire text. Text settings are found in the Format menu. The following text manipulations are
available in OMNotebook:

> Font family

> Font face (Plain, Bold, Italic, Underline)

> Font size

> Font stretch

> Font color

> Text horizontal alignment

> Text vertical alignment

> Border thickness

> Margin (outside the border)

> Padding (inside the border)

445 Insert Menu

Insert image — Images are added to a document with the menu item Insert->Image or the key
combination Ctrl+Shift+M. After an image has been selected a dialog appears, where the size of the
image can be chosen. The images actual size is the default value of the image. OMNotebook
stretches the image accordantly to the selected size. All images are saved in the same file as the rest
of the document.

Insert link — A document can contain links to other OMNotebook file or Mathematica notebook and
to add a new link a piece of text must first be selected. The selected text make up the part of the link
that the user can click on. Inserting a link is done from the menu Insert->Link or with the key
combination Ctrl+Shift+L. A dialog window, much like the one used to open documents, allows the
user to choose the file that the link refers to. All links are saved in the document with a relative file
path so documents that belong together easily can be moved from one place to another without the
links failing.

4.4.6 Window Menu

4.4.7

Change window — Each opened document has its own document window. To switch between those
use the Window menu. The window menu lists all titles of the open documents, in the same order
as they were opened. To switch to another document, simple click on the title of that document.

Help Menu

About OMNotebook — Accessing the about message box for OMNotebook is done from the menu
Help->About OMNotebook.
About Qt — To access the message box for Qt, use the menu Help->About Qt.

Help Text — Opening the help text (document OMNotebookHelp.onb) for OMNotebook can be
done in the same way as any OMNotebook document is opened or with the menu Help->Help
Text. The menu item can also be triggered with the key F1.
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4.4.8

Additional Features

Links — By clicking on a link, OMNotebook will open the document that is referred to in the link.

Update link — All links are stored with relative file path. Therefore OMNotebook has functions that
automatically updating links if a document is resaved in another folder. Every time a document is
saved, OMNotebook checks if the document is saved in the same folder as last time. If the folder
has changed, the links are updated.

Evaluate several cells — Several inputcells can be evaluated at the same time by selecting them in
the treeview and then pressing the key combination Shift+Enter or Shift+Return. The cells are
evaluated in the same order as they have been selected. If a groupcell is selected all inputcells in
that groupcell are evaluated, in the order they are located in the groupcell.

Command completion — Inputcells have command completion support, which checks if the user is
typing a command (or any keyword defined in the file commands.xml) and finish the command. If
the user types the first two or three letters in a command, the command completion function fills in
the rest. To use command completion, press the key combination Ctrl+Space or Shift+Tab. The
first command that matches the letters written will then appear. Holding down Shift and pressing
Tab (alternative holding down Ctrl and pressing Space) again will display the second command that
matches. Repeated request to use command completion will loop through all commands that match
the letters written. When a command is displayed by the command completion functionality any
field inside the command that should be edited by the user is automatically selected. Some
commands can have several of these fields and by pressing the key combination Ctrl+Tab, the next
field will be selected inside the command.

> Active Command completion: Ctrl+Space / Shift+Tab

> Next command: Ctrl+Space / Shift+Tab

> Next field in command: Ctrl+Tab’

Generated plot — When plotting a simulation result, OMC uses the program Ptplot to create a plot.
From Ptplot OMNotebook gets an image of the plot and automatically adds that image to the output
part of an inputcell. Like all other images in a document, the plot is saved in the document file
when the document is saved.

Stylesheet —-OMNotebook follows the style settings defined in stylesheet.xml and the correct style is
applied to a cell when the cell is created.

Automatic Chapter Numbering — OMNotebook automatically numbers different chapter,
subchapter, section and other styles. The user can specify which styles should have chapter
numbers and which level the style should have. This is done in the stylesheet.xml file. Every style
can have a <chapterLevel> tag that specifies the chapter level. Level 0 or no tag at all, means that
the style should not have any chapter numbering.

Scrollarea — Scrolling through a document can be done by using the mouse wheel. A document can
also be scrolled by moving the cell cursor up or down.

Syntax highlighter — The syntax highlighter runs in a separated thread which speeds up the loading
of large document that contains many Modelica code cells. The syntax highlighter only highlights
when letters are added, not when they are removed. The color settings for the different types of
keywords are stored in the file modelicacolors.xml. Besides defining the text color and
background color of keywords, whether or not the keywords should be bold or/and italic can be
defined.

Change indicator — A star (*) will appear behind the filename in the title of notebook window if the
document has been changed and needs saving. When the user closes a document that has some
unsaved change, OMNotebook asks the user if he/she wants to save the document before closing. If
the document never has been saved before, the save-as dialog appears so that a filename can be
choosen for the new document.
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e Update menus — All menus are constantly updated so that only menu items that are linked to actions
that can be performed on the currently selected cell is enabled. All other menu items will be
disabled. When a textcell is selected the Format menu is updated so that it indicates the text settings
for the text, in the current cursor position.
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Chapter 5

MDT — The OpenModelica Development Tooling
Eclipse Plugin

5.1

Introduction

The Modelica Development Tooling (MDT) Eclipse Plug-In as part of OMDev — The OpenModelica
Development Environment integrates the OpenModelica compiler with Eclipse. MDT, together with the
OpenModelica compiler, provides an environment for working with Modelica development projects.

The following features are available:

5.2

Browsing support for Modelica projects, packages, and classes

Wizards for creating Modelica projects, packages, and classes

Syntax color highlighting

Syntax checking

Browsing of the Modelica Standard Library or other libraries

Code completion for class names and function argument lists.

Goto definition for classes, types, and functions.

Displaying type information when hovering the mouse over an identifier.

Installation

The installation of MDT is accomplished by following the below installation instructions. These
instructions assume that you have successfully downloaded and installed Eclipse (http://www.eclipse.org).

1.

ar®d

©oo~No®

Start Eclipse

Select Help->Software Updates->Find and Install... from the menu

Select “Search for new features to install” and click ‘Next’

Select ‘New Remote Site...

Enter ‘MDT’ as name and ‘http://www.ida.liu.se/labs/pelab/modelica/OpenModelica/MDT’ as
URL and click ‘OK’

Make sure ‘MDT’ is selected and click ‘Finish’

In the updates dialog select the ‘MDT’ feature and click ‘Next’

Read through the license agreement, select ‘I accept...” and click ‘Next’

Click ‘Finish’ to install MDT




65

5.3 Getting Started

5.3.1 Configuring the OpenModelica Compiler

MDT needs to be able to locate the binary of the compiler. It uses the environment variable
OPENMODELICAHOME to do so.

If you have problems using MDT, make sure that OPENMODELICAHOME is pointing to the folder
where the Open Modelica Compiler is installed. In other words, OPENMODELICAHOME must point to
the folder that contains the Open Modelica Compiler (OMC) binary. On the Windows platform it’s called
omc.exe and on Unix platforms it’s called omc.

5.3.2 Using the Modelica Perspective

The most convenient way to work with Modelica projects is to use to the Modelica perspective. To switch
to the Modelica perspective, choose the Window menu item, pick Open Perspective followed by
Other... Select the Model ica option from the dialog presented and click OK..

5.3.3 Selecting a Workspace Folder

Eclipse stores your projects in a folder called a workspace. You need to choose a workspace folder for this
session, see Figure 5-1

& Modelica - Eclipse SDK — =2l =
File Edit Refactor MNavigate Search Project Run Window Help
New Alb+shift+ b ) | = - [E | [ Modelica >
Open File...
=8
close Chrl4F4
Close Al Chrl4-ShiftHE
| Chrl45
M Sove as...
i S=ve Al Chrl+Ehift+S
Revert
MovE. ..
Renams... 2
Refresh F3
Convert Line Delimiters To 4
ol Frint.. Chrl+F
E & workspace Launcher x|
g Import...
7 Export... Select a workspace
. Edipse SDK stores your projects in a folder called a workspace.
Frioperics AleEritse ose a workspace folder to use for this session.
1 README. txt [06_OMCAndCorba]
2 SOLUTION. txt [01_experiment]
3 Functions.mo [05_advanced]
4 SOLUTION. bt [05_advanced] Q-ri-7d
Exit _I
-
oK I Cancel I
=l _'l_I

o

Figure 5-1. Eclipse Setup — Switching Workspace.
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5.3.4  Creating one or more Modelica Projects

To start a new project, use the New Modelica Project Wizard. It is accessible through File->New->
Modelica Project or by right-clicking in the Modelica Projects view and selecting New->Modelica
Project.

& Modelica - Eclipse SDK == x|
Fle Edit Refactor Navigate Search Project Run Window Help
i | E Modelica

Ale+shift+N ¥ | g Project...

Open File...
£ Modelica Package =5
Close: ChriF4 Modion
Close &l Cirl+ShiftR aaelca Clacs
[ Folder
| B Cirlt5 Cirie
W 5ave s
=7 Fuar

& New Project

& New Modelica Project x|

Select a wizard . Create a Modelica project —
Create a new Modelica project. Create a Modelica project in the workspace.
Wizards: / Project name: I 01_experiment]

{ﬁ- Plug-n Project

g—

< Back Next > 3 Finish | Cance < Back | [ext = | Einish I Cancel
> 4

Figure 5-2. Eclipse Setup — creating a Modelica project in the workspace.

You need to disable automatic build for the project(s) (Figure 5-3).

& Modelica - Edlipse SDK I =1
Fle Edit Refactor Navigate Search |Project Run Window Help
| 5 - & | » |- Cpen Project =i [ & vodehea »
Close Project
=g = O
——  [aBuidal crl+8
Build Praject
Buid Working Set 3
L2703 _sssignment Clsan. .

{127 04a_assigntwotype
121 04b_modassigntwotype
120 05_advanced

+-[2] 06_OMCANdCorba Properties
07 07_pam
11 08_pamded

Convert b a Bynamic Web project.

«-12] 09_pamtrans
-1 10_petral
- etc

Build Automatically
should be DISABLED
for all projects

Problems [ &l Console £2 ™_Error Lng‘SEarch| kR BE2-r35-=0
SV
=

o o

N

Figure 5-3. Eclipse Setup — disable automatic build for the projects.
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Repeat the procedure for all the projects you need, e.g. for the exercises described in the MetaModelica
users guide: 01_experiment, 02a_expl, 02b_exp2, 03_assignment, 04a_assigntwotype, etc.

NOTE: Leave open only the projects you are working on! Close all the others!

5.3.5 Building and Running a Project

After having created a project, you eventually need to build the project (Figure 5-4).
iz

Fie B3t Refactor Mavigele Seorch | Froject Pun Window Helo

|| e
PRl = )
— L il
Busks Working Set

forrnct trdderitaton 12} T Modieicn I

1 05, advances
1 06 _DMCarCorba
1 07_pam

1 08 _pamded

1 09 _pamtrans

1 10_peral

e

N

K]

[Protiems | ) Comssie 13 "~ Emer Lag | Seareh |

Wrisable Insert 1:1

Figure 5-4. Eclipse MDT — Building a project.
There are several options: building, building from scratch (clean), running, see Figure 5-5.
e x|

Flle Edit Refactor Navigate Search FProject Run Window Help

| i R N I > S I = ] o o e R S = B - | correctIndentation [ | [ Modelica

E- 122 01_experiment

(= .externalToolBuilders
[ Functions.mo

1] Main.ma

[ Types.mo

[¥] .project

5] SOLUTION, txt
=i, Standard Library
157 02a_exp1

157 02b_expz

157 03_assignment

107 04a_assigntwotype
120 04b_modassigntwotype
127 05_advanced

120 06_OMCANndCorba

17 07_pam

package Functions

// impors Types;

function test

input String s;

cal
el =y Buiding project...
iy 6P

end test;

—
leave empty — builds the project § =

clean — cleans the project

run — runs the program

debug - builds in debug mode

function £2  punning OMDev-MINGW...

input Int
output In

{2 08_pamded algorithm
~[Z] 09_pamtrans cutValue Cancel Details ==
local T
g iije‘m' B - | - Variable input x|
case n then n*factoria -
Please input 3 valus
Eilf I .
Problems | & console 52 M A ls om0
[ =

The problems are in

the Problems view
after the build

The build and run results
are displayed in the console

‘ Writable | Insert ‘ 1:1 | Build Project: (0%) m o

Figure 5-5. Eclipse — building and running a project.
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You may also open additional views, e.g as in Figure 5-6.

& Modelica - Functions.mo - Eclipse SDK =i
File Edit Refactor Navigate Search Project Rum | Window Help r
N «f

New Editor

= J Correct Indentation

Ici-Clal& e e E

= N ="
# ModelcaPr... 52 = O Functions.mo_X (= Ant Al |3
Open Perspective e | (5 Basic =
B+ 01_experiment package Fun: 55 Modelca Projects |
> .extemalToolBuilders E——— . Il Backmarks
- [M) Functions.mo // impozt T:  Customize Perspective... |2 Problems s Classic Search
Main.mo Save Perspective As... —
13 t. te:
-] Types.mo uj:];tnsi Reset Perspective @ Internal Web Browser
B3] -project output In| IR 55 Navigator
L Make.mk algorithm Close All Perspectives
. :;:)i!lz txt ® 27 m2tel Navigation
SOLUTION. txt z: P - Flugin Dependencies (GEF Example)
- mh Standard Library cal (%1 Problems
g E;—E"D; ca.  Preferences... & Progress
_exp. elas 07 .
: Properties
~~120 03_assignment end matchcontinue; E-I. 5 pch
7 04a_assigntwotype end test; Efﬁr
~~12] 04b_modassigntwotype Snippets
121 05_advanced function factorial o) Tasks
-1 06_OMCAndCarba input Integer inVelue; B CfC++
£ 07 pam cutput Integer outValue; 5= Cheat Shests | |
--100 08_pamded algorithn catshes
7 03 pomirans cutValue := matchoontinue inValue B[ CVS
21 10_petrol local Integer n; A Data
o et case 0 then 1; [-(= Debug
case n then n*factorial(n-1); N N d
a1l [#-[= Functional Programming
Hel =
Bl-{= Help —
Problems | & console 52 _Error Lug‘SEard’|| -2 Java (]
<terminated> OMDev-MINGW/ [Program] c:\OMDevtools\msysbin\make. exe B[ Java Browsing
Im —£ 2.0t COfe WOD.CUT gEMON.OUT Wain main.exe Main.o Iypes.o R | [E-[Z Make =
(2= Modelica b
{1 Modelica Projects
.. . B[ PDE
To open additional views: (= PDE Runtime
g a [#-[= Readme
Window->ShowView->Other o R =

o ||

4 |

[ é 1 Wiritable | Insert w: 28 |

Figure 5-6. Eclipse — Opening views.

5.3.6 Switching to Another Perspective
If you need, you can (temporarily) switch to another perspective, e.g. to the Java perspective for working
with an OpenModelica Java client as in Figure 5-7.
laix

e Ddt Refactor Mavigate Seacch Project Fun Window  Help

|- = w |- |0y ]| BAR |G- - 2] ] oo "
(T, -
1 01_siperment 15 Debug
028 el
B 0 e

1 03_assigrenent
0 04 _sssgrimatype
1 04 _modassoniwtype
151 05 _advarced
1 j05_oMCanaCerha)
- settngs
- org

% dossoath

¥, .project

[0 mEADME txt
B 07_pam
1T 0 _panded
1 &9 _pamirans
1 10 _petedd
et

Frotiems [ Console 73 . Emer Log| Search W ln #@-ri-=°0
o [Frogr L

I® -f 4.0UT COFE MOR.OUT QEON.OUT MALN EAlR.eNe MAln.o Types.o FuneTions.o Main. Main.h Types.

ypeu.h Pansuions.e &

. | of

H
Figure 5-7. Eclipse — Switching to another perspective — e.g. the Java Perspective.
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5.3.7 Creating a Package

To create a new package inside a Modelica project, select File->New->Modelica Package. Enter the
desired name of the package and a description of what it contains. Note: for the exercises we already have
existing packages.

|f New Modelica Package Bl
Modelica Package
Create a new Modelica package.
Source folder: [PPC 970 l [ Browse...]
Name: [C ore l

Description: |Thi5 package contains the core stuff |

[lis encapsulated package

[ Finish l [ Cancel

Figure 5-8. Creating a new Modelica package.

5.3.8 Creating a Class

To create a new Modelica class, select where in the hierarchy that you want to add your new class and
select File->New->Modelica Class. When creating a Modelica class you can add different restrictions
on what the class can contain. These can for example be model, connector, block, record, or
function. When you have selected your desired class type, you can select modifiers that add code blocks
to the generated code. ‘Include initial code block’ will for example add the line ‘initial
equation’ to the class.

|f New Modelica Class il
Modelica Class

Create a new Modelica class.

Source folder: [PPC 970/Core l [Browse...]
Name: |ALU |
Type:

Medifiers: include initial equation block

[is partial class

O

[ Finish H Cancel

Figure 5-9. Creating a new Modelica class.
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5.3.9 Syntax Checking

Whenever a build command is given to the MDT environment, modified and saved Modelica (-mo) files
are checked for syntactical errors. Any errors that are found are added to the Problems view and also
marked in the source code editor. Errors are marked in the editor as a red circle with a white cross, a
squiggly red line under the problematic construct, and as a red marker in the right-hand side of the editor. If
you want to reach the problem, you can either click the item in the Problems view or select the red box in

the right-hand side of the editor.

e

%’ Modeli... 2
= 2 PPCY70

B ALU.mo

I package.mo

[» =i System Library

Modelica - ALU.mo - Eclipse SDK
File Edit MNavigate Search Project SWT Hierarchy Run

Window Help
*e 0oy o [Evosses]
= m =
block ALU Bl
equation
=
@ » - ! l ! »
end ALU: ;
[4] 3
Console [Z! Problems 2 = ¥ =0
2 errors, 0 wamings, 0 infos
Description Resource |In Folder Location
@ unexpected token  ALU.mo PPCO70/Core  line 5
@ unexpected token  ALU.mo PPCO70/Core line 5

NEI{EN

[+

Figure 5-10. Syntax checking.

5.3.10 Automatic Indentation Support

MDT currently has support for automatic indentation. When typing the Return (Enter) key, the next line is
indented correctly. You can also correct indentation of the current line or a range selection using CTRL+I

or “Correct Indentation” action on the toolbar or in the Edit menu.
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5.3.11 Code Completion

MDT supports Code Completion in two variants. The first variant, code completion when typing a dot after
a class (package) name, shows alternatives in a menu. Besides the alternatives, Modelica documentation
from comments is shown if is available. This makes the selection easyer.

< Modelica - DCEngine.mo - Eclipse SDK

File Edit Refactor Mawigate Search Run  Project  Window Help

H

TL'LDJI;I a1h %' Q;' ¥o oo~

[ Modelica Projects &5 = B *DCEngine. mo £
= Tﬁ Enginesimulation model DCEngine
¥ DCEngine . mo import I-Iu:udelica.l
project i
= ; Standard Library cauation %Elsifants
= £ Modelica end DCEngine; £ Electrical
+- £ Blocks
+-ff Constants i Icons
+- £ Electrical £ Math
-3 Icons 3 Mechanics
- f3 Math B s1units
+ acos EElThermaI
+ asin
+ aktan
+ atang
baselconl

Figure 5-11. Code completion when typing a dot.

The second variant is useful when typing a call to a function. It shows the function signature (formal
parameter names and types) in a popup when typing the parenthesis after the function name, here the
signature Real sin(SI.Angle u) of the sin function:

= Modelica - DCEngine.mo - Eclipse SDK

File Edit Refactor Mawvigate Search Run Project  Window Help

"

TL'L;:;_IL'__’J atd %" ¥ |0 o -

[MY] Modelica Projects 23 =0 *LCERGIne.mo oa
=122 Enginesimulation model DCEngine
+ DCEngine. mo import Modelica.Math. *;
|Z] .project output Real x;
—|-=) Standard Library egquation
= Modelica Feal singSLLAngle ) |
+- 4 Blocks ¥ = zin|
+- £} Constants
+-H4 Electrical B
end DCEngine;
+-FF Icons a

Figure 5-12. Code completion at a function call when typing left parenthesis.
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5.3.12 Code Assistance on Identifiers when Hovering

When hovering with the mouse over an identifier a popup with information about the identifier is
displayed. If the text is too long, the user can press F2 to focus the popup dialog and scroll up and down to
examine all the text. As one can see the information in the popup dialog is syntax-highlighted.

BT NEIES)
orrect Indentation ] 3 -8 e - | B Modelica =
s =5
input String inString; |
input I i teractiveSymbolTable inInteractiveSywbolTable;
output clean;
output
output sractiveSymbelTable cuslnseractiveSymbolTabls;

2lgorithm
loutBoolean, cutString, cutInteractiveSymbolTable) :=
matchcontinue (inString,inlnte SymbolTable)

local J

=, expmsg, debugssz;
L

izble> wars_l,vars;

Path, tuple<Types.TType, Cpticn<Ribsyn.Dath»>>> cf_1,cf;

jniontype Pach

z2ss>

case (str,isymb)
equation
true = Util.strnemp|™quiti)”, stz

end QUAL
racord T

Ident name "name"”

then

Ck\n", isymh) ;

end FULLYQUALIFIED;
end Pzth;

Figure 5-13. Displaying information for identifiers on hovering

5.3.13 Go to Definition Support

Besides hovering information the user can press CTRL+click to go to the definition of the identifier.
When pressing CTRL the identifier will be presented as a link and when pressing mouse click the editor will
go to the definition of the identifier.

5.3.14 Code Assistance on Writing Records

When writing records, the same functionality as for function calls is used. This is useful especially in
MetaModelica when writing cases in match constructs.
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File Edit MNavigate Search Project Run  Window Help

- | @ |

ItS-EHe| &%

[F Modelica Projects 53

| # i3

S

""" 120 modeqThG

[:I---Ig:& CpenModelica [trunk]

""" 12T org.modelica.mdt. core

""" 127 org.modelica.mdt.debug. core
""" 1T org.modelica.mdt.debug, ui
""" 127 org.modelica,mdt. feature

""" LT org.modelica.mdt.ome

""" T org.modelica.mdt, site

""" 157 org.modelica.mdt. test

""" 127 org.modelica.mdt. ui

- #5 (o » - | CorrectIndentation

local ComponentRef crefl, crefi; list<Exp> srgsl, argsZ; Boole

blst = Util_listThreadMap {ergal, argsZ, expEqual);

equal = Util.boolAndList(blst);
then egqual;

case (MATRIX (argsl) MATRIH (argsZ))

local ComponentBef crefl,crefZ;

equal = Util _boolBndList (Util.listFlatten
then egual;

expEqual) ;

(blsti);

[RANGE{Exp start, Option <Exp > step, Exp stop) |

case (RANGE(p11,SCME(elZ),el3])], RANGE (e2l, SOME (e22),e23))

local Exp ell,elZ el3, ezl eiZ, eZ3;
Bocolean bl ,bZ, b3;
equation

bl = expEqualiell,eZl);

ki = expEgquel (elZ, eZZ);
b3 = expEqual (el 23);

equal = Util.boolAndList{{bl, b2, b3});
then egqual;

case (RARNGE(ell, ,el3) RRNGE(eZl, ,e23))
local Exp ell,elZ, el3, el eiZ e23;
Boolean bl,bZ,b3;
equation
bl = expEqualiell,eZl);

list<list<Exp>> argsl,=srgsz;
klst = Ttil_listListThresdMep{argsl,argsz,

Figure 5-14. Code assistance when writing cases with records in MetaModelica.

5.3.15 Using the MDT Console for Plotting

& Modelica - demo/BouncingBall.mo - Eclipse SDK i

Fle Edit Navigate Search Project Rum Field Assist

[wi=

Window Help

@ |- 0-%- &+ |9 | @ | 5 |corectimdentation: | 2] 50 v *

I | [ Modelica aJJava
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- [M] BouncingBall.mo . par@atar Real
i Helloworld.ma 5 }EE_A :A(if;a,
- VanDerPol.mo 5| Real v "v .
-~ [¥] .project & Boolean flying(start=trume) "true, if ball is fly
: ; 7| Bom s .
= Libraries: C:\OpenModelica 1. 4,4Modelical . :c:__e-ar_ impacts
=~ Modelica g Ren1 v neut:
© extends Icoms.Library g discrete Integer n_kounce (start=0);:
: # Blocks o eqmation
B constants impact = h
| B8 Eectrical der(v) = if flying then -g else 0;
£ 1cons der(n} = v;
£ Math
3 Mechanics when {h <= 0.0 and v <= 0.0,impact} then
£ Slunits if edge(impact) then -e*pre(v) else 0:
1 =4 ;> 0;
8 UsersGuide = J-_new _> 0;
B Modelicaadditions e (v, v_new);
4 T 13 n_bounce=pre (n_bounce)+1;
20 end when;
BF outline 2% = ]| 21 lend BouncingBall;:

1Java Stack Trace Console

3New Cansole View

Axg s x| _’l_l
E M Bouncinggall [ Problems J console 3 Eﬁ]ﬁuukmarls]@“ ngress] * B e= ﬁ]
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J e

| 7 s

Figure 5-15. Activate the MDT Console
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Figure 5-16. Simulation from MDT Console
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Chapter 6

Modelica Algorithmic Subset Debugger

This chapter presents a comprehensive Modelica debugger for an extended algorithmic subset of the
Modelica language called MetaModelica. This replaces debugging of algorithmic code using primitive
means such as print statements or asserts which is complex, time-consuming and error- prone.

The debugger is portable since it is based on transparent source code instrumentation techniques that are
independent of the implementation platform.

The usual debugging functionality found in debuggers for procedural or traditional object-oriented
languages is supported, such as setting and removing breakpoints, single-stepping, inspecting variables,
back-trace of stack contents, tracing, etc. The debugger is integrated with Eclipse.

6.1 The Eclipse-based debugging environment

The debugging framework is based on the Eclipse environment and is implememented as a set of plugins
which are available from Modelica Development Tooling (MDT) environment. Some of the debugger
functionality is presented below. In the right part a variable value is expored. In the top-left part the stack
trace is presented. In the middle-left part the execution point is presented.
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Figure 6-1. Debugging functionality.
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6.2 Starting the Modelica Debugging Perspective

To be able to run in debug mode, one has to go through the following steps:
1. setting the debug configuration
2. setting breakpoints
3. running the debug configuration

All these steps are presented below using images.

6.2.1 Setting the debug configuration

While the Modelica perspective is activated the user should click on the bug icon on the toolbar and select
Debug in order to access the dialog for building debug configurations.
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To create the debug configuration, right click on the classification Modelica Development Tooling
(MDT) and select New as in figure below. Then give a name to the configuration, select the debugging
executable to be executed and give it command line parameters. There are several tabs in which the user
can select additional debug configuration settings like the environment in which the executable should be
run.
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&= Modelica - Main.mo - Eclipse SDK

File Edt Mavigate Search Project Run Window Help

et (@B -0 -Q- | P |0 - |comctmdematon | £+ oro cae oo
&= x|~
(A Modelca Projects 33 il
Codegen.mo | Create, manage, and run configurations
El} Connect.mo Run or Debug a MetaModelica program
Constants.ma
% Corba.mo
) e = 2 -
Ao DEx 05 Neme: [omcD
DAERXT.M | [ Fiter tet
3 DAELow.mo m Sburce| =] Common | Fg Environment
Debug.ma -[€] CfC++ Attach to Local Application
3 Derive.mo E C/C++ Local Application
Dump.ma E C/C++ Postmortem debugger
4 DumpGraphviz. -8 Edlipse Application Program: I Cihin‘cygwinthome\adrpolruntime-EclipseApplication{OpenModelica \build\bintomed.exe | Brawse.,
Env.mo o Equinox OSGi Framework
3 Error.mo B4l Java Applet
ErrarExt.mo I'fl Java Application Arquments:
3 Exp.
e, Hg Jav.a Bean +c=debug +d=interactiveCorba
Graphviz.mo Ju Junit
3 Inst.mo - Ji Uit Plug-in Test
3 Interactive.mo i Modelica Developement Toaling (MDT)
Lookup.mo 2”{. oMcD
3 Main.mo Z, Remote Java Application
i ~H3 Main -5 swT Application
S5 outine 5N
= Eﬁ‘ Main
+ checkClassdef
fixModelicaCutput
handleCommand
interactivemade
interactivemodeCor
isFlatModelicarile
isModelicaFile 2
isModelicaScriptFile &I &I
main -
makeDebugResult
modpar @ g LI Il
optimizeDas ooy A oo [T T
readSettings |H
readSettingsFile
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Figure 6-4. Specifying the executable to be run in debug mode.
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6.2.2 Setting/Deleting Breakpoints
€ Hodelca Haimmo - Edwse SOK 181X

Fle Edt Mavgate Search Froject Run Feidissst Window Hep

Ird= @ m | $-0-Q- |5 | |2 |8 |@ | 1« =5 G - |corectindentaton 3| ) Modeica =
Er—=— e =5

il = e i-hachage Matn =
el 61_siperment |

B2 extemaTooBuicers
B Anczons.no 5
= 3 Manmo < function =ain

@ @ man 7 input list<String args
- Types=o £ aigoritim

¥ roject 3 _om

T .::c:. = 17 matchcomtimie arg

o e case in_werii_)

] Funczons.h Mz 20cm
a Irtager &, n

i Maie

Funccigns.test (“one”) )i

Funccions.vess ("1e07) ) )3 -
»
=pn

8 Man Proiems | [ console 17 WyBeokmaris | Progress | = X (kiimB-ri-=0
B menfat<syng> wg) Develooement Tookng (4] C: 0, 38 DTGP =279 gREplPort=2T5] <GEVNPor =279 <gSgnaPort=279 10
@ imoort Functions)

Double click on the
ruler to set/delete
breakpoints

K]

| wnasie | trsert B | B Opertiodeion Compler 1,438 Orire | Jige

Figure 6-5. Setting/deleting breakpoints.

6.2.3 Starting the debugging session and enabling the debug perspective
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£ Modelica - Main.mo - Eclipse SDK
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Figure 6-7. Eclipse will ask if the user wants to switch to the debugging perspective.

6.3 The Debugging Perspective
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Chapter 7

Frequently Asked Questions (FAQ)

Below are some frequently asked questions in three areas, with associated answers.

7.1

7.2

OpenModelica General

Q: Why are not the MultiBody and Media libraries included in the OpenModelica distribution.

A: These libraries need special features in the Modelica language which are not yet implemented in
OpenModelica. We are working on it, but it will take some time.

Q: I did not find the graphic editor MathModelica Lite in the OpenModelica distribution. Where
can | find it?

A: You can download it via a link at the OpenModelica web site, e.g. the one placed under the
OpenModelica Environment heading, Graphic Editor bullet.

Q: OpenModelica 1.4.5 does not read the MODELICAPATH environment variable, even though
this is part of the Modelica Language Specification.

A: Use the OPENMODELICALIBRARY environment variable instead. We have temporarily
switched to this variable, in order not to interfere with other Modelica tools which might be
installed on the same system. In the future, we might switch to a solution with a settings file, that
also allows the user to turn on the MODELICAPATH functionality if desired.

Q: How do | enter multi-line models into OMShell since it evaluates when typing the Enter/Return
key?

A: There are basically three methods: 1) load the model from a file using the pull-down menu or the
loadModel command. 2) Enter the model/function as one (possibly long) line. 3) Type in the model
in another editor, where using multiple lines is no problem, and copy/paste the model into OMShell
as one operation, then push Enter. Another option is to use OMNotebook instead to enter and
evaluate models.

OMNotebook

Q: OMNotebook hangs, what to do?

A: It is probably waiting for the omc.exe (compiler) process. (Under windows): Kill the processes
omc.exe, g++.exe (C-compiler), as.exe (assembler), if present. If OMNotebook then asks whether
to restart OMC, answer yes. If not, kill the process OMNotebook.exe and restart manually.

Q: After a previous session, when starting OMNotebook again, | get a strange message.

A: You probably quit the previous OpenModelica session in the wrong way, which left the process
omc.exe running. Kill that process, and try starting OMNotebook again.
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7.3

Q: | copy and paste a graphic figure from Word or some other application into OMNotebook, but
the graphic does not appear. What is wrong?

A: OMNotebook supports the graphic picture formats supported by Qt 4, including the .png, .bmp
(bitmap) formats, but not for example the gif format. Try to convert your picture into one of the
supported formats, (e.g. in Word, first do paste as bitmap format), and then copy the converted
version into a text cell in OMNotebook.

Q: Plotting does not work in OMNotebook.

A: You probably have an old version of Java installed. Update your installation, and try again.
(Another known problem, soon to be fixed, is that plotting of parameters and constants does not yet
work).

Q: I select a cell, copy it (e.g. Ctrl-C), and try to paste it at another place in the notebook. However,
this does not work. Instead some other text that | earlier put on the clipboard is pasted into the
nearest text cell.

A: The problem is wrong choice of cursor mode, which can be text insertion or cell insertion. If you
click inside a cell, the cursor become vertical, and OMNotebook expects you to paste text inside the
cell. To paste a cell, you must be in cell insertion mode, i.e., click between two cells (or after a
cell), you will get a vertical line. Place the cursor carefully on that vertical line until you see a small
horizontal cursor. Then you should past the cell.

Q: Iam trying to click in cells to place the vertical character cursor, but it does not seem to react.

A: This seems to be a Qt feature. You have probably made a selection (e.g. for copying) in the
output section of an evaluation cell. This seems to block cursor position. Click again in the output
section to disable the selection. After that it will work normally.

Q: | have copied a text cell and start writing at the beginning of the cell. Strangely enough, the font
becomes much smaller than it should be.

A: This seems to be a Qt feature. Keep some of the old text and start writing the new stuff inside the

text, i.e., at least one character position to the right. Afterwards, delete the old text at the beginning
of the cell.

OMDev - OpenModelica Development Environment

Q: | get problems compiling and linking some files when using OMDev with the MINGW (Gnu) C
compiler under Windows.

A: You probably have some Logitech software installed. There is a known bug/incompatibility in
Logitech products. For example, if lvprcsrv.exe is running, kill it and/or prevent it to start again at
reboot; it does not do anything really useful, not needed for operation of web cameras or mice.
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Appendix A

Major OpenModelica Releases

This Appendix lists the most important OpenModelica releases and a brief description of their contents.
However, right now the versions from 1.3.1 to 1.4.5 are described.

A.1 OpenModelica 1.4.5, January 2009

This release has several improvements, especially platform availability, less compiler memory usage, and
supporting more aspects of Modelica 3.0.

A.1.1 OpenModelica Compiler (OMC)
This release includes small improvements and some bugfixes of the OpenModelica Compiler (OMC):

e Less memory consumption and better memory management over time. This also includes a better
API supporting automatic memory management when calling C functions from within the compiler.

e Modelica 3.0 parsing support.

e Export of DAE to XML and MATLAB.

e Support for several platforms Linux, MacOS, Windows (2000, Xp, Vista).

e Support for record and strings as function arguments.

e Many bug fixes.

e (Not part of OMC): Additional free graphic editor SimForge can be used with OpenModelica.

A.1.2 OpenModelica Notebook (OMNotebook)

A number of improvements, primarily in the plotting functionality and platform availability.
e A number of improvements in the plotting functionality: scalable plots, zooming, logarithmic plots,
grids, etc.
e Programmable plotting accessible through a Modelica API.
e Simple 3D visualization.
e Support for several platforms Linux, MacOS, Windows (2000, Xp, Vista).

A.1.3 OpenModelica Shell (OMShell)

Same as previously.

A.1.4 OpenModelica Eclipse Plug-in (MDT)

Minor bug fixes.

A.1.5 OpenModelica Development Environment (OMDev)

Same as previously.

A.2 OpenModelica 1.4.4, Feb 2008
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This release is primarily a bug fix release, except for a preliminary version of new plotting functionality
available both from the OMNotebook and separately through a Modelica API. This is also the first release
under the open source license OSMC-PL (Open Source Modelica Consortium Public License), with
support from the recently created Open Source Modelica Consortium. An integrated version handler, bug-,
and issue tracker has also been added.

A.2.1 OpenModelica Compiler (OMC)
This release includes small improvements and some bugfixes of the OpenModelica Compiler (OMC):

e Better support for if-equations, also inside when.

e Better support for calling functions in parameter expressions and interactively through dynamic
loading of functions.

e Less memory consumtion during compilation and interactive evaluation.
e A number of bug-fixes.

A.2.2 OpenModelica Notebook (OMNotebook)

Test release of improvements, primarily in the plotting functionality and platform availability.

e Preliminary version of improvements in the plotting functionality: scalable plots, zooming,
logarithmic plots, grids, etc., currently available in a preliminary version through the plot2 function.

e Programmable plotting accessible through a Modelica API.

A.2.3 OpenModelica Shell (OMShell)

Same as previously.

A.2.4 OpenModelica Eclipse Plug-in (MDT)

This release includes minor bugfixes of MDT and the associated MetaModelica debugger:

A.2.5 OpenModelica Development Environment (OMDev)

Extended test suite with a better structure. Version handling, bug tracking, issue tracking, etc. now
available under the integrated Codebeamer

A.3 OpenModelica 1.4.3, June 2007

This release has a number of significant improvements of the OMC compiler, OMNotebook, the MDT
plugin and the OMDev. Increased platform availability now also for Linux and Macintosh, in addition to
Windows. OMShell is the same as previously, but now ported to Linux and Mac.

A.3.1 OpenModelica Compiler (OMC)
This release includes a number of improvements of the OpenModelica Compiler (OMC):

¢ Significantly increased compilation speed, especially with large models and many packages.
¢ Now available also for Linux and Macintosh platforms.

e Support for when-equations in algorithm sections, including elsewhen.

e Support for inner/outer prefixes of components (but without type error checking).

e Improved solution of nonlinear systems.

e Added ability to compile generated simulation code using Visual Studio compiler.



85

Added "smart setting of fixed attribute to false. If initial equations, OMC instead has fixed=true as
default for states due to allowing overdetermined initial equation systems.

Better state select heuristics.

New function getlIncidenceMatrix(ClassName) for dumping the incidence matrix.

Builtin functions String(), product(), ndims(), implemented.

Support for terminate() and assert() in equations.

In emitted flat form: protected variables are now prefixed with protected when printing flat class.
Some support for tables, using omcTableTimelni instead of dymTableTimelni2.

Better support for empty arrays, and support for matrix operations like a*[1,2;3,4].

Improved val() function can now evaluate array elements and record fields, e.g. val(x[n]), val(x.y) .
Support for reinit in algorithm sections.

String support in external functions.

Double precision floating point precision now also for interpreted expressions

Better simulation error messages.

Support for der(expressions).

Support for iterator expressions such as {3*i for i in 1..10}.

More test cases in the test suite.

A number of bug fixes, including sample and event handling bugs.

A.3.2 OpenModelica Notebook (OMNotebook)

A number of improvements, primarily in the platform availability.

Available on the Linux and Macintosh platforms, in addition to Windows.
Fixed cell copying bugs, plotting of derivatives now works, etc.

A.3.3 OpenModelica Shell (OMShell)

Now available also on the Macintosh platform.

A.3.4 OpenModelica Eclipse Plug-in (MDT)

This release includes major improvements of MDT and the associated MetaModelica debugger:

Greatly improved browsing and code completion works both for standard Modelica and for
MetaModelica.

Hovering over identifiers displays type information.

A new and greatly improved implementation of the debugger for MetaModelica algorithmic code,
operational in Eclipse. Greatly improved performance — only approx 10% speed reduction even for
100 000 line programs. Greatly improved single stepping, step over, data structure browsing, etc.

Many bug fixes.

A.3.5 OpenModelica Development Environment (OMDev)

Increased compilation speed for MetaModelica. Better if-expression support in MetaModelica.

A.4 OpenModelica 1.4.2, October 2006

This release has improvements and bug fixes of the OMC compiler, OMNotebook, the MDT plugin and the
OMDev. OMShell is the same as previously.
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A.4.1 OpenModelica Compiler (OMC)

This release includes further improvements of the OpenModelica Compiler (OMC):
e Improved initialization and index reduction.
e Support for integer arrays is now largely implemented.

e The val(variable,time) scripting function for accessing the value of a simulation result variable at a
certain point in the simulated time.

e Interactive evalution of for-loops, while-loops, if-statements, if-expressions, in the interactive
scripting mode.

e Improved documentation and examples of calling the Model Query and Manipulation API.
e Many bug fixes.

A.4.2 OpenModelica Notebook (OMNotebook)

Search and replace functions have been added. The DrModelica tutorial (all files) has been updated,
obsolete sections removed, and models which are not supported by the current implementation marked
clearly. Automatic recognition of the .onb suffix (e.g. when double-clicking) in Windows makes it even
more convenient to use.

A.4.3 OpenModelica Eclipse Plug-in (MDT)
Two major improvements are added in this release:

e Browsing and code completion works both for standard Modelica and for MetaModelica.

e The debugger for algorithmic code is now available and operational in Eclipse for debugging of
MetaModelica programs.

A.4.4 OpenModelica Development Environment (OMDev)

Mostly the same as previously.

A.5 OpenModelica 1.4.1, June 2006

This release has only improvements and bug fixes of the OMC compiler, the MDT plugin and the OMDev
components. The OMShell and OMNotebook are the same.

A.5.1 OpenModelica Compiler (OMC)

This release includes further improvements of the OpenModelica Compiler (OMC):
e Support for external objects.
e OMC now reports the version number (via command line switches or CORBA API getVersion()).
¢ Implemented caching for faster instantiation of large models.
e Many bug fixes.

A.5.2 OpenModelica Eclipse Plug-in (MDT)

Improvements of the error reporting when building the OMC compiler. The errors are now added to the
problems view. The latest MDT release is version 0.6.6 (2006-06-06).

A.5.3 OpenModelica Development Environment (OMDev)
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Small fixes in the MetaModelica compiler. MetaModelica Users Guide is now part of the OMDev release.
The latest OMDev was release in 2006-06-06.

A.6 OpenModelica 1.4.0, May 2006

This release has a number of improvements described below. The most significant change is probably that
OMC has now been translated to an extended subset of Modelica (MetaModelica), and that all development
of the compiler is now done in this version..

A.6.1 OpenModelica Compiler (OMC)
This release includes further improvements of the OpenModelica Compiler (OMC):

e Partial support for mixed system of equations.

¢ New initialization routine, based on optimization (minimizing residuals of initial equations).

e Symbolic simplification of builtin operators for vectors and matrices.

e Improved code generation in simulation code to support e.g. Modelica functions.

e Support for classes extending basic types, e.g. connectors (support for MSL 2.2 block connectors).
e Support for parametric plotting via the plotParametric command.

¢ Many bug fixes.

A.6.2 OpenModelica Shell (OMShell)

Essentially the same OMShell as in 1.3.1. One difference is that now all error messages are sent to the
command window instead of to a separate log window.

A.6.3 OpenModelica Notebook (OMNotebook)

Many significant improvements and bug fixes. This version supports graphic plots within the cells in the
notebook. Improved cell handling and Modelica code syntax highlighting. Command completion of the
most common OMC commands is now supported. The notebook has been used in several courses.

A.6.4 OpenModelica Eclipse Plug-in (MDT)

This is the first really useful version of MDT. Full browsing of Modelica code, e.g. the MSL 2.2, is now
supported. (MetaModelica browsing is not yet fully supported). Full support for automatic indentation of
Modelica code, including the MetaModelica extensions. Many bug fixes. The Eclipse plug-in is now in use
for OpenModelica development at PELAB and MathCore Engineering AB since approximately one month.

A.6.5 OpenModelica Development Environment (OMDev)
The following mechanisms have been put in place to support OpenModelica development.
e A separate web page for OMDev (OpenModelica Development Environment).

e A pre-packaged OMDev zip-file with precompiled binaries for development under Windows using
the mingw Gnu compiler from the Eclipse MDT plug-in. (Development is also possible using
Visual Studio).

e All source code of the OpenModelica compiler has recently been translated to an extended subset of
Modelica, currently called MetaModelica. The current size of OMC is approximately 100 000 lines
All development is now done in this version.

e A new tutorial and users guide for development in MetaModelica.

e  Successful builds and tests of OMC under Linux and Solaris.
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A.7 OpenModelica 1.3.1, November 2005
This release has several important highlights.

This is also the first release for which the New BSD (Berkeley) open-source license applies to the source
code, including the whole compiler and run-time system. This makes is possible to use OpenModelica for
both academic and commercial purposes without restrictions.

A.7.1 OpenModelica Compiler (OMC)
This release includes a significantly improved OpenModelica Compiler (OMC):

e Support for hybrid and discrete-event simulation (if-equations, if-expressions, when-equations;
not yet if-statements and when-statements).

e Parsing of full Modelica 2.2
e Improved support for external functions.

e Vectorization of function arguments; each-modifiers, better implementation of replaceable, better
handling of structural parameters, better support for vector and array operations, and many other
improvements.

e Flattening of the Modelica Block library version 1.5 (except a few models), and simulation of most
of these.

e Automatic index reduction (present also in previous release).
e Updated User's Guide including examples of hybrid simulation and external functions.

A.7.2 OpenModelica Shell (OMShell)

An improved window-based interactive command shell, now including command completion and better
editing and font size support.

A.7.3 OpenModelica Notebook (OMNotebook)

A free implementation of an OpenModelica notebook (OMNOtebook), for electronic books with course
material, including the DrModelica interactive course material. It is possible to simulate and plot from this
notebook.

A.7.4 OpenModelica Eclipse Plug-in (MDT)

An early alpha version of the first Eclipse plug-in (called MDT for Modelica Development Tooling) for
Modelica Development. This version gives compilation support and partial support for browsing Modelica
package hierarchies and classes.

A.7.5 OpenModelica Development Environment (OMDev)
The following mechanisms have been put in place to support OpenModelica development.

e Bugzilla support for OpenModelica bug tracking, accessible to anybody.

e A system for automatic regression testing of the compiler and simulator, (+ other system parts)
usually run at check in time.

e Version handling is done using SVN, which is better than the previously used CVS system. For
example, name change of modules is now possible within the version handling system.
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Appendix B

Contributors to OpenModelica

This Appendix lists the individuals who have made significant contributions to OpenModelica, in the form
of software development, design, documentation, project leadership, tutorial material, promotion, etc. The
individuals are listed for each year, from 1998 to the current year: the project leader and main author/editor
of this document followed by main contributors followed by contributors in alphabetical order.

B.1 OpenModelica Contributors 2009
Peter Fritzson, PELAB, Linképing University, Linkping, Sweden.

Adrian Pop, PELAB, Linkdping University, Linkdping, Sweden.
Peter Aronsson, MathCore Engineering AB, Linkdping, Sweden.

David Akhvlediani, PELAB, Linkoping University, Linkdping, Sweden.
Bernhard Bachmann, Fachhochschule Bielefeld, Bielefeld, Germany.
Vasile Baluta, PELAB, Linkdping University, Linkdping, Sweden.
Constantin Belyaev, Bashpromavtomatika Ltd., Ufa, Russia

Simon Bjorklén, PELAB, Linkoping University, Link6ping, Sweden.
Mikael Blom, PELAB, Linkdéping University, Linképing, Sweden.
David Broman, PELAB, Linkdping University, Linkdping, Sweden.
Francesco Casella, Politecnico di Milano, Milan, Italy

Filippo Donida, Politecnico di Milano, Milan, Italy

Henrik Eriksson, PELAB, Linkoping University, Linkdping, Sweden.
Anders Fernstrdm, PELAB, Linkdping University, Linkdping, Sweden.
Pavel Grozman, Equa AB, Stockholm, Sweden.

Michael Hanke, NADA, KTH, Stockholm

Daniel Hedberg, MathCore Engineering AB, Linkdping, Sweden.

Alf Isaksson, ABB Corporate Research, Vasteras, Sweden

Kim Jansson, PELAB, Link&ping University, Linképing, Sweden.
Daniel Kanth, Bosch-Rexroth, Lohr am Main, Germany

Joel Klinghed, PELAB, Linkoping University, Link6ping, Sweden.
Juha Kortelainen, VTT, Espoo, Finland

Alexey Lebedev, Equa Simulation AB, Stockholm, Sweden

Magnus Leksell, Linkdping, Sweden

Oliver Lenord, Bosch-Rexroth, Lohr am Main, Germany

Hékan Lundvall, PELAB, Linkoping University, Linképing, Sweden.
Henrik Magnusson, Linképing, Sweden

Eric Meyers, Pratt & Whitney Rocketdyne, Palm City, Florida, USA.
Hannu Niemistd, VTT, Espoo, Finland

Kristoffer Norling, PELAB, Linkdping University, Linkdping, Sweden.
Per Sahlin, Equa Simulation AB, Stockholm, Sweden

Gerhard Schmitz, University of Hamburg, Hamburg, Germany

Klas Sjoholm, PELAB, Linkdping University, Linkdping, Sweden.
Kristian Stavaker, PELAB, Linkoping University, Linkoping, Sweden.
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Niklas Worschech, Bosch-Rexroth, Lohr am Main, Germany
Robert Wotzlaw, Goettingen, Germany
Bjorn Zachrisson, MathCore Engineering AB, Linkdping, Sweden

B.2 OpenModelica Contributors 2008
Peter Fritzson, PELAB, Linképing University, Linkdping, Sweden.

Adrian Pop, PELAB, Linkdping University, Linkdping, Sweden.
Peter Aronsson, MathCore Engineering AB, Link&ping, Sweden.

David Akhvlediani, PELAB, Linkoping University, Linkping, Sweden.
Bernhard Bachmann, Fachhochschule Bielefeld, Bielefeld, Germany.
Vasile Baluta, PELAB, Link6ping University, Linkdping, Sweden.
Mikael Blom, PELAB, Linkdping University, Linkdping, Sweden.
David Broman, PELAB, Linkdping University, Linkdping, Sweden.
Henrik Eriksson, PELAB, Link6ping University, Linkdping, Sweden.
Anders Fernstrom, PELAB, Linkdping University, Linkdping, Sweden.
Pavel Grozman, Equa AB, Stockholm, Sweden.

Daniel Hedberg, MathCore Engineering AB, Linkdping, Sweden.

Kim Jansson, PELAB, Linkdping University, Linkdping, Sweden.

Joel Klinghed, PELAB, Linkdping University, Linkdping, Sweden.
Hékan Lundvall, PELAB, Linkoping University, Linképing, Sweden.
Eric Meyers, Pratt & Whitney Rocketdyne, Palm City, Florida, USA.
Kristoffer Norling, PELAB, Linkdping University, Linkdping, Sweden.
Anders Sandholm, PELAB, Link6ping University, Link6ping, Sweden.
Klas Sjoholm, PELAB, Linkdping University, Linkdping, Sweden.
Kristian Stavaker, PELAB, Linkoping University, LinkGping, Sweden.
Simon Bjorklén, PELAB, Link6ping University, Link6ping, Sweden.
Constantin Belyaev, Bashpromavtomatika Ltd., Ufa, Russia

B.3 OpenModelica Contributors 2007
Peter Fritzson, PELAB, Linkoping University, Linkdping, Sweden.

Adrian Pop, PELAB, Linkdping University, Linkdping, Sweden.
Peter Aronsson, MathCore Engineering AB, Linkdping, Sweden.

David Akhvlediani, PELAB, Linkoping University, Linkping, Sweden.
Bernhard Bachmann, Fachhochschule Bielefeld, Bielefeld, Germany.
David Broman, PELAB, Linkdping University, Linkdping, Sweden.
Henrik Eriksson, PELAB, Linkoping University, Linkdping, Sweden.
Anders Fernstrdm, PELAB, Linkdping University, Linkdping, Sweden.
Pavel Grozman, Equa AB, Stockholm, Sweden.

Daniel Hedberg, MathCore Engineering AB, Linkdping, Sweden.

Ola Leifler, IDA, Link6ping University, Linképing, Sweden.

Hékan Lundvall, PELAB, Linkoping University, Linképing, Sweden.
Eric Meyers, Pratt & Whitney Rocketdyne, Palm City, Florida, USA.
Kristoffer Norling, PELAB, Linkdping University, Linképing, Sweden.
Anders Sandholm, PELAB, Linkdping University, Linkdping, Sweden.
Klas Sjoholm, PELAB, Linkdping University, Linkdping, Sweden.
William Spinelli, Politecnico di Milano, Milano, Italy

Kristian Stavaker, PELAB, Linkoping University, Link6ping, Sweden.
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Stefan Vorkoetter, MapleSoft, Waterloo, Canada.
Bjorn Zachrisson, MathCore Engineering AB, Link&ping, Sweden.
Constantin Belyaev, Bashpromavtomatika Ltd., Ufa, Russia

B.4 OpenModelica Contributors 2006
Peter Fritzson, PELAB, Linképing University, Linkdping, Sweden.

Peter Aronsson, MathCore Engineering AB, Linkdping, Sweden.
Adrian Pop, PELAB, Linkdping University, Linkoping, Sweden.
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Kaj Nystrom, PELAB, Linkdping University, Linkdping, Sweden.
Lucian Popescu, MathCore Engineering AB, Linkdping, Sweden.
Andreas Remar, PELAB, Linkdping University, Linkdping, Sweden.
Anders Sandholm, PELAB, Link6ping University, Link6ping, Sweden.

B.5 OpenModelica Contributors 2005
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B.7 OpenModelica Contributors 2003
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Erik Svensson, MathCore Engineering AB, Linkdping, Sweden.

B.8 OpenModelica Contributors 2002
Peter Fritzson, PELAB, Linkdping University, Linkdping, Sweden.

Levon Saldamli, PELAB, Linkdping University, Linképing, Sweden.
Peter Aronsson, Linkdping University, Linkdping, Sweden.

Daniel Hedberg, Linkoping University, Linkdping, Sweden.
Henrik Johansson, PELAB, Linkdping University, Linkdping, Sweden
Andreas Karstrom, PELAB, Linkdping University, Linkdping, Sweden

B.9 OpenModelica Contributors 2001
Peter Fritzson, PELAB, Linkdping University, Linkdping, Sweden.
Levon Saldamli, PELAB, Linkdping University, Linkdping, Sweden.

Peter Aronsson, Linkdping University, Linkdping, Sweden.

B.10 OpenModelica Contributors 2000
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